summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-09-30 23:17:51 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-10-06 13:23:41 +0200
commit38e87ca70fd35a55867b669e9d14021fde99996b (patch)
treeb922ef3c69f607549b275a1c88d1635cf975530d /sys-apps/thunderbolt-software-user-space
parentsys-apps/thunderbolt-software-user-space: Drop 0.9.2 (diff)
downloadgentoo-38e87ca70fd35a55867b669e9d14021fde99996b.tar.gz
gentoo-38e87ca70fd35a55867b669e9d14021fde99996b.tar.bz2
gentoo-38e87ca70fd35a55867b669e9d14021fde99996b.zip
sys-apps/thunderbolt-software-user-space: EAPI-7 bump, fix DEPENDs
Add missing dev-libs/boost slot operator. app-text/txt2tags is not needed at runtime. Fix typo. Bug: https://bugs.gentoo.org/648312 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-apps/thunderbolt-software-user-space')
-rw-r--r--sys-apps/thunderbolt-software-user-space/thunderbolt-software-user-space-0.9.3-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-apps/thunderbolt-software-user-space/thunderbolt-software-user-space-0.9.3-r1.ebuild b/sys-apps/thunderbolt-software-user-space/thunderbolt-software-user-space-0.9.3-r1.ebuild
new file mode 100644
index 000000000000..5d97235c7c4a
--- /dev/null
+++ b/sys-apps/thunderbolt-software-user-space/thunderbolt-software-user-space-0.9.3-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils linux-info
+
+DESCRIPTION="Thunderbolt(TM) user-space components"
+HOMEPAGE="https://github.com/intel/thunderbolt-software-user-space"
+SRC_URI="https://github.com/intel/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="app-text/txt2tags"
+DEPEND="dev-libs/boost:="
+RDEPEND="${DEPEND}"
+
+pkg_pretend() {
+ CONFIG_CHECK="THUNDERBOLT"
+ ERROR_THUNDERBOLT="This program talks to the thunderbolt kernel driver, so please enable it."
+ CONFIG_CHECK="HOTPLUG_PCI"
+ ERROR_HOTPLUG_PCI="Thunderbolt needs pci hotplug support, so please enable it."
+ check_extra_config
+}