summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-08 03:19:33 +0000
committerSam James <sam@gentoo.org>2023-02-08 03:19:46 +0000
commit7ee34ba33700f03beba8eb436f5afc697b61ed63 (patch)
treeef3024e7ed5c92c5a1f7e9d000a2ff4d9a43a739 /sys-apps/toybox/toybox-9999.ebuild
parentdev-python/docutils: fix tests w/ pygments-2.14.0 (diff)
downloadgentoo-7ee34ba33700f03beba8eb436f5afc697b61ed63.tar.gz
gentoo-7ee34ba33700f03beba8eb436f5afc697b61ed63.tar.bz2
gentoo-7ee34ba33700f03beba8eb436f5afc697b61ed63.zip
sys-apps/toybox: add 0.8.9
Closes: https://bugs.gentoo.org/874825 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/toybox/toybox-9999.ebuild')
-rw-r--r--sys-apps/toybox/toybox-9999.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/sys-apps/toybox/toybox-9999.ebuild b/sys-apps/toybox/toybox-9999.ebuild
index 888ca615d7a4..d890b64c89af 100644
--- a/sys-apps/toybox/toybox-9999.ebuild
+++ b/sys-apps/toybox/toybox-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit multiprocessing savedconfig toolchain-funcs
@@ -10,7 +10,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/landley/toybox.git"
else
SRC_URI="https://landley.net/code/toybox/downloads/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~arm64 ~x86"
fi
DESCRIPTION="Common linux commands in a multicall binary"
@@ -22,6 +22,10 @@ SLOT="0"
DEPEND="virtual/libcrypt:="
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${P}-verbose-build-fix.patch
+)
+
src_prepare() {
default
restore_config .config
@@ -45,14 +49,14 @@ src_configure() {
src_compile() {
unset CROSS_COMPILE
export CPUS=$(makeopts_jobs)
- emake V=1
+ emake V=1 NOSTRIP=1
}
src_test() {
- emake test
+ emake V=1 test
}
src_install() {
save_config .config
- newbin generated/unstripped/toybox toybox
+ dobin toybox
}