summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2016-07-26 14:23:00 +0800
committerYixun Lan <dlan@gentoo.org>2016-07-26 14:23:00 +0800
commitcdaadf65e31a8b72908898fd9ee1da7108fdcc42 (patch)
treeb098bf6d287c216fad65584d5ee3803987baca43 /sys-apps/tuned/tuned-2.7.0.ebuild
parentsys-process/criu: version bump 2.4 (diff)
downloadgentoo-cdaadf65e31a8b72908898fd9ee1da7108fdcc42.tar.gz
gentoo-cdaadf65e31a8b72908898fd9ee1da7108fdcc42.tar.bz2
gentoo-cdaadf65e31a8b72908898fd9ee1da7108fdcc42.zip
sys-apps/tuned: version bump 2.7.0
Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-apps/tuned/tuned-2.7.0.ebuild')
-rw-r--r--sys-apps/tuned/tuned-2.7.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-apps/tuned/tuned-2.7.0.ebuild b/sys-apps/tuned/tuned-2.7.0.ebuild
new file mode 100644
index 000000000000..33e00738fd12
--- /dev/null
+++ b/sys-apps/tuned/tuned-2.7.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 systemd
+
+DESCRIPTION="Daemon for monitoring and adaptive tuning of system devices"
+HOMEPAGE="https://fedorahosted.org/tuned/"
+SRC_URI="https://fedorahosted.org/releases/t/u/tuned/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/pyudev[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/dbus
+ sys-power/powertop
+ dev-util/systemtap
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-upstream.patch
+
+ sed -i \
+ -e "/^UNITDIR = /s:\$(shell rpm --eval '%{_unitdir}'):$(systemd_get_unitdir):" \
+ -e "/\$(DESTDIR)\/run\/tuned/d" \
+ Makefile ||die
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}"/tuned.initd tuned
+
+ python_fix_shebang "${ED}"
+}