summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/ucspi-proxy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/ucspi-proxy')
-rw-r--r--sys-apps/ucspi-proxy/Manifest3
-rw-r--r--sys-apps/ucspi-proxy/metadata.xml9
-rw-r--r--sys-apps/ucspi-proxy/ucspi-proxy-0.97.ebuild30
-rw-r--r--sys-apps/ucspi-proxy/ucspi-proxy-0.98.ebuild37
-rw-r--r--sys-apps/ucspi-proxy/ucspi-proxy-0.99.ebuild32
5 files changed, 111 insertions, 0 deletions
diff --git a/sys-apps/ucspi-proxy/Manifest b/sys-apps/ucspi-proxy/Manifest
new file mode 100644
index 000000000000..5195bf9c1465
--- /dev/null
+++ b/sys-apps/ucspi-proxy/Manifest
@@ -0,0 +1,3 @@
+DIST ucspi-proxy-0.97.tar.gz 26717 SHA256 14f76fc17b63143245b6a6af86d0d2159c7552e89da40009cccab397cdf8a93b
+DIST ucspi-proxy-0.98.tar.gz 35278 SHA256 bcdae7bc9443f1410b53808839c5af4ce41a398ef17a32287a76749f052f54d2 SHA512 db767fd19825753107965a3f8a7e8c588e053fb911b3cbe1060684e6100244f9ce720f73e97bdfb26a3af00f6dda2a011866f7e5008ff7edca71b0fe3319da1b WHIRLPOOL 8adc0d4a5ded66cc4aaceb6e98563b6dff8ae126add1b03e078da9d5463a9ba5d9529f7039e75527f46e1996c3920c7f5711b32b94e0ced5d0ef277d12f53f56
+DIST ucspi-proxy-0.99.tar.gz 35537 SHA256 42943e978f51875e587567c552d349e058b983723c0d80756d1816e3ad560beb SHA512 5bed82bd0db2501c3de8b38e23a07c39bf9937b9ce95166cf1822a6bd5551aec945dc01d6ba716d7ce35f4aa7f2a126d860d31f7df2d807f1f4eb5e355e93164 WHIRLPOOL 983cb72b72a1dba1b221a54f0bc314b8a016d3a3fea94b2e9996903d87b223b93b417bf306ba6a9fe418b08fa1c7fab743e63a5ae75712c9685b90e5f4d4dfd3
diff --git a/sys-apps/ucspi-proxy/metadata.xml b/sys-apps/ucspi-proxy/metadata.xml
new file mode 100644
index 000000000000..2b14dbd77d85
--- /dev/null
+++ b/sys-apps/ucspi-proxy/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+<longdescription lang="en">
+This package contains a proxy program that passes data back and forth
+between two connections set up by a UCSPI server and a UCSPI client.
+</longdescription>
+</pkgmetadata>
diff --git a/sys-apps/ucspi-proxy/ucspi-proxy-0.97.ebuild b/sys-apps/ucspi-proxy/ucspi-proxy-0.97.ebuild
new file mode 100644
index 000000000000..145443c6b172
--- /dev/null
+++ b/sys-apps/ucspi-proxy/ucspi-proxy-0.97.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="A proxy program for two connections set up by a UCSPI server and a UCSPI client"
+HOMEPAGE="http://untroubled.org/ucspi-proxy/"
+SRC_URI="${HOMEPAGE}archive/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+DEPEND=">=dev-libs/bglibs-1.025"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+ echo "${D}/usr/bin" > conf-bin
+ echo "${D}/usr/share/man/" > conf-man
+ echo "/usr/include/bglibs/" > conf-bgincs
+ echo "/usr/lib/bglibs/" > conf-bglibs
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc ANNOUNCEMENT NEWS README TODO
+}
diff --git a/sys-apps/ucspi-proxy/ucspi-proxy-0.98.ebuild b/sys-apps/ucspi-proxy/ucspi-proxy-0.98.ebuild
new file mode 100644
index 000000000000..294ee53df0ec
--- /dev/null
+++ b/sys-apps/ucspi-proxy/ucspi-proxy-0.98.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit toolchain-funcs multilib
+
+DESCRIPTION="proxy program for two connections set up by a UCSPI server and a UCSPI client"
+HOMEPAGE="http://untroubled.org/ucspi-proxy/"
+SRC_URI="http://untroubled.org/ucspi-proxy/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/bglibs-1.106"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e '/^>bin$/ac:::755::ucspi-proxy' INSTHIER
+}
+
+src_configure() {
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+ echo "${D}/usr/bin" > conf-bin
+ echo "${D}/usr/share/man" > conf-man
+ echo "/usr/include/bglibs" > conf-bgincs
+ echo "/usr/$(get_libdir)/bglibs" > conf-bglibs
+}
+
+src_install() {
+ einstall || die
+ dodoc ANNOUNCEMENT NEWS README TODO
+}
diff --git a/sys-apps/ucspi-proxy/ucspi-proxy-0.99.ebuild b/sys-apps/ucspi-proxy/ucspi-proxy-0.99.ebuild
new file mode 100644
index 000000000000..846228186593
--- /dev/null
+++ b/sys-apps/ucspi-proxy/ucspi-proxy-0.99.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs multilib
+
+DESCRIPTION="proxy program for two connections set up by a UCSPI server and a UCSPI client"
+HOMEPAGE="http://untroubled.org/ucspi-proxy/"
+SRC_URI="http://untroubled.org/ucspi-proxy/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/bglibs-1.106"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e '/^>bin$/ac:::755::ucspi-proxy' INSTHIER
+}
+
+src_configure() {
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+ echo "${D}/usr/bin" > conf-bin
+ echo "${D}/usr/share/man" > conf-man
+ echo "/usr/include/bglibs" > conf-bgincs
+ echo "/usr/$(get_libdir)/bglibs" > conf-bglibs
+}