summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/udevil/udevil-0.4.4-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/udevil/udevil-0.4.4-r1.ebuild')
-rw-r--r--sys-apps/udevil/udevil-0.4.4-r1.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/sys-apps/udevil/udevil-0.4.4-r1.ebuild b/sys-apps/udevil/udevil-0.4.4-r1.ebuild
new file mode 100644
index 000000000000..50e6751d3fee
--- /dev/null
+++ b/sys-apps/udevil/udevil-0.4.4-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools user
+
+DESCRIPTION="mount and unmount removable devices without a password"
+HOMEPAGE="http://ignorantguru.github.com/udevil/"
+SRC_URI="https://github.com/IgnorantGuru/udevil/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-shells/bash-4.0:*
+ dev-libs/glib:2
+ sys-apps/util-linux
+ virtual/acl
+ >=virtual/udev-143"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup(){
+ enewgroup plugdev
+}
+
+src_prepare() {
+ # This works for 0.4.4 too, no sense copying the patch
+ epatch "${FILESDIR}"/${PN}-0.4.3-flags.patch
+ epatch "${FILESDIR}"/${P}-stat.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-setfacl-prog="$(type -P setfacl)" \
+ --enable-systemd
+}
+
+src_install() {
+ default
+ fowners root:plugdev /usr/bin/udevil
+ fperms 4754 /usr/bin/udevil
+}
+
+pkg_postinst() {
+ einfo
+ elog "Please add your user to the plugdev group"
+ elog "to be able to use ${PN} as a user"
+ elog
+ elog "Optional dependencies:"
+ elog " gnome-extra/zenity (devmon popups)"
+ elog " net-fs/davfs2 (mount WebDAV resources)"
+ elog " net-fs/cifs-utils (mounting samba shares)"
+ elog " net-fs/curlftpfs (mounting ftp shares)"
+ elog " net-fs/nfs-utils (mounting nfs shares)"
+ elog " sys-fs/sshfs-fuse (mounting sftp shares)"
+ elog " virtual/eject (eject via devmon)"
+ if ! has_version 'sys-fs/udisks' ; then
+ elog
+ elog "When using ${PN} without udisks, and without the udisks-daemon running,"
+ elog "you may need to enable kernel polling for device media changes to be detected."
+ elog "See http://ignorantguru.github.com/${PN}/#polling"
+ has_version '<virtual/udev-173' && ewarn "You need at least udev-173"
+ kernel_is lt 2 6 38 && ewarn "You need at least kernel 2.6.38"
+ einfo
+ fi
+}