summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2021-01-15 14:51:25 -0600
committerBen Kohler <bkohler@gentoo.org>2021-01-15 14:51:25 -0600
commit3b4b017b8db2de84936f692b809e79ae0b109fc3 (patch)
tree419de116f1bb36c4f04d776517f8dd317c675062 /sys-apps/udevil
parentmedia-gfx/iscan: fix build due to `bool` mismatch (diff)
downloadgentoo-3b4b017b8db2de84936f692b809e79ae0b109fc3.tar.gz
gentoo-3b4b017b8db2de84936f692b809e79ae0b109fc3.tar.bz2
gentoo-3b4b017b8db2de84936f692b809e79ae0b109fc3.zip
sys-apps/udevil: drop libtool
Thanks to Ørjan Malde (red@foxi.me) for patch Closes: https://github.com/gentoo/gentoo/pull/19062 Closes: https://bugs.gentoo.org/765568 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'sys-apps/udevil')
-rw-r--r--sys-apps/udevil/files/udevil-0.4.4-no-libtool.patch10
-rw-r--r--sys-apps/udevil/udevil-0.4.4-r4.ebuild76
2 files changed, 86 insertions, 0 deletions
diff --git a/sys-apps/udevil/files/udevil-0.4.4-no-libtool.patch b/sys-apps/udevil/files/udevil-0.4.4-no-libtool.patch
new file mode 100644
index 000000000000..ba01e94f15f7
--- /dev/null
+++ b/sys-apps/udevil/files/udevil-0.4.4-no-libtool.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -11,7 +11,6 @@ AM_MAINTAINER_MODE
+ AC_ISC_POSIX
+ AM_PROG_CC_C_O
+ AC_HEADER_STDC
+-AM_PROG_LIBTOOL
+ AC_PROG_INSTALL
+
+ AC_DEFINE_UNQUOTED(UDEVIL_VERSION, "$VERSION", [udevil version])
diff --git a/sys-apps/udevil/udevil-0.4.4-r4.ebuild b/sys-apps/udevil/udevil-0.4.4-r4.ebuild
new file mode 100644
index 000000000000..c65d66c45e09
--- /dev/null
+++ b/sys-apps/udevil/udevil-0.4.4-r4.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="mount and unmount removable devices without a password"
+HOMEPAGE="https://ignorantguru.github.com/udevil/"
+SRC_URI="https://github.com/IgnorantGuru/udevil/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ acct-group/plugdev
+ >=app-shells/bash-4.0:*
+ dev-libs/glib:2
+ sys-apps/util-linux
+ virtual/acl
+ >=virtual/udev-143"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+PATCHES=(
+ # This works for 0.4.4 too, no sense copying the patch
+ "${FILESDIR}"/${PN}-0.4.3-flags.patch
+ "${FILESDIR}"/${PN}-0.4.4-stat.patch
+ "${FILESDIR}"/${PN}-0.4.4-include-sysmacros.patch
+ "${FILESDIR}"/${PN}-0.4.4-no-libtool.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-setfacl-prog="$(type -P setfacl)" \
+ --enable-systemd
+}
+
+src_install() {
+ default
+ fowners root:plugdev /usr/bin/udevil
+ fperms 4754 /usr/bin/udevil
+}
+
+pkg_postinst() {
+ einfo
+ elog "Please add your user to the plugdev group"
+ elog "to be able to use ${PN} as a user"
+ elog
+ elog "Optional dependencies:"
+ elog " gnome-extra/zenity (devmon popups)"
+ elog " net-fs/davfs2 (mount WebDAV resources)"
+ elog " net-fs/cifs-utils (mounting samba shares)"
+ elog " net-fs/curlftpfs (mounting ftp shares)"
+ elog " net-fs/nfs-utils (mounting nfs shares)"
+ elog " net-fs/sshfs (mounting sftp shares)"
+ elog " virtual/eject (eject via devmon)"
+ if ! has_version 'sys-fs/udisks' ; then
+ elog
+ elog "When using ${PN} without udisks, and without the udisks-daemon running,"
+ elog "you may need to enable kernel polling for device media changes to be detected."
+ elog "See https://ignorantguru.github.com/${PN}/#polling"
+ has_version '<virtual/udev-173' && ewarn "You need at least udev-173"
+ kernel_is lt 2 6 38 && ewarn "You need at least kernel 2.6.38"
+ einfo
+ fi
+}