summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-05-16 08:17:03 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-05-16 08:17:03 +0200
commit336d92bbfee20a0031bd09677eaf9764ccedb0f6 (patch)
treee4fe7d709e5288d439f12c32fe35943bddc392af /sys-apps/usbutils
parentwww-apache/passenger: cleanup (diff)
downloadgentoo-336d92bbfee20a0031bd09677eaf9764ccedb0f6.tar.gz
gentoo-336d92bbfee20a0031bd09677eaf9764ccedb0f6.tar.bz2
gentoo-336d92bbfee20a0031bd09677eaf9764ccedb0f6.zip
sys-apps/usbutils: Bump to version 010
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'sys-apps/usbutils')
-rw-r--r--sys-apps/usbutils/Manifest1
-rw-r--r--sys-apps/usbutils/usbutils-010.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/sys-apps/usbutils/Manifest b/sys-apps/usbutils/Manifest
index 791681db19e1..56036a34bf8b 100644
--- a/sys-apps/usbutils/Manifest
+++ b/sys-apps/usbutils/Manifest
@@ -1,2 +1,3 @@
DIST usbutils-008.tar.xz 287052 BLAKE2B eb9b998adb69938d004828585f782840e34f453327de54a32c563268db22a870fd7298cf839692e58ae42148e63037260e09bc2f1d5700ff96bcc451aff626ba SHA512 ab1ad36467ff79ff5ab0b924620001612cae44def58c05ade01a4e58d8a4d48df61c09faba49a20497b7d6314045bbaf137b51a9f4e6b65ed0ea3bb339bf1c45
DIST usbutils-009.tar.xz 309608 BLAKE2B bb5d7f756241377e81aa8f5b074bb0ba36bc778698afaebf7054cdb153149e4f3808a7b172019434756cae8b33410643cd6a03a36277f80ead9b0f4446385fd9 SHA512 e5936a42615690c13e618655fc5eb4f414d9a84f85b860eaeb3bcf737258e05d299b09d1c5388d50c718626036ec8cac5d670ad567ceadfaab85f401f0744a8a
+DIST usbutils-010.tar.xz 308344 BLAKE2B 5f0ba85564acaf60faad0e187e7ed5c870056cf80a1e1ae888fa498429a7a9e28eaced49047f8f793bad3c59f3b515557054860286b17d9f89f915d0db5943cc SHA512 8bc197307bc34b38c406c58c939be32f0b20ce9d3e7c977472fe4c3d47e791765432e381fd8d7393df621bbd4bf159ca24a08b22441770e7ae464e767f99a2e3
diff --git a/sys-apps/usbutils/usbutils-010.ebuild b/sys-apps/usbutils/usbutils-010.ebuild
new file mode 100644
index 000000000000..6f049d0533bf
--- /dev/null
+++ b/sys-apps/usbutils/usbutils-010.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="USB enumeration utilities"
+HOMEPAGE="https://www.kernel.org/pub/linux/utils/usb/usbutils/
+ https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/usbutils.git/"
+SRC_URI="mirror://kernel/linux/utils/usb/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+CDEPEND="virtual/libusb:1=
+ virtual/libudev:="
+DEPEND="${CDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ sys-apps/hwids
+ python? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ use python && python_fix_shebang lsusb.py.in
+}
+
+src_configure() {
+ local myeconfargs=(
+ --datarootdir="${EPREFIX}/usr/share"
+ --datadir="${EPREFIX}/usr/share/misc"
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ newdoc usbhid-dump/NEWS NEWS.usbhid-dump
+
+ use python || rm -f "${ED%/}"/usr/bin/lsusb.py
+}