summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-06-29 14:33:05 +0200
committerDavid Seifert <soap@gentoo.org>2020-06-29 14:33:05 +0200
commitdb365bacbc0122deac04a5add301d2d86c505aab (patch)
treee8bafe1e663fac582103bb7179e83299aa53cb81 /sys-apps/x86info/files
parentsys-apps/x86info: [QA] Fix various issues (diff)
downloadgentoo-db365bacbc0122deac04a5add301d2d86c505aab.tar.gz
gentoo-db365bacbc0122deac04a5add301d2d86c505aab.tar.bz2
gentoo-db365bacbc0122deac04a5add301d2d86c505aab.zip
sys-apps/x86info: Remove old
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-apps/x86info/files')
-rw-r--r--sys-apps/x86info/files/1.21-pic.patch14
-rw-r--r--sys-apps/x86info/files/x86info-1.24-pic.patch33
-rw-r--r--sys-apps/x86info/files/x86info-1.29-parallel-make-cleanup.patch12
-rw-r--r--sys-apps/x86info/files/x86info-1.30-fix-build-system.patch12
4 files changed, 0 insertions, 71 deletions
diff --git a/sys-apps/x86info/files/1.21-pic.patch b/sys-apps/x86info/files/1.21-pic.patch
deleted file mode 100644
index 7bf89240c2c0..000000000000
--- a/sys-apps/x86info/files/1.21-pic.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/bench/benchmarks.c
-+++ b/bench/benchmarks.c
-@@ -19,7 +19,10 @@
- #ifdef __linux__
- TIME(asm volatile("int $0x80" :"=a" (tmp) :"0" (__NR_getppid)), "int 0x80");
- #endif
-- TIME(asm volatile("cpuid": : :"ax", "dx", "cx", "bx"), "cpuid");
-+ TIME(asm volatile("movl %%ebx,%%edi\n"
-+ "cpuid\n"
-+ "movl %%edi,%%ebx\n"
-+ : : :"%eax", "%edx", "%ecx", "%edi"), "cpuid");
-
- TIME(asm volatile("addl $1,0(%esp)"), "addl");
- TIME(asm volatile("lock ; addl $1,0(%esp)"), "locked add");
diff --git a/sys-apps/x86info/files/x86info-1.24-pic.patch b/sys-apps/x86info/files/x86info-1.24-pic.patch
deleted file mode 100644
index b4098c5c68c2..000000000000
--- a/sys-apps/x86info/files/x86info-1.24-pic.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-http://bugs.gentoo.org/270388
-
---- a/cpuid.c
-+++ b/cpuid.c
-@@ -62,12 +62,28 @@
- sched_setaffinity(getpid(), sizeof(set), &set);
- }
-
-+#ifdef __PIC__
-+ /* GCC on i386 bitches if you clobber ebx. So hide it behind
-+ * gcc's back. */
-+ asm(
-+ "movl %%ebx,%%edi\n"
-+ "cpuid\n"
-+ "movl %%ebx,%1\n"
-+ "movl %%edi,%%ebx\n"
-+ : "=a" (a),
-+ "=m" (b),
-+ "+c" (c),
-+ "=d" (d)
-+ : "0" ((unsigned int)idx)
-+ : "edi");
-+#else
- asm("cpuid"
- : "=a" (a),
- "=b" (b),
- "+c" (c),
- "=d" (d)
- : "0" ((unsigned int)idx));
-+#endif
-
- if (eax!=NULL)
- *eax = a;
diff --git a/sys-apps/x86info/files/x86info-1.29-parallel-make-cleanup.patch b/sys-apps/x86info/files/x86info-1.29-parallel-make-cleanup.patch
deleted file mode 100644
index a9cec0397fac..000000000000
--- a/sys-apps/x86info/files/x86info-1.29-parallel-make-cleanup.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -12,7 +12,8 @@
- LSMSR_TMP_HEADERS=AMD/k8.h AMD/fam10h.h AMD/fam11h.h generic_msr.h
-
- %.h: %.regs scripts/createheader.py
-- python scripts/createheader.py $< `basename $< .regs` >$@
-+ $(PYTHON) scripts/createheader.py $< `basename $< .regs` >$@.tmp ; \
-+ mv $@.tmp $@
-
- LSMSR_SRC = \
- lsmsr.c \
diff --git a/sys-apps/x86info/files/x86info-1.30-fix-build-system.patch b/sys-apps/x86info/files/x86info-1.30-fix-build-system.patch
deleted file mode 100644
index 21034d99edc5..000000000000
--- a/sys-apps/x86info/files/x86info-1.30-fix-build-system.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -1,9 +1,5 @@
- VERSION=1.30
-
--CFLAGS = -g -O2 -Werror -Wall -Wshadow -Wextra -Wmissing-declarations -Wdeclaration-after-statement -Wredundant-decls
--LDFLAGS = -Wl,-z,relro,-z,now
--CC = gcc
--
- SHELL = /bin/sh
-
- all: x86info test lsmsr