summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-25 18:00:34 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-25 18:05:25 +0100
commit277c9e630192d6ef58827b879d025dd613f22258 (patch)
tree478800fb5d5072620b1979df9a242b0702e41ea8 /sys-apps/xdg-desktop-portal
parentsys-fs/udev: 241 bump (diff)
downloadgentoo-277c9e630192d6ef58827b879d025dd613f22258.tar.gz
gentoo-277c9e630192d6ef58827b879d025dd613f22258.tar.bz2
gentoo-277c9e630192d6ef58827b879d025dd613f22258.zip
sys-apps/xdg-desktop-portal: New package
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-apps/xdg-desktop-portal')
-rw-r--r--sys-apps/xdg-desktop-portal/Manifest1
-rw-r--r--sys-apps/xdg-desktop-portal/metadata.xml8
-rw-r--r--sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.2.0.ebuild47
3 files changed, 56 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal/Manifest b/sys-apps/xdg-desktop-portal/Manifest
new file mode 100644
index 000000000000..cb882d4c980c
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal/Manifest
@@ -0,0 +1 @@
+DIST xdg-desktop-portal-1.2.0.tar.xz 405856 BLAKE2B 8d198c7c18b829f531e34d6526b52776a1acffcb874a2ea93953314710aa18bcb1988ffe190bb7b7f7c0d1c4eb1bc3d39fd2f7da626754730bf64f349ae75d39 SHA512 7c7dff8f1f44b4f564f195a8f9ad2985f6085d16638d18941459cd14d76d8ae7cafaf72f461f2c0c1414a8bace9f3ab4a5416de06edb71df677fd7bdca47f61a
diff --git a/sys-apps/xdg-desktop-portal/metadata.xml b/sys-apps/xdg-desktop-portal/metadata.xml
new file mode 100644
index 000000000000..2fdbf33d963d
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.2.0.ebuild b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.2.0.ebuild
new file mode 100644
index 000000000000..90099e8c1c67
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.2.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd
+
+DESCRIPTION="Desktop integration portal"
+HOMEPAGE="https://flatpak.org/ https://github.com/flatpak/xdg-desktop-portal"
+SRC_URI="https://github.com/flatpak/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc geolocation"
+
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? (
+ app-text/xmlto
+ app-text/docbook-xml-dtd:4.3
+ )
+"
+DEPEND="
+ dev-libs/glib:2[dbus]
+ sys-fs/fuse:0
+ geolocation? ( app-misc/geoclue:2.0 )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed -e "/^PKG_CHECK_MODULES(FLATPAK/s/^/# DONT /" -i configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-pipewire
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+ $(use_enable doc docbook-docs)
+ $(use_enable geolocation geoclue)
+ )
+ econf "${myeconfargs[@]}"
+}