summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 22:32:52 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:56:38 +0100
commit008541583c3effccc9cd915a0bd55f5a444118a0 (patch)
treeb4d593c19a17463d55dadee578fe29322dc94eb0 /sys-apps
parentsys-apps/onerng: drop 3.6-r3 (diff)
downloadgentoo-008541583c3effccc9cd915a0bd55f5a444118a0.tar.gz
gentoo-008541583c3effccc9cd915a0bd55f5a444118a0.tar.bz2
gentoo-008541583c3effccc9cd915a0bd55f5a444118a0.zip
sys-apps/pnputils: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pnputils/pnputils-0.1-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-apps/pnputils/pnputils-0.1-r1.ebuild b/sys-apps/pnputils/pnputils-0.1-r1.ebuild
new file mode 100644
index 000000000000..57de733ddcdd
--- /dev/null
+++ b/sys-apps/pnputils/pnputils-0.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Plug and Play BIOS utilities"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="http://archive.debian.org/debian/pool/main/p/${PN}/${P/-/_}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+
+PATCHES=(
+ "${FILESDIR}/${P}-makefile.patch"
+ "${FILESDIR}/${P}-musl.patch"
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)" all
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ einstalldocs
+}