summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2018-05-25 12:33:41 +0800
committerJason Zaman <perfinion@gentoo.org>2018-05-25 15:27:44 +0800
commit010eea95e37d8ffe79b20b1d14d3ab482383d21a (patch)
treec27a9ef0b34b4f9d1b23e011905a58f49e2b2aa4 /sys-apps
parentsys-apps/policycoreutils: bump to 2.8 (diff)
downloadgentoo-010eea95e37d8ffe79b20b1d14d3ab482383d21a.tar.gz
gentoo-010eea95e37d8ffe79b20b1d14d3ab482383d21a.tar.bz2
gentoo-010eea95e37d8ffe79b20b1d14d3ab482383d21a.zip
sys-apps/selinux-python: bump to 2.8
Package-Manager: Portage-2.3.39, Repoman-2.3.9
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/selinux-python/Manifest1
-rw-r--r--sys-apps/selinux-python/selinux-python-2.8.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/sys-apps/selinux-python/Manifest b/sys-apps/selinux-python/Manifest
index d9f6d673ac6a..ebba7c6615fa 100644
--- a/sys-apps/selinux-python/Manifest
+++ b/sys-apps/selinux-python/Manifest
@@ -2,3 +2,4 @@ DIST selinux-python-2.7.tar.gz 2068004 BLAKE2B 57c7f324a8faddf57a576f9ec5c46c8db
DIST selinux-python-2.8-rc1.tar.gz 2068420 BLAKE2B 7c00bd05cb692ae31e11c5d415641f5ceafd032882a329984a495b353e8e7272a87045c732e10a563cd0d33faca81fb373cee3d0671bc6699b6f007148f13d7d SHA512 bce5823ac4c24f1bceae9219a07fc9e6192d703e044711f9dfc170946dde411b833cb7a6d0c175e569efcd878a75a8df33dda0498e3da888f60b7adf9d5448a1
DIST selinux-python-2.8-rc2.tar.gz 2068421 BLAKE2B 1c1564f9eb281f896a794a5086ef09e91486f8ba7d404de14b0de78f3ec4aa9c3a8293b24988b80289e4e9e186b06184e8016a1ec936d6d76f17db0c3ef22a40 SHA512 5a3fb2131a12850bfe5beb794083c97507fd3f43d87674cb7050fd33ea181607077a9e004cf983918bb5b349ed22b02f3c681f2a1f72a64ee93bd49fbf40bd32
DIST selinux-python-2.8-rc3.tar.gz 2068452 BLAKE2B 37e25ac52ea157f5bb360d1391ad17c59c9dd74eb3cab4053bef0aef98b38d2e0eb2c79bb468591b91462494788e11b0b445ca123a291e4875bbf4af9ef326a0 SHA512 0481891563df1872688d881d11bb498cbd402f7b31eb674fb83526e9fa391907b424be3df5da0cef17e053e3aca3200333bf90acfe42f7f58929f322ad447ab3
+DIST selinux-python-2.8.tar.gz 2068101 BLAKE2B c28f12e4bd453955148a6ba82fd28621d1a4600f872ac63d97372f2e0153091adf1cf871f89765dd300bc6b7b2d610b96f87e3fc5accbfad713ed8a0d8f76f5a SHA512 e695c11122f7f8105b75d1ef98355fd2b82b40d93c2fd9e733dcd95d4d7c392f60b646df81203c43ad2a0e8447f9901083007e1572b78e17368ad2764ffa1aad
diff --git a/sys-apps/selinux-python/selinux-python-2.8.ebuild b/sys-apps/selinux-python/selinux-python-2.8.ebuild
new file mode 100644
index 000000000000..96a4fbaa8e14
--- /dev/null
+++ b/sys-apps/selinux-python/selinux-python-2.8.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE="xml"
+
+inherit python-r1 toolchain-funcs
+
+MY_P="${P//_/-}"
+
+MY_RELEASEDATE="20180524"
+SEPOL_VER="${PV}"
+SELNX_VER="${PV}"
+SEMNG_VER="${PV}"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DESCRIPTION="SELinux core utilities"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN#selinux-}"
+else
+ SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-libs/libselinux-${SELNX_VER}:=[python]
+ >=sys-libs/libsemanage-${SEMNG_VER}:=[python]
+ >=sys-libs/libsepol-${SEPOL_VER}:=
+ >=app-admin/setools-4.1.1[${PYTHON_USEDEP}]
+ dev-python/ipy[${PYTHON_USEDEP}]
+ !dev-python/sepolgen
+ ${PYTHON_DEPS}"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed -i 's/-Werror//g' "${S}"/*/Makefile || die "Failed to remove Werror"
+
+ python_copy_sources
+}
+
+src_compile() {
+ building() {
+ emake -C "${BUILD_DIR}" \
+ CC="$(tc-getCC)" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)"
+ }
+ python_foreach_impl building
+}
+
+src_install() {
+ installation() {
+ emake -C "${BUILD_DIR}" \
+ DESTDIR="${D}" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ install
+ python_optimize
+ }
+ python_foreach_impl installation
+
+ # Set version-specific scripts
+ for pyscript in audit2allow sepolgen-ifgen sepolicy chcat; do
+ python_replicate_script "${ED}/usr/bin/${pyscript}"
+ done
+ for pyscript in semanage; do
+ python_replicate_script "${ED}/usr/sbin/${pyscript}"
+ done
+
+ # Create sepolgen.conf with different devel location definition
+ if [[ -f /etc/selinux/config ]];
+ then
+ local selinuxtype=$(awk -F'=' '/^SELINUXTYPE/ {print $2}' /etc/selinux/config);
+ mkdir -p "${D}"/etc/selinux || die "Failed to create selinux directory";
+ echo "SELINUX_DEVEL_PATH=/usr/share/selinux/${selinuxtype}/include:/usr/share/selinux/${selinuxtype}" > "${D}"/etc/selinux/sepolgen.conf;
+ else
+ local selinuxtype="${POLICY_TYPES%% *}";
+ if [[ -n "${selinuxtype}" ]];
+ then
+ echo "SELINUX_DEVEL_PATH=/usr/share/selinux/${selinuxtype}/include:/usr/share/selinux/${selinuxtype}" > "${D}"/etc/selinux/sepolgen.conf;
+ else
+ echo "SELINUX_DEVEL_PATH=/usr/share/selinux/strict/include:/usr/share/selinux/strict" > "${D}"/etc/selinux/sepolgen.conf;
+ fi
+ fi
+}