summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-08-24 13:13:19 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-08-24 13:14:15 -0500
commit046e89752c49f8542e53ef2b0f695b8e19dcf418 (patch)
treeaf7dd77da1d2ce855f618cabd2af5dbbd4b1c1ea /sys-apps
parentwww-client/opera-developer: Version 72.0.3791.0 (diff)
downloadgentoo-046e89752c49f8542e53ef2b0f695b8e19dcf418.tar.gz
gentoo-046e89752c49f8542e53ef2b0f695b8e19dcf418.tar.bz2
gentoo-046e89752c49f8542e53ef2b0f695b8e19dcf418.zip
sys-apps/bolt: add openrc support
thanks to redflyhacker+gentoo@gmail.com for providing the init script and the kernel config checks. Closes: https://bugs.gentoo.org/692510 Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/bolt/bolt-0.9-r1.ebuild52
-rw-r--r--sys-apps/bolt/files/bolt.openrc14
2 files changed, 66 insertions, 0 deletions
diff --git a/sys-apps/bolt/bolt-0.9-r1.ebuild b/sys-apps/bolt/bolt-0.9-r1.ebuild
new file mode 100644
index 000000000000..8145c75880e1
--- /dev/null
+++ b/sys-apps/bolt/bolt-0.9-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info meson systemd
+
+DESCRIPTION="Userspace system daemon to enable security levels for Thunderbolt 3"
+HOMEPAGE="https://gitlab.freedesktop.org/bolt/bolt"
+SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc systemd"
+
+DEPEND="
+ >=dev-libs/glib-2.56.0:2
+ dev-util/glib-utils
+ virtual/libudev
+ virtual/udev
+ dev-util/umockdev
+ sys-auth/polkit[introspection]
+ systemd? ( sys-apps/systemd )
+ doc? ( app-text/asciidoc )"
+RDEPEND="${DEPEND}"
+
+pkg_pretend() {
+ CONFIG_CHECK="~THUNDERBOLT"
+ ERROR_THUNDERBOLT="This package requires the thunderbolt kernel driver."
+ check_extra_config
+
+ CONFIG_CHECK="~HOTPLUG_PCI"
+ ERROR_HOTPLUG_PCI="Thunderbolt requires PCI hotplug support."
+ check_extra_config
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dman=$(usex doc true false)
+ --sysconfdir=/etc
+ --localstatedir=/var
+ --sharedstatedir=/var/lib
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ newinitd "${FILESDIR}"/${PN}.openrc boltd
+ keepdir /var/lib/boltd
+}
diff --git a/sys-apps/bolt/files/bolt.openrc b/sys-apps/bolt/files/bolt.openrc
new file mode 100644
index 000000000000..b80a7b31b26e
--- /dev/null
+++ b/sys-apps/bolt/files/bolt.openrc
@@ -0,0 +1,14 @@
+#!/sbin/openrc-run
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+name="Thunderbolt Security Daemon"
+description="Userspace system daemon to enable security levels for Thunderbolt 3"
+command="/usr/libexec/boltd"
+command_background="true"
+pidfile="/var/run/boltd.pid"
+
+depend() {
+ need dbus
+ before xdm
+}