summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-03 23:52:04 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-03 23:54:22 +0100
commit062a5b3a1a31e918a8e609686d90af2aa7bd5a87 (patch)
tree91f058a2192fec11aa2a0d58142756362ee009ea /sys-apps
parentdev-util/kdbg: 3.0.1 version bump (diff)
downloadgentoo-062a5b3a1a31e918a8e609686d90af2aa7bd5a87.tar.gz
gentoo-062a5b3a1a31e918a8e609686d90af2aa7bd5a87.tar.bz2
gentoo-062a5b3a1a31e918a8e609686d90af2aa7bd5a87.zip
sys-apps/xdg-desktop-portal: 1.6.0 version bump
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/xdg-desktop-portal/Manifest1
-rw-r--r--sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.6.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal/Manifest b/sys-apps/xdg-desktop-portal/Manifest
index c07ddc5f59fe..495b8273cf43 100644
--- a/sys-apps/xdg-desktop-portal/Manifest
+++ b/sys-apps/xdg-desktop-portal/Manifest
@@ -1 +1,2 @@
DIST xdg-desktop-portal-1.4.2.tar.xz 421660 BLAKE2B 5395218fa182947c589ff51cd43b838591e47442b23c4fe0719f0970bff3602e81c4f79ad93890bde97a529ca34a733032e85a1f21f41e9aa230d5c2d40e1136 SHA512 9a19dc8f6899a24f8827ce36447316ce74f293abed469be24adfaa16d18deac0b7c5d77f744eed9b540b54cd23145281dacb6811dc52b34180b21d6dc02efc5a
+DIST xdg-desktop-portal-1.6.0.tar.xz 453516 BLAKE2B 13ffcb21de6b61ddeb0782dcfc7b684287e54f94b9494b19589178594d1383a15048b8f9aeed7fb1260c3a2c967b267061d1db401085a686938c8629de8824c3 SHA512 7a0c702851762a55326142cb6b470205775284e0f749620ae6b648f216afcd684f8b20500339680b42812f628634344c9e826ab7cf13dd918fdbf733381d44ce
diff --git a/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.6.0.ebuild b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.6.0.ebuild
new file mode 100644
index 000000000000..656a81da4813
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.6.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd
+
+DESCRIPTION="Desktop integration portal"
+HOMEPAGE="https://flatpak.org/ https://github.com/flatpak/xdg-desktop-portal"
+SRC_URI="https://github.com/flatpak/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="doc geolocation screencast"
+
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? (
+ app-text/xmlto
+ app-text/docbook-xml-dtd:4.3
+ )
+"
+DEPEND="
+ dev-libs/glib:2[dbus]
+ dev-libs/json-glib
+ media-libs/fontconfig
+ sys-fs/fuse:0
+ geolocation? ( >=app-misc/geoclue-2.5.3:2.0 )
+ screencast? ( media-video/pipewire:= )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+ $(use_enable doc docbook-docs)
+ $(use_enable geolocation geoclue)
+ $(use_enable screencast pipewire)
+ --disable-libportal # not packaged
+ --disable-geoclue
+ )
+ econf "${myeconfargs[@]}"
+}