summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2022-04-10 16:11:20 -0700
committerJason Zaman <perfinion@gentoo.org>2022-04-10 20:43:50 -0700
commit08a58462238cfa3a4565af5bc44775c63263402b (patch)
tree80cf68b59d5607ee476034e400a1c8a829cff0fa /sys-apps
parentsys-apps/semodule-utils: update live ebuild (diff)
downloadgentoo-08a58462238cfa3a4565af5bc44775c63263402b.tar.gz
gentoo-08a58462238cfa3a4565af5bc44775c63263402b.tar.bz2
gentoo-08a58462238cfa3a4565af5bc44775c63263402b.zip
sys-apps/secilc: update live ebuild
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/secilc/secilc-9999.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/sys-apps/secilc/secilc-9999.ebuild b/sys-apps/secilc/secilc-9999.ebuild
index 38dc82e0bcdd..13b261011af0 100644
--- a/sys-apps/secilc/secilc-9999.ebuild
+++ b/sys-apps/secilc/secilc-9999.ebuild
@@ -1,9 +1,12 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
inherit toolchain-funcs
+MY_PV="${PV//_/-}"
+MY_P="${PN}-${MY_PV}"
+
DESCRIPTION="SELinux Common Intermediate Language (CIL) Compiler"
HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
@@ -12,8 +15,9 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
S="${WORKDIR}/${P}/${PN}"
else
- SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~x86"
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_PV}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ S="${WORKDIR}/${MY_P}"
fi
LICENSE="GPL-2"