summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-03-24 08:12:33 -0400
committerNP-Hardass <NP-Hardass@gentoo.org>2016-03-24 08:13:28 -0400
commit09ee287ee9224cb67edc1afa7d5abff4fe791ad3 (patch)
treeac8256621fe6c92bb19e28e7aac919d201872672 /sys-apps
parentx11-drivers/nvidia-drivers: Install nvidia-drm.ko by Timo Rothenpieler (bug #... (diff)
downloadgentoo-09ee287ee9224cb67edc1afa7d5abff4fe791ad3.tar.gz
gentoo-09ee287ee9224cb67edc1afa7d5abff4fe791ad3.tar.bz2
gentoo-09ee287ee9224cb67edc1afa7d5abff4fe791ad3.zip
sys-apps/duc: Fix configure phase, #577860
Package-Manager: portage-2.2.26
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/duc/duc-1.4.1-r1.ebuild (renamed from sys-apps/duc/duc-1.4.1.ebuild)19
-rw-r--r--sys-apps/duc/duc-9999.ebuild19
2 files changed, 16 insertions, 22 deletions
diff --git a/sys-apps/duc/duc-1.4.1.ebuild b/sys-apps/duc/duc-1.4.1-r1.ebuild
index 3c2974ee0706..579a78bd347a 100644
--- a/sys-apps/duc/duc-1.4.1.ebuild
+++ b/sys-apps/duc/duc-1.4.1-r1.ebuild
@@ -4,9 +4,7 @@
EAPI=5
-AUTOTOOLS_AUTORECONF="true"
-AUTOTOOLS_IN_SOURCE_BUILD="true"
-inherit autotools-utils
+inherit autotools
if [[ "${PV}" == "9999" ]]; then
inherit git-r3
@@ -37,7 +35,7 @@ DEPEND="
x11-libs/libX11
x11-libs/pango[X]
)
- !X? ( virtual/opengl )
+ !X? ( >=media-libs/glfw-3.0 )
)
leveldb? ( dev-libs/leveldb )
ncurses? ( sys-libs/ncurses:= )
@@ -57,14 +55,13 @@ src_unpack() {
src_prepare() {
sed -i -e "/ldconfig/d" -e "/install-exec-hook/d" Makefile.am || die
- autotools-utils_src_prepare
+ default
+
+ eautoreconf
}
src_configure() {
- local myconf=(
- --disable-static
- $(use_with ncurses ui)
- )
+ local myconf=( $(use_enable ncurses ui) )
if use tokyocabinet; then
myconf+=( --with-db-backend=tokyocabinet )
@@ -83,8 +80,8 @@ src_configure() {
myconf+=( --disable-x11 --enable-opengl $(use_enable cairo) )
else
# No GUI
- myconf+=( $(use_enable cairo) )
+ myconf+=( $(use_enable cairo) --disable-x11 --disable-opengl )
fi
- autotools-utils_src_configure
+ econf ${myconf[@]}
}
diff --git a/sys-apps/duc/duc-9999.ebuild b/sys-apps/duc/duc-9999.ebuild
index 3c2974ee0706..579a78bd347a 100644
--- a/sys-apps/duc/duc-9999.ebuild
+++ b/sys-apps/duc/duc-9999.ebuild
@@ -4,9 +4,7 @@
EAPI=5
-AUTOTOOLS_AUTORECONF="true"
-AUTOTOOLS_IN_SOURCE_BUILD="true"
-inherit autotools-utils
+inherit autotools
if [[ "${PV}" == "9999" ]]; then
inherit git-r3
@@ -37,7 +35,7 @@ DEPEND="
x11-libs/libX11
x11-libs/pango[X]
)
- !X? ( virtual/opengl )
+ !X? ( >=media-libs/glfw-3.0 )
)
leveldb? ( dev-libs/leveldb )
ncurses? ( sys-libs/ncurses:= )
@@ -57,14 +55,13 @@ src_unpack() {
src_prepare() {
sed -i -e "/ldconfig/d" -e "/install-exec-hook/d" Makefile.am || die
- autotools-utils_src_prepare
+ default
+
+ eautoreconf
}
src_configure() {
- local myconf=(
- --disable-static
- $(use_with ncurses ui)
- )
+ local myconf=( $(use_enable ncurses ui) )
if use tokyocabinet; then
myconf+=( --with-db-backend=tokyocabinet )
@@ -83,8 +80,8 @@ src_configure() {
myconf+=( --disable-x11 --enable-opengl $(use_enable cairo) )
else
# No GUI
- myconf+=( $(use_enable cairo) )
+ myconf+=( $(use_enable cairo) --disable-x11 --disable-opengl )
fi
- autotools-utils_src_configure
+ econf ${myconf[@]}
}