summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <william.hubbs@sony.com>2019-07-25 18:04:58 -0500
committerWilliam Hubbs <williamh@gentoo.org>2019-07-25 18:07:55 -0500
commit0fe0ae974180ad7b8f4f41feb66c774e5241bc9a (patch)
treea9cfc47a09219ddb0132b31d14a8ced8efd92478 /sys-apps
parentsys-libs/glibc: fix CPPFLAGS handling, bug #686248 (diff)
downloadgentoo-0fe0ae974180ad7b8f4f41feb66c774e5241bc9a.tar.gz
gentoo-0fe0ae974180ad7b8f4f41feb66c774e5241bc9a.tar.bz2
gentoo-0fe0ae974180ad7b8f4f41feb66c774e5241bc9a.zip
sys-apps/openrc: add sysv-utils use flag
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/openrc/metadata.xml1
-rw-r--r--sys-apps/openrc/openrc-9999.ebuild10
2 files changed, 7 insertions, 4 deletions
diff --git a/sys-apps/openrc/metadata.xml b/sys-apps/openrc/metadata.xml
index 74ac5c680da1..e9c26481f89a 100644
--- a/sys-apps/openrc/metadata.xml
+++ b/sys-apps/openrc/metadata.xml
@@ -11,6 +11,7 @@
</flag>
<flag name="netifrc">enable Gentoo's network stack (net.* scripts)</flag>
<flag name="newnet">enable the new network stack (experimental)</flag>
+ <flag name="sysv-utils">Install sysvinit compatibility scripts for halt, init, poweroff, reboot and shutdown</flag>
</use>
<upstream>
<remote-id type="github">openrc/openrc</remote-id>
diff --git a/sys-apps/openrc/openrc-9999.ebuild b/sys-apps/openrc/openrc-9999.ebuild
index 11160d67f9bc..891a73480c4b 100644
--- a/sys-apps/openrc/openrc-9999.ebuild
+++ b/sys-apps/openrc/openrc-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit flag-o-matic pam toolchain-funcs usr-ldscript
@@ -19,7 +19,7 @@ fi
LICENSE="BSD-2"
SLOT="0"
IUSE="audit bash debug ncurses pam newnet prefix +netifrc selinux static-libs
- unicode kernel_linux kernel_FreeBSD"
+ sysv-utils unicode kernel_linux kernel_FreeBSD"
COMMON_DEPEND="kernel_FreeBSD? ( || ( >=sys-freebsd/freebsd-ubin-9.0_rc sys-process/fuser-bsd ) )
ncurses? ( sys-libs/ncurses:0= )
@@ -40,12 +40,13 @@ COMMON_DEPEND="kernel_FreeBSD? ( || ( >=sys-freebsd/freebsd-ubin-9.0_rc sys-proc
!<sys-fs/udev-init-scripts-27"
DEPEND="${COMMON_DEPEND}
virtual/os-headers
- bash? ( app-shells/bash )
ncurses? ( virtual/pkgconfig )"
RDEPEND="${COMMON_DEPEND}
+ bash? ( app-shells/bash )
!prefix? (
kernel_linux? (
- >=sys-apps/sysvinit-2.86-r6[selinux?]
+ sysv-utils? ( !sys-apps/sysvinit )
+ !sysv-utils? ( >=sys-apps/sysvinit-2.86-r6[selinux?] )
virtual/tmpfiles
)
kernel_FreeBSD? ( sys-freebsd/freebsd-sbin )
@@ -77,6 +78,7 @@ src_compile() {
MKBASHCOMP=yes
MKNET=$(usex newnet)
MKSELINUX=$(usex selinux)
+ MKSYSVINIT=$(usex sysv-utils)
MKAUDIT=$(usex audit)
MKPAM=$(usev pam)
MKSTATICLIBS=$(usex static-libs)