summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-05-26 13:26:39 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-05-26 13:26:50 +0300
commit2a5e49f5c45ee940ed6801c4d46feb5b2130d0b4 (patch)
tree3e1f179b75e43a714e8d5425b33c294d643f395a /sys-apps
parentsys-apps/pcmciautils: ppc stable wrt bug #651716 (diff)
downloadgentoo-2a5e49f5c45ee940ed6801c4d46feb5b2130d0b4.tar.gz
gentoo-2a5e49f5c45ee940ed6801c4d46feb5b2130d0b4.tar.bz2
gentoo-2a5e49f5c45ee940ed6801c4d46feb5b2130d0b4.zip
sys-apps/pcmciautils: Drop old
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pcmciautils/pcmciautils-018_p8.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/sys-apps/pcmciautils/pcmciautils-018_p8.ebuild b/sys-apps/pcmciautils/pcmciautils-018_p8.ebuild
deleted file mode 100644
index ccfdd306b052..000000000000
--- a/sys-apps/pcmciautils/pcmciautils-018_p8.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-inherit eutils flag-o-matic linux-info toolchain-funcs udev
-
-DEB_REV=${PV#*_p}
-MY_PV=${PV%_p*}
-
-DESCRIPTION="PCMCIA userspace utilities for Linux"
-HOMEPAGE="https://packages.qa.debian.org/pcmciautils"
-SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${MY_PV}.orig.tar.gz
- mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${MY_PV}-${DEB_REV}.debian.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm ppc sh x86"
-IUSE="debug staticsocket"
-
-RDEPEND="virtual/modutils"
-DEPEND="${RDEPEND}
- virtual/yacc
- sys-devel/flex"
-
-S=${WORKDIR}/${PN}-${MY_PV}
-
-pkg_setup() {
- CONFIG_CHECK="~PCMCIA"
- linux-info_pkg_setup
-
- kernel_is lt 2 6 32 && ewarn "${P} requires at least kernel 2.6.32."
-
- mypcmciaopts=(
- STARTUP=$(usex staticsocket true false)
- exec_prefix=/usr
- UDEV=true
- DEBUG=false
- STATIC=false
- V=true
- udevdir="$(get_udevdir)"
- CC="$(tc-getCC)"
- LD="$(tc-getCC)"
- AR="$(tc-getAR)"
- STRIP=true
- RANLIB="$(tc-getRANLIB)"
- OPTIMIZATION="${CFLAGS} ${CPPFLAGS}"
- DESTDIR="${D}"
- )
-
- use debug && append-cppflags -DDEBUG
-}
-
-src_prepare() {
- epatch \
- "${WORKDIR}"/debian/patches/no-modprobe-rules.patch \
- "${WORKDIR}"/debian/patches/remove-libsysfs-dep.patch
-
- sed -i \
- -e '/CFLAGS/s:-fomit-frame-pointer::' \
- -e '/dir/s:sbin:bin:g' \
- Makefile || die
-}
-
-src_compile() {
- emake "${mypcmciaopts[@]}"
-}
-
-src_install() {
- emake "${mypcmciaopts[@]}" install
-
- dodoc doc/*.txt
-}