summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteven Johnson <steven.gregory.johnson@gmail.com>2020-08-23 01:02:44 -0700
committerDavid Seifert <soap@gentoo.org>2020-08-23 13:36:36 +0200
commit2e24c2f37fc512bcfcf2c35b2a6eaa90f14dcd41 (patch)
tree4e84d6bc8e3e1b7280a4e923b2426639ce935392 /sys-apps
parentdev-python/pycuda: Remove live ebuild (diff)
downloadgentoo-2e24c2f37fc512bcfcf2c35b2a6eaa90f14dcd41.tar.gz
gentoo-2e24c2f37fc512bcfcf2c35b2a6eaa90f14dcd41.tar.bz2
gentoo-2e24c2f37fc512bcfcf2c35b2a6eaa90f14dcd41.zip
sys-apps/smartmontools: use EROOT instead of EPREFIX in postinst
Closes: https://bugs.gentoo.org/738668 Closes: https://github.com/gentoo/gentoo/pull/17229 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Steven Johnson <steven.gregory.johnson@gmail.com> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/smartmontools/smartmontools-7.0-r1.ebuild4
-rw-r--r--sys-apps/smartmontools/smartmontools-7.1.ebuild4
-rw-r--r--sys-apps/smartmontools/smartmontools-9999.ebuild4
3 files changed, 6 insertions, 6 deletions
diff --git a/sys-apps/smartmontools/smartmontools-7.0-r1.ebuild b/sys-apps/smartmontools/smartmontools-7.0-r1.ebuild
index 285822cc66a6..bca8212f62bd 100644
--- a/sys-apps/smartmontools/smartmontools-7.0-r1.ebuild
+++ b/sys-apps/smartmontools/smartmontools-7.0-r1.ebuild
@@ -114,8 +114,8 @@ src_install() {
pkg_postinst() {
if use daemon || use update_drivedb; then
- local initial_db_file="${EPREFIX}/usr/share/${PN}/drivedb.h"
- local db_path="${EPREFIX}/var/db/${PN}"
+ local initial_db_file="${EROOT}/usr/share/${PN}/drivedb.h"
+ local db_path="${EROOT}/var/db/${PN}"
if [[ ! -f "${db_path}/drivedb.h" ]] ; then
# No initial database found
diff --git a/sys-apps/smartmontools/smartmontools-7.1.ebuild b/sys-apps/smartmontools/smartmontools-7.1.ebuild
index 2a8ee6a3de63..fb41bdc784b5 100644
--- a/sys-apps/smartmontools/smartmontools-7.1.ebuild
+++ b/sys-apps/smartmontools/smartmontools-7.1.ebuild
@@ -114,8 +114,8 @@ src_install() {
pkg_postinst() {
if use daemon || use update_drivedb; then
- local initial_db_file="${EPREFIX}/usr/share/${PN}/drivedb.h"
- local db_path="${EPREFIX}/var/db/${PN}"
+ local initial_db_file="${EROOT}/usr/share/${PN}/drivedb.h"
+ local db_path="${EROOT}/var/db/${PN}"
if [[ ! -f "${db_path}/drivedb.h" ]] ; then
# No initial database found
diff --git a/sys-apps/smartmontools/smartmontools-9999.ebuild b/sys-apps/smartmontools/smartmontools-9999.ebuild
index 984b82cc76d4..9c4544209c16 100644
--- a/sys-apps/smartmontools/smartmontools-9999.ebuild
+++ b/sys-apps/smartmontools/smartmontools-9999.ebuild
@@ -114,8 +114,8 @@ src_install() {
pkg_postinst() {
if use daemon || use update_drivedb; then
- local initial_db_file="${EPREFIX}/usr/share/${PN}/drivedb.h"
- local db_path="${EPREFIX}/var/db/${PN}"
+ local initial_db_file="${EROOT}/usr/share/${PN}/drivedb.h"
+ local db_path="${EROOT}/var/db/${PN}"
if [[ ! -f "${db_path}/drivedb.h" ]] ; then
# No initial database found