summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-11-25 19:31:47 -0500
committerMike Frysinger <vapier@gentoo.org>2016-11-25 19:32:00 -0500
commit3a9c391e65d1ddf5f92632c43379e722391e2db3 (patch)
tree35d8713e8c8cb6f0b8b65135f52af7d62e686607 /sys-apps
parentprofiles: mask open-vm-tools-kmod for removal (diff)
downloadgentoo-3a9c391e65d1ddf5f92632c43379e722391e2db3.tar.gz
gentoo-3a9c391e65d1ddf5f92632c43379e722391e2db3.tar.bz2
gentoo-3a9c391e65d1ddf5f92632c43379e722391e2db3.zip
sys-apps/memtest86+: add links to patches sent upstream
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/memtest86+/files/memtest86+-5.01-gcc-473.patch12
-rw-r--r--sys-apps/memtest86+/files/memtest86+-5.01-io-extern-inline.patch2
-rw-r--r--sys-apps/memtest86+/files/memtest86+-5.01-no-C-headers.patch2
-rw-r--r--sys-apps/memtest86+/files/memtest86+-5.01-no-clean.patch3
-rw-r--r--sys-apps/memtest86+/files/memtest86+-5.01-no-scp.patch2
-rw-r--r--sys-apps/memtest86+/files/memtest86+-5.01-reboot-def.patch2
6 files changed, 17 insertions, 6 deletions
diff --git a/sys-apps/memtest86+/files/memtest86+-5.01-gcc-473.patch b/sys-apps/memtest86+/files/memtest86+-5.01-gcc-473.patch
index b793c326b262..af011d67c705 100644
--- a/sys-apps/memtest86+/files/memtest86+-5.01-gcc-473.patch
+++ b/sys-apps/memtest86+/files/memtest86+-5.01-gcc-473.patch
@@ -1,6 +1,7 @@
-diff -Narup memtest86+-5.01-orig/controller.c memtest86+-5.01/controller.c
---- memtest86+-5.01-orig/controller.c 2013-08-09 22:01:58.000000000 -0400
-+++ memtest86+-5.01/controller.c 2014-06-22 11:01:17.347923472 -0400
+http://forum.canardpc.com/threads/110950-fix-controller-loop-error
+
+--- memtest86+-5.01/controller.c
++++ memtest86+-5.01/controller.c
@@ -292,7 +292,7 @@ static void setup_nhm(void)
/* First, locate the PCI bus where the MCH is located */
@@ -19,9 +20,8 @@ diff -Narup memtest86+-5.01-orig/controller.c memtest86+-5.01/controller.c
pci_conf_read( possible_nhm_bus[i], 3, 4, 0x00, 2, &vid);
pci_conf_read( possible_nhm_bus[i], 3, 4, 0x02, 2, &did);
vid &= 0xFFFF;
-diff -Narup memtest86+-5.01-orig/Makefile memtest86+-5.01/Makefile
---- memtest86+-5.01-orig/Makefile 2013-08-09 22:01:58.000000000 -0400
-+++ memtest86+-5.01/Makefile 2014-06-22 10:59:27.463573842 -0400
+--- memtest86+-5.01/Makefile
++++ memtest86+-5.01/Makefile
@@ -12,7 +12,7 @@ FDISK=/dev/fd0
AS=as -32
CC=gcc
diff --git a/sys-apps/memtest86+/files/memtest86+-5.01-io-extern-inline.patch b/sys-apps/memtest86+/files/memtest86+-5.01-io-extern-inline.patch
index 8dc13b1307f5..682dd5d01a1e 100644
--- a/sys-apps/memtest86+/files/memtest86+-5.01-io-extern-inline.patch
+++ b/sys-apps/memtest86+/files/memtest86+-5.01-io-extern-inline.patch
@@ -1,3 +1,5 @@
+http://forum.canardpc.com/threads/110951-fix-build-with-newer-gcc-versions
+
the meaning of extern inline changed between standards. use static inline
for these tiny I/O functions everywhere to keep things simple.
diff --git a/sys-apps/memtest86+/files/memtest86+-5.01-no-C-headers.patch b/sys-apps/memtest86+/files/memtest86+-5.01-no-C-headers.patch
index bbb222849df1..ce7f906a19d5 100644
--- a/sys-apps/memtest86+/files/memtest86+-5.01-no-C-headers.patch
+++ b/sys-apps/memtest86+/files/memtest86+-5.01-no-C-headers.patch
@@ -1,3 +1,5 @@
+http://forum.canardpc.com/threads/110955-PATCH-don-t-pull-in-system-headers
+
avoid using C library headers as it'd mean we'd need 32-bit glibc files available
https://bugs.gentoo.org/592638
diff --git a/sys-apps/memtest86+/files/memtest86+-5.01-no-clean.patch b/sys-apps/memtest86+/files/memtest86+-5.01-no-clean.patch
index 876edcf68360..e9cbf10399c3 100644
--- a/sys-apps/memtest86+/files/memtest86+-5.01-no-clean.patch
+++ b/sys-apps/memtest86+/files/memtest86+-5.01-no-clean.patch
@@ -1,3 +1,6 @@
+http://forum.canardpc.com/threads/110954-PATCH-fix-parallel-build-issues
+
+
don't run the clean target when building all as we run into parallel races:
- memtest kicks off building of a bunch of .o files
- clean runs in parallel which runs `rm` and deletes some of the new .o
diff --git a/sys-apps/memtest86+/files/memtest86+-5.01-no-scp.patch b/sys-apps/memtest86+/files/memtest86+-5.01-no-scp.patch
index 8303ccf4229c..8d830e297ec2 100644
--- a/sys-apps/memtest86+/files/memtest86+-5.01-no-scp.patch
+++ b/sys-apps/memtest86+/files/memtest86+-5.01-no-scp.patch
@@ -1,3 +1,5 @@
+http://forum.canardpc.com/threads/110953-PATCH-don-t-try-to-scp-after-building
+
this makes no sense in a sane build world
--- a/Makefile
diff --git a/sys-apps/memtest86+/files/memtest86+-5.01-reboot-def.patch b/sys-apps/memtest86+/files/memtest86+-5.01-reboot-def.patch
index a121fdecd75a..f4b42feb5fb3 100644
--- a/sys-apps/memtest86+/files/memtest86+-5.01-reboot-def.patch
+++ b/sys-apps/memtest86+/files/memtest86+-5.01-reboot-def.patch
@@ -1,3 +1,5 @@
+http://forum.canardpc.com/threads/110952-fix-build-due-to-missing-reboot-symbol
+
the reboot func is used elsewhere, so don't mark it inline
--- a/lib.c