summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2017-01-25 14:44:07 -1000
committerMike Frysinger <vapier@gentoo.org>2017-01-25 14:47:24 -1000
commit3b68244ddce256fa9637d75cab0e001a711dfb46 (patch)
tree8e4fa49ce3db6e4ac004582ff9ebe71a3d2a8eb3 /sys-apps
parentapp-eselect/eselect-opengl: Drop old. (diff)
downloadgentoo-3b68244ddce256fa9637d75cab0e001a711dfb46.tar.gz
gentoo-3b68244ddce256fa9637d75cab0e001a711dfb46.tar.bz2
gentoo-3b68244ddce256fa9637d75cab0e001a711dfb46.zip
sys-apps/keyutils: fix extern C markings in keyutils.h
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/keyutils/files/keyutils-1.5.9-header-extern-c.patch43
-rw-r--r--sys-apps/keyutils/keyutils-1.5.9-r3.ebuild93
2 files changed, 136 insertions, 0 deletions
diff --git a/sys-apps/keyutils/files/keyutils-1.5.9-header-extern-c.patch b/sys-apps/keyutils/files/keyutils-1.5.9-header-extern-c.patch
new file mode 100644
index 000000000000..c7a4c1034c90
--- /dev/null
+++ b/sys-apps/keyutils/files/keyutils-1.5.9-header-extern-c.patch
@@ -0,0 +1,43 @@
+sent upstream
+
+From 1f15000ad21c301a51f7746eb561659348060f45 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@chromium.org>
+Date: Wed, 25 Jan 2017 14:06:55 -1000
+Subject: [PATCH keyutils] add extern C markings to header file for C++ users
+
+If people try to use keyutils from C++ code, the header doesn't work
+properly because the compiler mangles the keyutils symbols. Add the
+right extern markings so it works out of the box.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ keyutils.h | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/keyutils.h b/keyutils.h
+index a69fa7aaa11d..d50d19d3e929 100644
+--- a/keyutils.h
++++ b/keyutils.h
+@@ -15,6 +15,10 @@
+ #include <sys/types.h>
+ #include <stdint.h>
+
++#ifdef __cplusplus
++extern "C" {
++#endif
++
+ extern const char keyutils_version_string[];
+ extern const char keyutils_build_string[];
+
+@@ -180,4 +184,8 @@ extern int recursive_session_key_scan(recursive_key_scanner_t func, void *data);
+ extern key_serial_t find_key_by_type_and_desc(const char *type, const char *desc,
+ key_serial_t destringid);
+
++#ifdef __cplusplus
++}
++#endif
++
+ #endif /* KEYUTILS_H */
+--
+2.11.0
+
diff --git a/sys-apps/keyutils/keyutils-1.5.9-r3.ebuild b/sys-apps/keyutils/keyutils-1.5.9-r3.ebuild
new file mode 100644
index 000000000000..54b7d6e2906a
--- /dev/null
+++ b/sys-apps/keyutils/keyutils-1.5.9-r3.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit multilib eutils toolchain-funcs linux-info multilib-minimal
+
+DESCRIPTION="Linux Key Management Utilities"
+HOMEPAGE="https://people.redhat.com/dhowells/keyutils/"
+SRC_URI="https://people.redhat.com/dhowells/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux"
+IUSE="static static-libs test"
+
+RDEPEND=""
+DEPEND="!prefix? ( >=sys-kernel/linux-headers-2.6.11 )"
+
+pkg_setup() {
+ CONFIG_CHECK="~KEYS"
+ use test && CONFIG_CHECK="${CONFIG_CHECK} ~KEYS_DEBUG_PROC_KEYS"
+ ERROR_KEYS="You must have CONFIG_KEYS to use this package!"
+ ERROR_KEYS_DEBUG_PROC_KEYS="You must have CONFIG_KEYS_DEBUG_PROC_KEYS to run the package testsuite!"
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.5.5-makefile-fixup.patch
+ epatch "${FILESDIR}"/${PN}-1.5.9-endian-check-{1,2}.patch #426424
+ epatch "${FILESDIR}"/${PN}-1.5.9-disable-tests.patch #519062 #522050
+ epatch "${FILESDIR}"/${PN}-1.5.9-header-extern-c.patch
+
+ # The lsb check is useless, so avoid spurious command not found messages.
+ sed -i -e 's,lsb_release,:,' tests/prepare.inc.sh || die
+ # All the test files are bash, but try to execute via `sh`.
+ sed -i -r \
+ -e 's:([[:space:]])sh([[:space:]]):\1bash\2:' \
+ tests/{Makefile*,*.sh} || die
+ find tests/ -name '*.sh' -exec sed -i '1s:/sh$:/bash:' {} +
+ # Some tests call the kernel which calls userspace, but that will
+ # run the install keyutils rather than the locally compiled one,
+ # so disable round trip tests.
+ rm -rf tests/keyctl/requesting/{bad-args,piped,valid}
+
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ tc-export AR CC
+ sed -i \
+ -e "1iRPATH = $(usex static -static '')" \
+ -e '/^C.*FLAGS/s|:=|+=|' \
+ -e 's:-Werror::' \
+ -e '/^BUILDFOR/s:=.*:=:' \
+ -e "/^LIBDIR/s:=.*:= /usr/$(get_libdir):" \
+ -e '/^USRLIBDIR/s:=.*:=$(LIBDIR):' \
+ -e "s: /: ${EPREFIX}/:g" \
+ -e '/^NO_ARLIB/d' \
+ Makefile || die
+
+ # We need the static lib in order to statically link programs.
+ if use static ; then
+ export NO_ARLIB=0
+ # Hack the progs to depend on the static lib instead.
+ sed -i \
+ -e '/^.*:.*[$](DEVELLIB)$/s:$(DEVELLIB):$(ARLIB):' \
+ Makefile || die
+ else
+ export NO_ARLIB=$(usex static-libs 0 1)
+ fi
+ emake
+}
+
+multilib_src_test() {
+ # Execute the locally compiled code rather than the
+ # older versions already installed in the system.
+ LD_LIBRARY_PATH=${BUILD_DIR} \
+ PATH="${BUILD_DIR}:${PATH}" \
+ emake test
+}
+
+multilib_src_install() {
+ # Possibly undo the setting for USE=static (see src_compile).
+ export NO_ARLIB=$(usex static-libs 0 1)
+
+ default
+ use static || gen_usr_ldscript -a keyutils
+}
+
+multilib_src_install_all() {
+ dodoc README
+}