summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-08-22 22:02:51 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-08-22 22:16:12 +0200
commit3e4595217e0c85542f0729012bffcc0fd39d38f9 (patch)
tree64ca4b1d20a7998e7bd26818c6d90822d2f9ba85 /sys-apps
parentapp-misc/graphlcd-base: bump to version 2.0.0 (diff)
downloadgentoo-3e4595217e0c85542f0729012bffcc0fd39d38f9.tar.gz
gentoo-3e4595217e0c85542f0729012bffcc0fd39d38f9.tar.bz2
gentoo-3e4595217e0c85542f0729012bffcc0fd39d38f9.zip
sys-apps/hw-probe: bump to version 1.6_beta2
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hw-probe/Manifest1
-rw-r--r--sys-apps/hw-probe/hw-probe-1.6_beta2.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/sys-apps/hw-probe/Manifest b/sys-apps/hw-probe/Manifest
index dcd90fe38903..6bc85b53ded8 100644
--- a/sys-apps/hw-probe/Manifest
+++ b/sys-apps/hw-probe/Manifest
@@ -1 +1,2 @@
DIST hw-probe-1.5.tar.gz 113996 BLAKE2B 59f6fc27e2cbb99a4b7dd9428e32a93dce2ffcc1133e82539b8836a694e6c5634fe2e172732675acf0d83504907a750c63f138d6dec236039eb7c805010a8383 SHA512 80dd2484bd317ac1e86d7f434626f288648aebf110a4bf81c0c05548abcb19d990119c1690fcb5796384a6c32fd5c1e827698a31165bfc41ef6df9fc7fdd368d
+DIST hw-probe-1.6_beta2.tar.gz 143569 BLAKE2B fc7b7562f86eb1b26fef32a8ed9b4a8d01c5621bedbc7e810d5a011c53d528b000ff9df312cf5e3f0ab455558e08e2b9a3ddcd543cd6856208466721f9a0e13c SHA512 2727e7b0fe449cbb6dd21fc112660df4ec666be845bbfd21037b41372a499dfb80c8c2dc37bd222032c68faadff91192a6d6f5229353cb0fc63b8e3dbd715f5d
diff --git a/sys-apps/hw-probe/hw-probe-1.6_beta2.ebuild b/sys-apps/hw-probe/hw-probe-1.6_beta2.ebuild
new file mode 100644
index 000000000000..e6accc081c3f
--- /dev/null
+++ b/sys-apps/hw-probe/hw-probe-1.6_beta2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV="${PV/_/-}"
+MY_PV_BETA="${MY_PV/2/}"
+
+inherit eutils readme.gentoo-r1
+
+DESCRIPTION="A tool to probe for hardware, check it's operability and find drivers"
+HOMEPAGE="https://github.com/linuxhw/hw-probe/"
+SRC_URI="https://github.com/linuxhw/hw-probe/archive/${MY_PV_BETA}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Digest-SHA1
+ net-misc/curl
+ sys-apps/dmidecode
+ sys-apps/edid-decode
+ sys-apps/hwinfo
+ sys-apps/pciutils
+ sys-apps/smartmontools
+ sys-apps/usbutils
+ virtual/perl-Data-Dumper
+"
+
+S="${WORKDIR}/${PN}-${MY_PV_BETA}"
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ default
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ optfeature "showing Machine Check Exceptions." app-admin/mcelog
+ optfeature "showing additional I/O statistics." app-admin/sysstat
+ optfeature "showing display data channel (ddc) information." app-misc/ddcutil
+ optfeature "showing smart card (reader) information." dev-libs/opensc
+ optfeature "showing Vulkan GPU hardware information." dev-util/vulkan-tools
+ optfeature "showing information of attached scanners." media-gfx/sane-backends
+ optfeature "showing GPU information provided by MESA." media-libs/mesa
+ optfeature "showing zeroconf statistics." net-dns/avahi
+ optfeature "showing HP printer statistics." net-print/hplip
+ optfeature "showing status about rfkill switches on communication devices." net-wireless/rfkill
+ optfeature "showing additional CPU capabilities." sys-apps/cpuid
+ optfeature "showing hard disk (HDD, SSD, ..) capabilities." sys-apps/hdparm
+ optfeature "showing available I2C sensors." sys-apps/i2c-tools
+ optfeature "showing additional hardware and system information detected by inxi." sys-apps/inxi
+ optfeature "showing information about tested memory for faults." sys-apps/memtester
+ optfeature "showing 'Plug & Play' devices." sys-apps/pnputils
+ optfeature "showing systemd boot process information." sys-apps/systemd
+ optfeature "showing ACPI statistics and tables." sys-power/iasl
+ optfeature "showing information about NUMA." sys-process/numactl
+ optfeature "showing additional GPU information provided by MESA progs." x11-apps/mesa-progs
+ optfeature "showing available Xinput devices." x11-apps/xinput
+}