summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-06-12 22:47:00 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-06-12 22:49:18 +0200
commit430733d66882ebd89cad7b81783713b02d7f44bb (patch)
treefbac9e1791d27d70165ce30e266691d4a2ce09cd /sys-apps
parentmedia-libs/imlib2: keyworded 1.5.1 for sparc (diff)
downloadgentoo-430733d66882ebd89cad7b81783713b02d7f44bb.tar.gz
gentoo-430733d66882ebd89cad7b81783713b02d7f44bb.tar.bz2
gentoo-430733d66882ebd89cad7b81783713b02d7f44bb.zip
sys-apps/diffutils: fix build with glibc 2.26
Aside fix for building with glibc 2.26, ebuild was bumped to EAPI=6. Bug: https://bugs.gentoo.org/653914 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/diffutils/diffutils-3.6-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/diffutils/diffutils-3.6-r1.ebuild b/sys-apps/diffutils/diffutils-3.6-r1.ebuild
new file mode 100644
index 000000000000..ab2624456bf7
--- /dev/null
+++ b/sys-apps/diffutils/diffutils-3.6-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="Tools to make diffs and compare files"
+HOMEPAGE="https://www.gnu.org/software/diffutils/"
+SRC_URI="mirror://gnu/diffutils/${P}.tar.xz
+ mirror://gnu-alpha/diffutils/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls static"
+
+DEPEND="app-arch/xz-utils
+ nls? ( sys-devel/gettext )"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+
+src_configure() {
+ use static && append-ldflags -static
+
+ # Disable automagic dependency over libsigsegv; see bug #312351.
+ export ac_cv_libsigsegv=no
+
+ # required for >=glibc-2.26, bug #653914
+ use elibc_glibc && export gl_cv_func_getopt_gnu=yes
+
+ local myeconfargs=(
+ --with-packager="Gentoo"
+ --with-packager-version="${PVR}"
+ --with-packager-bug-reports="https://bugs.gentoo.org/"
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ # explicitly allow parallel testing
+ emake check
+}