summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 22:31:32 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:56:35 +0100
commit4b43784bea5465041bb3827e9dcf1e3e62587456 (patch)
tree78a12505a4e300d5d6b69c09bfb0387cb41d6705 /sys-apps
parentsys-apps/ipmicfg: drop 1.33.0.210528 (diff)
downloadgentoo-4b43784bea5465041bb3827e9dcf1e3e62587456.tar.gz
gentoo-4b43784bea5465041bb3827e9dcf1e3e62587456.tar.bz2
gentoo-4b43784bea5465041bb3827e9dcf1e3e62587456.zip
sys-apps/lcdutils: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/lcdutils/lcdutils-0.2-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-apps/lcdutils/lcdutils-0.2-r2.ebuild b/sys-apps/lcdutils/lcdutils-0.2-r2.ebuild
new file mode 100644
index 000000000000..ff9a36838a23
--- /dev/null
+++ b/sys-apps/lcdutils/lcdutils-0.2-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="(Sun) Cobalt Qube/RaQ button reading and LCD writing utilities"
+HOMEPAGE="https://people.debian.org/~pm/mips-cobalt/"
+SRC_URI="https://people.debian.org/~pm/mips-cobalt/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~mips x86"
+
+PATCHES=(
+ "${FILESDIR}/${P}-include-stdlib.h-for-exit.patch"
+ "${FILESDIR}/${P}-makefile.patch"
+)
+
+src_prepare() {
+ default
+
+ tc-export CC
+}