summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2019-02-16 09:29:28 +0000
committerPatrick Lauer <patrick@gentoo.org>2019-02-16 09:29:28 +0000
commit4ff445f3edb18c67d30edbd48169069ed8dfff42 (patch)
tree10969eaabcd8142998a582c8a2a9abc6815bcb04 /sys-apps
parentdev-vcs/hgsubversion: Drop old (diff)
downloadgentoo-4ff445f3edb18c67d30edbd48169069ed8dfff42.tar.gz
gentoo-4ff445f3edb18c67d30edbd48169069ed8dfff42.tar.bz2
gentoo-4ff445f3edb18c67d30edbd48169069ed8dfff42.zip
sys-apps/toybox: Bump
Package-Manager: Portage-2.3.60, Repoman-2.3.12 X-Autogenerated-SOB: Yes Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/toybox/Manifest1
-rw-r--r--sys-apps/toybox/toybox-0.8.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/sys-apps/toybox/Manifest b/sys-apps/toybox/Manifest
index 02052b026aff..ae67edfc5143 100644
--- a/sys-apps/toybox/Manifest
+++ b/sys-apps/toybox/Manifest
@@ -2,3 +2,4 @@ DIST toybox-0.7.5.tar.gz 818815 BLAKE2B 0d91eb07b9c2e64c611be24eb09aac7ffc26d65f
DIST toybox-0.7.6.tar.gz 834351 BLAKE2B 7c6737a8b16f77fd7a5e389be17ef8eb41d28718e46231ec1aa48af0a0ec1cbdc1c0b74670c3f79f58a5b0547f47aa6e5ccbaccc5451b12a80e1c566ee49a30d SHA512 1ed06114f5feb46e642bfeee517366a16c0a5d76562841a3cdf6b003bb330be10d4ac5009c7cf845eb5ea99bb8ae8b4291c413bbd45fd89c2ae3e4a69c1455bb
DIST toybox-0.7.7.tar.gz 843039 BLAKE2B fb4ef2ad483acd2b42905e765f7287b41fa8b1822796579c4a57a8ad3f5a3cdb8bbcd0e6790eddc8daf2ec41c50be478c7d19623d1c8db2e7b1d4db8b52fbbc6 SHA512 89369662eaf48bb52909f49932b98395eed6e672f6a37387819a02ba9c33f6b737686782ca3bf0ed0f9b60e1e2fff88ad1ebb678999582986acfec371d100827
DIST toybox-0.7.8.tar.gz 903344 BLAKE2B e223dabd7b44a050bb884d595235ea469524ffbcf3b29ee8a106354dff3250b5e9c7922cb8b499ff343e170735e29b321b9c00c370c67a1d20c8a5e44ab2bdd2 SHA512 125e4b22deda1e707a62c49b40bf7ac8a36122af27fd70ed45c651a61b5607765cf1c9b3b1c3103c0a5b5f4e7760a50e87ac62bfc89aa870a22ae8ad0aacad65
+DIST toybox-0.8.0.tar.gz 975002 BLAKE2B e137c3616d2affaf8b6f234cab49190b98540fe8f954244172f9ca80c749069f85ff8addd94e1018d3680f1a307df54671ee9b01726c5279f340f8fee3669609 SHA512 aeb15a02782cc0b3b46a892e2d82834e5172a7da04e2498eaefec58221305dd24a86aada5ce05978bd4694895ffeb94ae980fd767f4ee00c499b3dd518fd3e20
diff --git a/sys-apps/toybox/toybox-0.8.0.ebuild b/sys-apps/toybox/toybox-0.8.0.ebuild
new file mode 100644
index 000000000000..564d2c54b23c
--- /dev/null
+++ b/sys-apps/toybox/toybox-0.8.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit multiprocessing savedconfig toolchain-funcs
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/landley/toybox.git"
+else
+ SRC_URI="https://landley.net/code/toybox/downloads/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+# makefile is stupid
+RESTRICT="test"
+
+DESCRIPTION="Common linux commands in a multicall binary"
+HOMEPAGE="https://landley.net/code/toybox/"
+
+# The source code does not explicitly say that it's BSD, but the author has repeatedly said it
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+src_prepare() {
+ default
+ restore_config .config
+}
+
+src_configure() {
+ if [ -f .config ]; then
+ yes "" | emake -j1 oldconfig > /dev/null
+ return 0
+ else
+ einfo "Could not locate user configfile, so we will save a default one"
+ emake -j1 defconfig > /dev/null
+ fi
+}
+
+src_compile() {
+ tc-export CC STRIP
+ export HOSTCC=$(tc-getBUILD_CC)
+ unset CROSS_COMPILE
+ export CPUS=$(makeopts_jobs)
+ emake V=1
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ save_config .config
+ newbin generated/unstripped/toybox toybox
+}