summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-06-04 19:28:24 -0400
committerTim Harder <radhermit@gentoo.org>2018-06-04 19:33:30 -0400
commit565fdc0359edc73f8df6b32c58ac9f69aaef267a (patch)
tree4e2f95d88ac0876152dd513231c9e22a329f4dc6 /sys-apps
parentdev-python/pychroot: drop py2 support for live ebuild and update deps (diff)
downloadgentoo-565fdc0359edc73f8df6b32c58ac9f69aaef267a.tar.gz
gentoo-565fdc0359edc73f8df6b32c58ac9f69aaef267a.tar.bz2
gentoo-565fdc0359edc73f8df6b32c58ac9f69aaef267a.zip
sys-apps/pkgcore: bump live ebuild to only supporting py3.6
And update deps.
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pkgcore/pkgcore-9999.ebuild16
1 files changed, 5 insertions, 11 deletions
diff --git a/sys-apps/pkgcore/pkgcore-9999.ebuild b/sys-apps/pkgcore/pkgcore-9999.ebuild
index 53434ea7411a..28296ac77537 100644
--- a/sys-apps/pkgcore/pkgcore-9999.ebuild
+++ b/sys-apps/pkgcore/pkgcore-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+EAPI=6
+PYTHON_COMPAT=( python3_6 )
DISTUTILS_IN_SOURCE_BUILD=1
inherit distutils-r1
@@ -26,24 +26,18 @@ if [[ ${PV} == *9999 ]] ; then
else
SPHINX="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
fi
-RDEPEND="$(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' python{2_7,3_4,3_5})"
if [[ ${PV} == *9999 ]]; then
RDEPEND+=" =dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
else
- RDEPEND+=" >=dev-python/snakeoil-0.7.5[${PYTHON_USEDEP}]"
+ RDEPEND+=" >=dev-python/snakeoil-0.8.0[${PYTHON_USEDEP}]"
fi
DEPEND="${RDEPEND}
${SPHINX}
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/pyparsing[${PYTHON_USEDEP}]
- test? ( $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
"
-pkg_setup() {
- # disable snakeoil 2to3 caching...
- unset PY2TO3_CACHEDIR
-}
-
python_compile_all() {
esetup.py build_man $(usex doc "build_docs" "")
}