summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-01-16 15:42:02 -0500
committerMike Gilbert <floppym@gentoo.org>2020-01-17 11:02:34 -0500
commit56f502eea34a0d9d50fac1ea9a7f28105cc9b6da (patch)
tree04754dec753a0f8fdbf8d5daf91a5c475cf92d8d /sys-apps
parentmedia-libs/libjpeg-turbo: Bump to version 2.0.4 (diff)
downloadgentoo-56f502eea34a0d9d50fac1ea9a7f28105cc9b6da.tar.gz
gentoo-56f502eea34a0d9d50fac1ea9a7f28105cc9b6da.tar.bz2
gentoo-56f502eea34a0d9d50fac1ea9a7f28105cc9b6da.zip
sys-apps/sed: remove forced-sandbox USE flag
This "feature" isn't supported by upstream, and breaks at least one build system. Closes: https://bugs.gentoo.org/705578 Package-Manager: Portage-2.3.84_p2, Repoman-2.3.20_p24 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/sed/metadata.xml7
-rw-r--r--sys-apps/sed/sed-4.5.ebuild31
-rw-r--r--sys-apps/sed/sed-4.7.ebuild29
-rw-r--r--sys-apps/sed/sed-4.8.ebuild29
4 files changed, 4 insertions, 92 deletions
diff --git a/sys-apps/sed/metadata.xml b/sys-apps/sed/metadata.xml
index 504b6a5e4649..b738f8c54a01 100644
--- a/sys-apps/sed/metadata.xml
+++ b/sys-apps/sed/metadata.xml
@@ -8,11 +8,4 @@
<upstream>
<remote-id type="sourceforge">sed</remote-id>
</upstream>
-<use>
- <flag name="forced-sandbox">
- Always enable --sandbox mode for simpler/secure runtime (disables e/r/w commands).
- Note: This may break many configure scripts, so it should be avoided on dev systems
- (and generally used on binpkg/final systems only).
- </flag>
-</use>
</pkgmetadata>
diff --git a/sys-apps/sed/sed-4.5.ebuild b/sys-apps/sed/sed-4.5.ebuild
index 555171c1e834..0d105052fcd6 100644
--- a/sys-apps/sed/sed-4.5.ebuild
+++ b/sys-apps/sed/sed-4.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,7 +12,7 @@ SRC_URI="mirror://gnu/sed/${P}.tar.xz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sh sparc x86"
-IUSE="acl forced-sandbox nls selinux static"
+IUSE="acl nls selinux static"
RDEPEND="acl? ( virtual/acl )
nls? ( virtual/libintl )
@@ -20,33 +20,6 @@ RDEPEND="acl? ( virtual/acl )
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
-src_bootstrap_sed() {
- # make sure system-sed works #40786 #650052
- if ! type -p sed > /dev/null || has_version 'sys-apps/sed[forced-sandbox]' ; then
- mkdir -p "${T}/bootstrap"
- printf '#!/bin/sh\nexec busybox sed "$@"\n' > "${T}/bootstrap/sed" || die
- chmod a+rx "${T}/bootstrap/sed"
- PATH="${T}/bootstrap:${PATH}"
- fi
-}
-
-src_prepare() {
- # Don't use sed before bootstrap if we have to recover a broken host sed.
- src_bootstrap_sed
-
- default
-
- if use forced-sandbox ; then
- # Upstream doesn't want to add a configure flag for this.
- # https://lists.gnu.org/archive/html/bug-sed/2018-03/msg00001.html
- sed -i \
- -e '/^bool sandbox = false;/s:false:true:' \
- sed/sed.c || die
- # Make sure the sed took.
- grep -q '^bool sandbox = true;' sed/sed.c || die "forcing sandbox failed"
- fi
-}
-
src_configure() {
local myconf=()
if use userland_GNU; then
diff --git a/sys-apps/sed/sed-4.7.ebuild b/sys-apps/sed/sed-4.7.ebuild
index 778456b75253..f57b47cb55a1 100644
--- a/sys-apps/sed/sed-4.7.ebuild
+++ b/sys-apps/sed/sed-4.7.ebuild
@@ -12,7 +12,7 @@ SRC_URI="mirror://gnu/sed/${P}.tar.xz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 ~sh ~sparc x86"
-IUSE="acl forced-sandbox nls selinux static"
+IUSE="acl nls selinux static"
RDEPEND="acl? ( virtual/acl )
nls? ( virtual/libintl )
@@ -20,33 +20,6 @@ RDEPEND="acl? ( virtual/acl )
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
-src_bootstrap_sed() {
- # make sure system-sed works #40786 #650052
- if ! type -p sed > /dev/null || has_version 'sys-apps/sed[forced-sandbox]' ; then
- mkdir -p "${T}/bootstrap"
- printf '#!/bin/sh\nexec busybox sed "$@"\n' > "${T}/bootstrap/sed" || die
- chmod a+rx "${T}/bootstrap/sed"
- PATH="${T}/bootstrap:${PATH}"
- fi
-}
-
-src_prepare() {
- # Don't use sed before bootstrap if we have to recover a broken host sed.
- src_bootstrap_sed
-
- default
-
- if use forced-sandbox ; then
- # Upstream doesn't want to add a configure flag for this.
- # https://lists.gnu.org/archive/html/bug-sed/2018-03/msg00001.html
- sed -i \
- -e '/^bool sandbox = false;/s:false:true:' \
- sed/sed.c || die
- # Make sure the sed took.
- grep -q '^bool sandbox = true;' sed/sed.c || die "forcing sandbox failed"
- fi
-}
-
src_configure() {
local myconf=()
if use userland_GNU; then
diff --git a/sys-apps/sed/sed-4.8.ebuild b/sys-apps/sed/sed-4.8.ebuild
index eee25f42b285..b2801d707f75 100644
--- a/sys-apps/sed/sed-4.8.ebuild
+++ b/sys-apps/sed/sed-4.8.ebuild
@@ -12,7 +12,7 @@ SRC_URI="mirror://gnu/sed/${P}.tar.xz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
-IUSE="acl forced-sandbox nls selinux static"
+IUSE="acl nls selinux static"
RDEPEND="acl? ( virtual/acl )
nls? ( virtual/libintl )
@@ -20,33 +20,6 @@ RDEPEND="acl? ( virtual/acl )
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
-src_bootstrap_sed() {
- # make sure system-sed works #40786 #650052
- if ! type -p sed > /dev/null || has_version 'sys-apps/sed[forced-sandbox]' ; then
- mkdir -p "${T}/bootstrap"
- printf '#!/bin/sh\nexec busybox sed "$@"\n' > "${T}/bootstrap/sed" || die
- chmod a+rx "${T}/bootstrap/sed"
- PATH="${T}/bootstrap:${PATH}"
- fi
-}
-
-src_prepare() {
- # Don't use sed before bootstrap if we have to recover a broken host sed.
- src_bootstrap_sed
-
- default
-
- if use forced-sandbox ; then
- # Upstream doesn't want to add a configure flag for this.
- # https://lists.gnu.org/archive/html/bug-sed/2018-03/msg00001.html
- sed -i \
- -e '/^bool sandbox = false;/s:false:true:' \
- sed/sed.c || die
- # Make sure the sed took.
- grep -q '^bool sandbox = true;' sed/sed.c || die "forcing sandbox failed"
- fi
-}
-
src_configure() {
local myconf=()
if use userland_GNU; then