summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-01-15 08:29:53 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-01-15 08:29:53 +0100
commit5af915b3bc8f93ee928dabb130f4a45f623734b7 (patch)
tree86685f463515963fec82cf7f2e648192655b0a5e /sys-apps
parentdev-db/barman: Use HTTPS (diff)
downloadgentoo-5af915b3bc8f93ee928dabb130f4a45f623734b7.tar.gz
gentoo-5af915b3bc8f93ee928dabb130f4a45f623734b7.tar.bz2
gentoo-5af915b3bc8f93ee928dabb130f4a45f623734b7.zip
sys-apps/sed: Bump to version 4.8
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/sed/Manifest1
-rw-r--r--sys-apps/sed/sed-4.8.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/sys-apps/sed/Manifest b/sys-apps/sed/Manifest
index 6c207894fdee..5db3054460a2 100644
--- a/sys-apps/sed/Manifest
+++ b/sys-apps/sed/Manifest
@@ -1,2 +1,3 @@
DIST sed-4.5.tar.xz 1274252 BLAKE2B 08525659e0e01ec50e736c1665634f3816f57c48aeefa7f6bc7a152cd6c171bb4e96e5c215429fc5edbe6e1de6cc3efe4f2f3bf6865933a30dd1700e921d5b3f SHA512 f95fb27e03b2301dae63878413b4c48e40341cc676945a612e1d0bd911da3192858ae142791292a99fbdaacbc7dab2d6fccb50787c06846f99b0b3740b40c196
DIST sed-4.7.tar.xz 1298316 BLAKE2B 752bc2e942b6f041710c6811518147c5fa4b143b33ae842ec1f142ec914bfaf4d7e8a94a2b1a5b345789944e5426f7946997f2ccbc43ee5034351a95ce3a677e SHA512 e0be5db4cdf8226b34aaa9071bc5ae0eafde1c52227cee3512eea7fe2520d6c5cebf15266aa5c4adffbb51bf125c140a15644e28d57759893c12823ea9bbf4fb
+DIST sed-4.8.tar.xz 1348048 BLAKE2B 62f6b6500cc9a20a35cafc2b09b12bb7da67fa0afb0b1b26153babc0023424b3126f44d29eba14c25fc4490996c90738b191c9440c66da6c120bbb9bc6f6df65 SHA512 7de25d9bc2981c63321c2223f3fbcab61d7b0df4fcf7d4394b72400b91993e1288d8bf53948ed5fffcf5a98c75265726a68ad4fb98e1d571bf768603a108c1c8
diff --git a/sys-apps/sed/sed-4.8.ebuild b/sys-apps/sed/sed-4.8.ebuild
new file mode 100644
index 000000000000..eee25f42b285
--- /dev/null
+++ b/sys-apps/sed/sed-4.8.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Super-useful stream editor"
+HOMEPAGE="http://sed.sourceforge.net/"
+SRC_URI="mirror://gnu/sed/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+IUSE="acl forced-sandbox nls selinux static"
+
+RDEPEND="acl? ( virtual/acl )
+ nls? ( virtual/libintl )
+ selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_bootstrap_sed() {
+ # make sure system-sed works #40786 #650052
+ if ! type -p sed > /dev/null || has_version 'sys-apps/sed[forced-sandbox]' ; then
+ mkdir -p "${T}/bootstrap"
+ printf '#!/bin/sh\nexec busybox sed "$@"\n' > "${T}/bootstrap/sed" || die
+ chmod a+rx "${T}/bootstrap/sed"
+ PATH="${T}/bootstrap:${PATH}"
+ fi
+}
+
+src_prepare() {
+ # Don't use sed before bootstrap if we have to recover a broken host sed.
+ src_bootstrap_sed
+
+ default
+
+ if use forced-sandbox ; then
+ # Upstream doesn't want to add a configure flag for this.
+ # https://lists.gnu.org/archive/html/bug-sed/2018-03/msg00001.html
+ sed -i \
+ -e '/^bool sandbox = false;/s:false:true:' \
+ sed/sed.c || die
+ # Make sure the sed took.
+ grep -q '^bool sandbox = true;' sed/sed.c || die "forcing sandbox failed"
+ fi
+}
+
+src_configure() {
+ local myconf=()
+ if use userland_GNU; then
+ myconf+=( --exec-prefix="${EPREFIX}" )
+ else
+ myconf+=( --program-prefix=g )
+ fi
+
+ export ac_cv_search_setfilecon=$(usex selinux -lselinux)
+ export ac_cv_header_selinux_{context,selinux}_h=$(usex selinux)
+ use static && append-ldflags -static
+ myconf+=(
+ $(use_enable acl)
+ $(use_enable nls)
+ )
+ econf "${myconf[@]}"
+}