summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-09-02 21:38:13 -0400
committerMike Gilbert <floppym@gentoo.org>2017-09-02 21:38:13 -0400
commit60022877952e822d4571cccf698d812ac082497f (patch)
tree79881ff513bc0ed7c9156975611bdd9d6e3777a2 /sys-apps
parentnet-wireless/bluez: call systemd_reenable in postinst (diff)
downloadgentoo-60022877952e822d4571cccf698d812ac082497f.tar.gz
gentoo-60022877952e822d4571cccf698d812ac082497f.tar.bz2
gentoo-60022877952e822d4571cccf698d812ac082497f.zip
sys-apps/systemd: call systemd_reenable in postinst
Package-Manager: Portage-2.3.6_p39, Repoman-2.3.3_p17
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/systemd/systemd-233-r4.ebuild2
-rw-r--r--sys-apps/systemd/systemd-234-r3.ebuild2
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild2
3 files changed, 6 insertions, 0 deletions
diff --git a/sys-apps/systemd/systemd-233-r4.ebuild b/sys-apps/systemd/systemd-233-r4.ebuild
index 02b80aa41398..fe718b7fe600 100644
--- a/sys-apps/systemd/systemd-233-r4.ebuild
+++ b/sys-apps/systemd/systemd-233-r4.ebuild
@@ -442,6 +442,8 @@ pkg_postinst() {
# between OpenRC & systemd
migrate_locale
+ systemd_reenable systemd-networkd.service systemd-resolved.service
+
if [[ ${FAIL} ]]; then
eerror "One of the postinst commands failed. Please check the postinst output"
eerror "for errors. You may need to clean up your system and/or try installing"
diff --git a/sys-apps/systemd/systemd-234-r3.ebuild b/sys-apps/systemd/systemd-234-r3.ebuild
index 9ce3fc2558a4..15bf64cd7327 100644
--- a/sys-apps/systemd/systemd-234-r3.ebuild
+++ b/sys-apps/systemd/systemd-234-r3.ebuild
@@ -426,6 +426,8 @@ pkg_postinst() {
# between OpenRC & systemd
migrate_locale
+ systemd_reenable systemd-networkd.service systemd-resolved.service
+
if [[ ${FAIL} ]]; then
eerror "One of the postinst commands failed. Please check the postinst output"
eerror "for errors. You may need to clean up your system and/or try installing"
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 940031e4b38a..6be7da5ca64a 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -423,6 +423,8 @@ pkg_postinst() {
# between OpenRC & systemd
migrate_locale
+ systemd_reenable systemd-networkd.service systemd-resolved.service
+
if [[ ${FAIL} ]]; then
eerror "One of the postinst commands failed. Please check the postinst output"
eerror "for errors. You may need to clean up your system and/or try installing"