summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-06-04 11:18:01 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-06-04 11:18:17 +0200
commit725cda22cea340597d07977b800f3f1f9dd7c1ea (patch)
treeff221dae557b349e8e355f2f1dbaa6a44a0b87a9 /sys-apps
parentdev-libs/ell: Initial commit (diff)
downloadgentoo-725cda22cea340597d07977b800f3f1f9dd7c1ea.tar.gz
gentoo-725cda22cea340597d07977b800f3f1f9dd7c1ea.tar.bz2
gentoo-725cda22cea340597d07977b800f3f1f9dd7c1ea.zip
sys-apps/ipmiutil: Bump to version 3.1.1
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/ipmiutil/Manifest1
-rw-r--r--sys-apps/ipmiutil/ipmiutil-3.1.1.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/sys-apps/ipmiutil/Manifest b/sys-apps/ipmiutil/Manifest
index 38ad95b98f0e..f0dc079ba321 100644
--- a/sys-apps/ipmiutil/Manifest
+++ b/sys-apps/ipmiutil/Manifest
@@ -1,3 +1,4 @@
DIST ipmiutil-3.0.6.tar.gz 1692679 BLAKE2B dcc02dbb5467b824005dbc95c8f5231b2e2758e7600231c1c3fc31c1207cff0540400857dd1bfa83fc8b033fe0277ab23c6013f110744bff57fe4bc7b89174f9 SHA512 0c47246b7aa6a060091745d36e33aae07e7907dcad5fefb1759aac62adf48316915ce5818d2f9241e24b73be13e54fbb57046234a69c60ce56f41a933915580f
DIST ipmiutil-3.0.9.tar.gz 1697688 BLAKE2B 93ed8865cae1cea0ea4f7de4683f4698e3f75e9190cc7e0af1832ca44a08f52aa149393761f1ede3994827db78841061d54058bbe4178b5930accd3a4c225ba7 SHA512 c2c0a516216a46a52621159e665a77d96cf81f385fc9cf19877e72283be3e1a4dad5a4826454727b71576c22cc4de3c73ff428d26f35bf496c7dc1511305cda3
DIST ipmiutil-3.1.0.tar.gz 1697374 BLAKE2B 42cbe5a252fff7427f9a6eed48f110a16ecccc1e251f033ef8184b9efa7d9d184af4e83483e234fa97c1cfd964bce1c5fae756e34b5713328ed58be4d66e0fef SHA512 2089110e5c829f7bb2d97d634a543a93612503fb918d5696a17e376bf12aff160272634634652085d7f374ea39102c2bc8fc06d61ccbd50c6a76152073ea0a8c
+DIST ipmiutil-3.1.1.tar.gz 1697588 BLAKE2B 89d5f6a4b92494d5b5845a856011bf75eb6925506d7956b72efd3a258b29726f3b426185588cbf45a721c804e5e2f8203b1ba5ca132e8e907435cc2cbe5e563a SHA512 c2a7e05f85d668d6d02c990c1078d6f05c30f7ca26b5fdb4bbfe09952dcc4e9cc5eb67657ca07770fa8b0d333bc4d4a96ba845b45efe942c28342be013cf60bd
diff --git a/sys-apps/ipmiutil/ipmiutil-3.1.1.ebuild b/sys-apps/ipmiutil/ipmiutil-3.1.1.ebuild
new file mode 100644
index 000000000000..ac6d2f9004f7
--- /dev/null
+++ b/sys-apps/ipmiutil/ipmiutil-3.1.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools systemd
+
+DESCRIPTION="IPMI Management Utilities"
+HOMEPAGE="http://ipmiutil.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/openssl-1:0="
+DEPEND="${RDEPEND}
+ virtual/os-headers"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.9.8-flags.patch
+ "${FILESDIR}"/${PN}-2.9.9-lib_symlink.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e 's|-O2 -g|$(CFLAGS)|g;s|-g -O2|$(CFLAGS)|g' util/Makefile.am* || die
+ sed -i -e 's|which rpm |which we_are_gentoo_rpm_is_a_guest |' configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-systemd --enable-sha256
+}
+
+src_compile() {
+ # Ulgy workaround. Upstream is misusing the make system here
+ # and it doesn't even work.
+ # Please check on each bump if this workaround is still required.
+ pushd lib/lanplus &>/dev/null || die
+ emake || die "emake lanplus failed"
+ cp libipmi_lanplus.a .. || die
+ popd &>/dev/null || die
+
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" sysdto="${D}/$(systemd_get_systemunitdir)" install
+ dodoc -r AUTHORS ChangeLog NEWS README TODO doc/UserGuide
+
+ # Init scripts are only for Fedora
+ rm -r "${ED%/}"/etc/init.d || die 'remove initscripts failed'
+
+ if ! use static-libs ; then
+ find "${ED}" -name '*.a' -delete || die
+ fi
+}