summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRandall Vasquez <ran.dall@icloud.com>2022-04-12 06:34:17 -0700
committerSam James <sam@gentoo.org>2022-04-12 23:37:51 +0100
commit7af3ec75563c6744dba7db4bd94da818844c6039 (patch)
treeae5acc80b0603e445fb67b38f76d5624687a25b5 /sys-apps
parentapp-office/ledger: Keyword 3.2.1 riscv, #838076 (diff)
downloadgentoo-7af3ec75563c6744dba7db4bd94da818844c6039.tar.gz
gentoo-7af3ec75563c6744dba7db4bd94da818844c6039.tar.bz2
gentoo-7af3ec75563c6744dba7db4bd94da818844c6039.zip
sys-apps/fakeroot: add flag-o-matic filter for flag -fno-semantic-interposition
Bug: https://bugs.gentoo.org/834445 Bug: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=101270 Signed-off-by: Randall Vasquez <ran.dall@icloud.com> Closes: https://github.com/gentoo/gentoo/pull/25007 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/fakeroot/fakeroot-1.25.3-r1.ebuild4
-rw-r--r--sys-apps/fakeroot/fakeroot-1.26-r1.ebuild4
-rw-r--r--sys-apps/fakeroot/fakeroot-1.27.ebuild4
3 files changed, 12 insertions, 0 deletions
diff --git a/sys-apps/fakeroot/fakeroot-1.25.3-r1.ebuild b/sys-apps/fakeroot/fakeroot-1.25.3-r1.ebuild
index 1a91280d8313..801674395ecb 100644
--- a/sys-apps/fakeroot/fakeroot-1.25.3-r1.ebuild
+++ b/sys-apps/fakeroot/fakeroot-1.25.3-r1.ebuild
@@ -36,6 +36,10 @@ src_configure() {
use acl || export ac_cv_search_acl_get_fd=no # bug 759568
use debug && append-cppflags -DLIBFAKEROOT_DEBUGGING
+ # https://bugs.gentoo.org/834445
+ # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=101270
+ filter-flags -fno-semantic-interposition
+
econf --disable-static
}
diff --git a/sys-apps/fakeroot/fakeroot-1.26-r1.ebuild b/sys-apps/fakeroot/fakeroot-1.26-r1.ebuild
index eaea8a55af70..60f715a23827 100644
--- a/sys-apps/fakeroot/fakeroot-1.26-r1.ebuild
+++ b/sys-apps/fakeroot/fakeroot-1.26-r1.ebuild
@@ -47,6 +47,10 @@ src_configure() {
use acl || export ac_cv_search_acl_get_fd=no # bug 759568
use debug && append-cppflags -DLIBFAKEROOT_DEBUGGING
+ # https://bugs.gentoo.org/834445
+ # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=101270
+ filter-flags -fno-semantic-interposition
+
econf --disable-static
}
diff --git a/sys-apps/fakeroot/fakeroot-1.27.ebuild b/sys-apps/fakeroot/fakeroot-1.27.ebuild
index d033244f8182..468f9ec15684 100644
--- a/sys-apps/fakeroot/fakeroot-1.27.ebuild
+++ b/sys-apps/fakeroot/fakeroot-1.27.ebuild
@@ -47,6 +47,10 @@ src_configure() {
use acl || export ac_cv_search_acl_get_fd=no # bug 759568
use debug && append-cppflags -DLIBFAKEROOT_DEBUGGING
+ # https://bugs.gentoo.org/834445
+ # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=101270
+ filter-flags -fno-semantic-interposition
+
econf --disable-static
}