summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2016-04-08 08:19:51 +0200
committerWolfram Schlich <wschlich@gentoo.org>2016-04-08 08:20:27 +0200
commit85043246f020b391377af85cc17fb82bec33ae72 (patch)
tree1cbffc93fae37af544e7aa4621bf5e46b18495d3 /sys-apps
parentdev-ruby/ruby-shadow: drop ruby19, add ruby23 (diff)
downloadgentoo-85043246f020b391377af85cc17fb82bec33ae72.tar.gz
gentoo-85043246f020b391377af85cc17fb82bec33ae72.tar.bz2
gentoo-85043246f020b391377af85cc17fb82bec33ae72.zip
sys-apps/pcsc-lite: version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pcsc-lite/Manifest1
-rw-r--r--sys-apps/pcsc-lite/pcsc-lite-1.8.16.ebuild106
2 files changed, 107 insertions, 0 deletions
diff --git a/sys-apps/pcsc-lite/Manifest b/sys-apps/pcsc-lite/Manifest
index 003d14d9f9fa..cba824f1db74 100644
--- a/sys-apps/pcsc-lite/Manifest
+++ b/sys-apps/pcsc-lite/Manifest
@@ -2,3 +2,4 @@ DIST pcsc-lite-1.8.12.tar.bz2 580449 SHA256 f2c30a2aba6805f2859ede5f2eca351ca6c4
DIST pcsc-lite-1.8.13.tar.bz2 584083 SHA256 f315047e808d63a3262c4a040f77548af2e04d1fd707e0c2759369b926fbbc3b SHA512 ce45b48fa0da568690e25f80c8b37c201f8a6eb411c7d12a55748af16eda1d8b39984261f562c5af50ff79d7476597e3363097cb5f0b6ca8fa009d9321d02023 WHIRLPOOL 6bf25e06e26583a8a5ac7f2e7c53f85f3aee0942d838c11afa40c2c95ef4dae805a00c813a11e5eb20221f2a2004608da6fea48b00d6edd661cc728e68d1989f
DIST pcsc-lite-1.8.14.tar.bz2 689197 SHA256 b91f97806042315a41f005e69529cb968621f73f2ddfbd1380111a175b02334e SHA512 a374ee254403b57a9bb24629e1d2d867b4b2046126f06fcc9df5d2e4b1ab9e8e2daddf371082c829e40d0874d2e84a8d657240857cc928242adfbbb1516c3362 WHIRLPOOL 9a045ba14273324661e9d8dddfa4ed0bdc89ecc8bd3a06c28e428b8a84f30ca97d9dd91718c7e83dffd20fad90ddab3d02de886b75cfb080b4eb205fe9b49a78
DIST pcsc-lite-1.8.15.tar.bz2 692567 SHA256 ad8b1f3d2c59d3a966cb203fc74588629c4a5fa30f8ad9005e06ef7aa445d341 SHA512 60d3440baa39232d42ddba972e4e40eb74c7d1d98845b5f6f41de35357f92b092d20e8e2d25a9bba51198b1a31de1e64cfcc64aa7dd8568b875db9e23c6cdd1b WHIRLPOOL 01b6b012e06286def878c1c66361c786e75122fbc4a85ca9c9f26d7d484e7b18aa608391b10e9c9daac15e9e5b21ca142b90e2a0374816b46ce694804e675b81
+DIST pcsc-lite-1.8.16.tar.bz2 710247 SHA256 e7d08aa38897e86fdf632d56ac70663a3a9add3c0bf4031dc32e783f19c0688a SHA512 815b57f53adc8e820bb702a6704b2be4e9e7d772d46d4cc73d5730d3821334245c316d078a4565bbe8450fc1657a12b02ced40175ca314bf0d462c2f2599e714 WHIRLPOOL d54c5c02b2a47de535da3a3a0eca54c2dce78ca5c5ae48530c0fdbc9f77ad3a465e9eeb2a2297a7ebea565ecf93c651e3d1dd275dbc61308786717e6376cbaf9
diff --git a/sys-apps/pcsc-lite/pcsc-lite-1.8.16.ebuild b/sys-apps/pcsc-lite/pcsc-lite-1.8.16.ebuild
new file mode 100644
index 000000000000..580c77b85bad
--- /dev/null
+++ b/sys-apps/pcsc-lite/pcsc-lite-1.8.16.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1 multilib systemd udev user autotools-multilib
+
+DESCRIPTION="PC/SC Architecture smartcard middleware library"
+HOMEPAGE="http://pcsclite.alioth.debian.org/"
+
+STUPID_NUM="4164"
+MY_P="${PN}-${PV/_/-}"
+SRC_URI="http://alioth.debian.org/download.php/file/${STUPID_NUM}/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+# GPL-2 is there for the init script; everything else comes from
+# upstream.
+LICENSE="BSD ISC MIT GPL-3+ GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+# This is called libusb so that it doesn't fool people in thinking that
+# it is _required_ for USB support. Otherwise they'll disable udev and
+# that's going to be worse.
+IUSE="libusb policykit selinux +udev"
+
+REQUIRED_USE="^^ ( udev libusb )"
+
+# No dependencies need the MULTILIB_DEPS because the libraries are actually
+# standalone, the deps are only needed for the daemon itself.
+CDEPEND="${PYTHON_DEPS}
+ libusb? ( virtual/libusb:1 )
+ udev? ( virtual/udev )
+ policykit? ( >=sys-auth/polkit-0.111 )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ !<app-crypt/ccid-1.4.1-r1
+ !<sys-apps/baselayout-2
+ !<sys-apps/openrc-0.11.8
+ selinux? ( sec-policy/selinux-pcscd )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.11-polkit-pcscd.patch
+)
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+
+ enewgroup openct # make sure it exists
+ enewgroup pcscd
+ enewuser pcscd -1 -1 /run/pcscd pcscd,openct
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-maintainer-mode
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ --enable-usbdropdir="${EPREFIX}/usr/$(get_libdir)/readers/usb"
+ --enable-ipcdir=/run/pcscd
+ $(multilib_native_use_enable udev libudev)
+ $(multilib_native_use_enable libusb)
+ $(multilib_native_use_enable policykit polkit)
+ "$(systemd_with_unitdir)"
+ )
+ autotools-utils_src_configure
+}
+
+DOCS=( AUTHORS DRIVERS HELP README SECURITY ChangeLog )
+
+multilib_src_install_all() {
+ einstalldocs
+
+ newinitd "${FILESDIR}"/pcscd-init.7 pcscd
+
+ if use udev; then
+ insinto "$(get_udevdir)"/rules.d
+ doins "${FILESDIR}"/99-pcscd-hotplug.rules
+ fi
+
+ python_fix_shebang "${ED}/usr/bin"
+}
+
+pkg_postinst() {
+ elog "Starting from version 1.6.5, pcsc-lite will start as user nobody in"
+ elog "the pcscd group, to avoid running as root."
+ elog ""
+ elog "This also means you need the newest drivers available so that the"
+ elog "devices get the proper owner."
+ elog ""
+ elog "Furthermore, a conf.d file is no longer installed by default, as"
+ elog "the default configuration does not require one. If you need to"
+ elog "pass further options to pcscd, create a file and set the"
+ elog "EXTRA_OPTS variable."
+ elog ""
+ if use udev; then
+ elog "Hotplug support is provided by udev rules; you only need to tell"
+ elog "the init system to hotplug it, by setting this variable in"
+ elog "/etc/rc.conf:"
+ elog ""
+ elog " rc_hotplug=\"pcscd\""
+ fi
+}