summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-12-21 19:59:27 +1100
committerMichael Palimaka <kensington@gentoo.org>2017-12-21 20:07:35 +1100
commit934bb90b8d96dbcef70848f22a48d9349cd057aa (patch)
tree6e0c8dc09e17c89a4b614db3605e58186df10460 /sys-apps
parentdev-python/python-evdev: remove 0.6.1 (diff)
downloadgentoo-934bb90b8d96dbcef70848f22a48d9349cd057aa.tar.gz
gentoo-934bb90b8d96dbcef70848f22a48d9349cd057aa.tar.bz2
gentoo-934bb90b8d96dbcef70848f22a48d9349cd057aa.zip
sys-apps/iotools: remove 1.4
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/iotools/Manifest1
-rw-r--r--sys-apps/iotools/iotools-1.4.ebuild51
2 files changed, 0 insertions, 52 deletions
diff --git a/sys-apps/iotools/Manifest b/sys-apps/iotools/Manifest
index 3fdf3694d690..a1ec70fba77e 100644
--- a/sys-apps/iotools/Manifest
+++ b/sys-apps/iotools/Manifest
@@ -1,2 +1 @@
-DIST iotools-1.4.tar.gz 22217 BLAKE2B 71edca870ccdd645a39d385790e0adffe8b1da6d1f09c9c4d2e7169b6bfb9bde2d9554b3b3b789cac1749b93e9468fe430a983005e28862c6636c86d2b0c953a SHA512 10b5f5c4183fb78900c254359b1d40d681519d4b0a79d10795c44d6f1691d73b93d02ede57cf84b5bac67e6083bc5a0de45c464caccbad8b2127a2c53cd7e94b
DIST iotools-1.5.tar.gz 23422 BLAKE2B 7d647a32e0289e6b85055252eb6ccf9bdb71b99ebdec7e0c1de0d60157c7401e462a07422e0dd25fb3aec42744be981cd927a4c359b577a764acef331bd42bbe SHA512 d298343ee814c8b7d8404bc6af4050df730e89963a7c53798b3d251e94fd2b13e04c36e6da7ec5fd4126ea3a961be26a937910f791844e1b1d5b7dc5aa638c44
diff --git a/sys-apps/iotools/iotools-1.4.ebuild b/sys-apps/iotools/iotools-1.4.ebuild
deleted file mode 100644
index 4b470a70670e..000000000000
--- a/sys-apps/iotools/iotools-1.4.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Simple commands to access hardware device registers"
-HOMEPAGE="https://code.google.com/p/iotools/"
-SRC_URI="https://iotools.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="static make-symlinks"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-cpuid-pic.patch
- epatch "${FILESDIR}"/${P}-ldflags.patch
- sed -i 's:-Werror::' Makefile || die
-}
-
-src_compile() {
- emake \
- CC="$(tc-getCC)" \
- STATIC=$(usex static 1 0) \
- IOTOOLS_DEBUG="${CFLAGS}"
-}
-
-src_install() {
- dosbin iotools
-
- # Note: This is done manually because invoking the iotools binary
- # when cross-compiling will likely fail.
- local known_cmds="and btr bts busy_loop cmos_read cmos_write cpu_list cpuid io_read16 io_read32 io_read8 io_write16 io_write32 io_write8 mmio_dump mmio_read16 mmio_read32 mmio_read64 mmio_read8 mmio_write16 mmio_write32 mmio_write64 mmio_write8 not or pci_list pci_read16 pci_read32 pci_read8 pci_write16 pci_write32 pci_write8 rdmsr rdtsc runon shl shr smbus_quick smbus_read16 smbus_read8 smbus_readblock smbus_receive_byte smbus_send_byte smbus_write16 smbus_write8 smbus_writeblock wrmsr xor"
- if ! tc-is-cross-compiler ; then
- local check_cmds=$(echo $(./iotools --list-cmds 2>/dev/null | grep '^ ' | LC_ALL=C sort))
- if [[ ${known_cmds} != "${check_cmds:-${known_cmds}}" ]] ; then
- eerror "known_cmds = ${known_cmds}"
- eerror "check_cmds = ${check_cmds}"
- die "need to update known_cmds cache in the ebuild"
- fi
- fi
-
- if use make-symlinks ; then
- local cmd
- for cmd in ${known_cmds} ; do
- dosym iotools /usr/sbin/${cmd}
- done
- fi
-}