summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-08-16 02:51:29 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-08-16 02:53:41 +0200
commit9592c7dbfb4460198368d0e91406038fd439f669 (patch)
treec75645e7c2ff31eeeb22fd95c5737463635f67f4 /sys-apps
parentsys-apps/logwatch: drop old (diff)
downloadgentoo-9592c7dbfb4460198368d0e91406038fd439f669.tar.gz
gentoo-9592c7dbfb4460198368d0e91406038fd439f669.tar.bz2
gentoo-9592c7dbfb4460198368d0e91406038fd439f669.zip
sys-apps/logwatch: bump to v7.5.4
Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/logwatch/Manifest1
-rw-r--r--sys-apps/logwatch/logwatch-7.5.4.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/sys-apps/logwatch/Manifest b/sys-apps/logwatch/Manifest
index 724bde2b08ea..079b34e6eb14 100644
--- a/sys-apps/logwatch/Manifest
+++ b/sys-apps/logwatch/Manifest
@@ -1 +1,2 @@
DIST logwatch-7.5.3.tar.gz 495110 BLAKE2B b28d7381d259a132de7d9fd347ac4bafb44440b187aa811f3d3f65d7b1ccbb00c6b5bb660229cd8155fa5d7bc9668e7b4dd1ebe7bbb909b48367c6a6dd6793e5 SHA512 ad404f031fe016599a8f8d8c0820b23db61a9ad102815d3713e5d13e9a810c819ca7ad9cea50891852982e073ef033dbe7595fde8846971336148e32cbbe29ca
+DIST logwatch-7.5.4.tar.gz 481766 BLAKE2B d86ae3afc33a100fc353948be3591cd13566568d47cad02fa5f390882a223ca9d4d78692214f2f0898fa8bf8687314f60ad9ce02f0987bb86dd7136150a1d2b9 SHA512 6e6a5e8b7ae977244ea97895e06cccde320fce3dfbd2b1c58c945fc8872325a9676c8afe122b1f7230cb6617b64813caf90ef37fc472a1b200eb0b24ea72fa9b
diff --git a/sys-apps/logwatch/logwatch-7.5.4.ebuild b/sys-apps/logwatch/logwatch-7.5.4.ebuild
new file mode 100644
index 000000000000..6b03d4907f51
--- /dev/null
+++ b/sys-apps/logwatch/logwatch-7.5.4.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit tmpfiles
+
+PATCHES=()
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/logwatch/git ${PN}"
+ inherit git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+DESCRIPTION="Analyzes and Reports on system logs"
+HOMEPAGE="http://www.logwatch.org/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="virtual/cron
+ virtual/mta
+ virtual/mailx
+ dev-lang/perl
+ dev-perl/Date-Calc
+ dev-perl/Date-Manip
+ dev-perl/Tie-IxHash
+ dev-perl/Sys-CPU
+ dev-perl/Sys-MemInfo"
+
+src_install() {
+ dodir /usr/share/logwatch/lib
+ dodir /usr/share/logwatch/scripts/services
+ dodir /usr/share/logwatch/scripts/shared
+ dodir /usr/share/logwatch/default.conf/logfiles
+ dodir /usr/share/logwatch/default.conf/services
+ dodir /usr/share/logwatch/default.conf/html
+ keepdir /etc/logwatch
+
+ # logwatch.pl requires cache dir (bug #607668)
+ newtmpfiles "${FILESDIR}"/logwatch.tmpfile ${PN}.conf
+
+ newsbin scripts/logwatch.pl logwatch.pl
+
+ exeinto /usr/share/logwatch/lib
+ doexe lib/*.pm
+
+ exeinto /usr/share/logwatch/scripts/services
+ doexe scripts/services/*
+
+ exeinto /usr/share/logwatch/scripts/shared
+ doexe scripts/shared/*
+
+ insinto /usr/share/logwatch/default.conf
+ doins conf/logwatch.conf
+
+ insinto /usr/share/logwatch/default.conf/logfiles
+ doins conf/logfiles/*
+
+ insinto /usr/share/logwatch/default.conf/services
+ doins conf/services/*
+
+ insinto /usr/share/logwatch/default.conf/html
+ doins conf/html/*
+
+ # Make sure logwatch is run before anything else #100243
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/logwatch 00-logwatch
+
+ doman logwatch.8
+ dodoc README HOWTO-Customize-LogWatch
+
+ # Do last due to insopts modification.
+ insinto /usr/share/logwatch/scripts/logfiles
+ insopts -m755
+ doins -r scripts/logfiles/*
+}
+
+pkg_postinst() {
+ # Migration from /etc/cron.daily/logwatch -> /etc/cron.daily/00-logwatch (bug #100243)
+ if [[ -e ${ROOT}/etc/cron.daily/logwatch ]] ; then
+ local md5=$(md5sum "${ROOT}"/etc/cron.daily/logwatch)
+ [[ ${md5} == "edb003cbc0686ed4cf37db16025635f3" ]] \
+ && rm -f "${ROOT}"/etc/cron.daily/logwatch \
+ || ewarn "You have two logwatch files in /etc/cron.daily/"
+ fi
+
+ # Trigger cache dir creation to allow immediate use of logwatch (bug #607668)
+ tmpfiles_process ${PN}.conf
+}