summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-04-16 16:31:44 -0400
committerMike Gilbert <floppym@gentoo.org>2016-04-16 16:32:05 -0400
commit9fa567f59170f6a859e83c6ca2dfccf969632896 (patch)
treebf1920d346b05383b38991bac42b515fa7204ba9 /sys-apps
parentpackage.mask: Mask monitorix-{3.6.0,3.8.1} because of security bug 580210 (diff)
downloadgentoo-9fa567f59170f6a859e83c6ca2dfccf969632896.tar.gz
gentoo-9fa567f59170f6a859e83c6ca2dfccf969632896.tar.bz2
gentoo-9fa567f59170f6a859e83c6ca2dfccf969632896.zip
sys-apps/systemd: Backport sysmacros fix
Package-Manager: portage-2.2.28_p3
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/systemd/files/229-sysmacros.patch79
-rw-r--r--sys-apps/systemd/systemd-229-r100.ebuild1
-rw-r--r--sys-apps/systemd/systemd-229.ebuild1
3 files changed, 81 insertions, 0 deletions
diff --git a/sys-apps/systemd/files/229-sysmacros.patch b/sys-apps/systemd/files/229-sysmacros.patch
new file mode 100644
index 000000000000..7b0dfbf46d68
--- /dev/null
+++ b/sys-apps/systemd/files/229-sysmacros.patch
@@ -0,0 +1,79 @@
+From 27d13af71c3af6b2f9b60556d2c046dbb6e36e23 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Mon, 14 Mar 2016 17:44:49 -0400
+Subject: [PATCH] include sys/sysmacros.h in more places
+
+Since glibc is moving away from implicitly including sys/sysmacros.h
+all the time via sys/types.h, include the header directly in more
+places. This seems to cover most makedev/major/minor usage.
+---
+ src/basic/macro.h | 1 +
+ src/basic/util.h | 1 +
+ src/libudev/libudev.h | 1 +
+ src/systemd/sd-device.h | 1 +
+ src/udev/udev.h | 1 +
+ 5 files changed, 5 insertions(+)
+
+diff --git a/src/basic/macro.h b/src/basic/macro.h
+index c34441d..b36a956 100644
+--- a/src/basic/macro.h
++++ b/src/basic/macro.h
+@@ -23,6 +23,7 @@
+ #include <inttypes.h>
+ #include <stdbool.h>
+ #include <sys/param.h>
++#include <sys/sysmacros.h>
+ #include <sys/types.h>
+
+ #define _printf_(a,b) __attribute__ ((format (printf, a, b)))
+diff --git a/src/basic/util.h b/src/basic/util.h
+index e095254..286db05 100644
+--- a/src/basic/util.h
++++ b/src/basic/util.h
+@@ -36,6 +36,7 @@
+ #include <sys/socket.h>
+ #include <sys/stat.h>
+ #include <sys/statfs.h>
++#include <sys/sysmacros.h>
+ #include <sys/types.h>
+ #include <time.h>
+ #include <unistd.h>
+diff --git a/src/libudev/libudev.h b/src/libudev/libudev.h
+index eb58740..3f6d0ed 100644
+--- a/src/libudev/libudev.h
++++ b/src/libudev/libudev.h
+@@ -21,6 +21,7 @@
+ #define _LIBUDEV_H_
+
+ #include <stdarg.h>
++#include <sys/sysmacros.h>
+ #include <sys/types.h>
+
+ #ifdef __cplusplus
+diff --git a/src/systemd/sd-device.h b/src/systemd/sd-device.h
+index 5bfca6e..c1d0756 100644
+--- a/src/systemd/sd-device.h
++++ b/src/systemd/sd-device.h
+@@ -22,6 +22,7 @@
+ ***/
+
+ #include <inttypes.h>
++#include <sys/sysmacros.h>
+ #include <sys/types.h>
+
+ #include "_sd-common.h"
+diff --git a/src/udev/udev.h b/src/udev/udev.h
+index 5659051..8433e8d 100644
+--- a/src/udev/udev.h
++++ b/src/udev/udev.h
+@@ -19,6 +19,7 @@
+ */
+
+ #include <sys/param.h>
++#include <sys/sysmacros.h>
+ #include <sys/types.h>
+
+ #include "libudev.h"
+--
+2.8.1
+
diff --git a/sys-apps/systemd/systemd-229-r100.ebuild b/sys-apps/systemd/systemd-229-r100.ebuild
index cd9d4466dd89..66357cf7af4c 100644
--- a/sys-apps/systemd/systemd-229-r100.ebuild
+++ b/sys-apps/systemd/systemd-229-r100.ebuild
@@ -153,6 +153,7 @@ src_prepare() {
"${FILESDIR}/218-Dont-enable-audit-by-default.patch"
"${FILESDIR}/228-noclean-tmp.patch"
"${FILESDIR}/linux-headers-if.h.patch"
+ "${FILESDIR}/229-sysmacros.patch"
)
[[ -d "${WORKDIR}"/patches ]] && PATCHES+=( "${WORKDIR}"/patches )
diff --git a/sys-apps/systemd/systemd-229.ebuild b/sys-apps/systemd/systemd-229.ebuild
index 0a35d504a89f..0c297d222f00 100644
--- a/sys-apps/systemd/systemd-229.ebuild
+++ b/sys-apps/systemd/systemd-229.ebuild
@@ -153,6 +153,7 @@ src_prepare() {
"${FILESDIR}/218-Dont-enable-audit-by-default.patch"
"${FILESDIR}/228-noclean-tmp.patch"
"${FILESDIR}/linux-headers-if.h.patch"
+ "${FILESDIR}/229-sysmacros.patch"
)
[[ -d "${WORKDIR}"/patches ]] && PATCHES+=( "${WORKDIR}"/patches )