summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-11-24 15:47:34 -0500
committerMike Frysinger <vapier@gentoo.org>2015-11-24 17:01:27 -0500
commita5371bbe754e942377e7778e715ebe7ce3126a31 (patch)
tree9ae246246de1ded3d64e9953ec5e4fb6e7682429 /sys-apps
parentstandardize various metadata.xml style (diff)
downloadgentoo-a5371bbe754e942377e7778e715ebe7ce3126a31.tar.gz
gentoo-a5371bbe754e942377e7778e715ebe7ce3126a31.tar.bz2
gentoo-a5371bbe754e942377e7778e715ebe7ce3126a31.zip
sys-process/procps, sys-apps/{coreutils,util-linux}: add USE=kill to install `kill` #566264
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/coreutils/coreutils-8.24.ebuild22
-rw-r--r--sys-apps/coreutils/metadata.xml1
-rw-r--r--sys-apps/util-linux/metadata.xml1
-rw-r--r--sys-apps/util-linux/util-linux-2.27.1.ebuild25
-rw-r--r--sys-apps/util-linux/util-linux-9999.ebuild25
5 files changed, 45 insertions, 29 deletions
diff --git a/sys-apps/coreutils/coreutils-8.24.ebuild b/sys-apps/coreutils/coreutils-8.24.ebuild
index 5b88e1c96f5f..8b60db7a46be 100644
--- a/sys-apps/coreutils/coreutils-8.24.ebuild
+++ b/sys-apps/coreutils/coreutils-8.24.ebuild
@@ -24,7 +24,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
-IUSE="acl caps gmp multicall nls selinux static userland_BSD vanilla xattr"
+IUSE="acl caps gmp kill multicall nls selinux static userland_BSD vanilla xattr"
LIB_DEPEND="acl? ( sys-apps/acl[static-libs] )
caps? ( sys-libs/libcap )
@@ -32,18 +32,22 @@ LIB_DEPEND="acl? ( sys-apps/acl[static-libs] )
xattr? ( !userland_BSD? ( sys-apps/attr[static-libs] ) )"
RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs]} )
selinux? ( sys-libs/libselinux )
- nls? ( virtual/libintl )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )
+ app-arch/xz-utils"
+RDEPEND+="
+ kill? (
+ !sys-apps/util-linux[kill]
+ !sys-process/procps[kill]
+ )
!app-misc/realpath
!<sys-apps/util-linux-2.13
!sys-apps/stat
!net-mail/base64
!sys-apps/mktemp
!<app-forensics/tct-1.18-r1
- !<net-fs/netatalk-2.0.3-r4
-"
-DEPEND="${RDEPEND}
- static? ( ${LIB_DEPEND} )
- app-arch/xz-utils"
+ !<net-fs/netatalk-2.0.3-r4"
src_prepare() {
if ! use vanilla ; then
@@ -87,8 +91,8 @@ src_configure() {
--with-packager="Gentoo" \
--with-packager-version="${PVR} (p${PATCH_VER:-0})" \
--with-packager-bug-reports="https://bugs.gentoo.org/" \
- --enable-install-program="arch" \
- --enable-no-install-program="groups,hostname,kill,su,uptime" \
+ --enable-install-program="arch,$(usev kill)" \
+ --enable-no-install-program="groups,hostname,$(usev !kill),su,uptime" \
--enable-largefile \
$(use caps || echo --disable-libcap) \
$(use_enable nls) \
diff --git a/sys-apps/coreutils/metadata.xml b/sys-apps/coreutils/metadata.xml
index 1ef77adc1fc5..95b8f3e0f807 100644
--- a/sys-apps/coreutils/metadata.xml
+++ b/sys-apps/coreutils/metadata.xml
@@ -3,6 +3,7 @@
<pkgmetadata>
<herd>base-system</herd>
<use>
+ <flag name='kill'>Build the kill program</flag>
<flag name='multicall'>Build all tools into a single `coreutils` program akin to busybox to save space</flag>
</use>
<upstream>
diff --git a/sys-apps/util-linux/metadata.xml b/sys-apps/util-linux/metadata.xml
index 5dd62eaab28d..cdf5dc7c323b 100644
--- a/sys-apps/util-linux/metadata.xml
+++ b/sys-apps/util-linux/metadata.xml
@@ -7,6 +7,7 @@
<flag name='cramfs'>build mkfs/fsck helpers for cramfs filesystems</flag>
<flag name='cytune'>build cytune for Cyclades-Z multiport serial cards</flag>
<flag name='fdformat'>build fdformat (floppy disk format)</flag>
+ <flag name='kill'>build the kill program</flag>
<flag name='pam'>build runuser helper</flag>
<flag name='suid'>
install mount/umount as setuid so non-root users may mount/umount devices,
diff --git a/sys-apps/util-linux/util-linux-2.27.1.ebuild b/sys-apps/util-linux/util-linux-2.27.1.ebuild
index 95c5785af85e..d8760725199c 100644
--- a/sys-apps/util-linux/util-linux-2.27.1.ebuild
+++ b/sys-apps/util-linux/util-linux-2.27.1.ebuild
@@ -25,16 +25,9 @@ HOMEPAGE="https://www.kernel.org/pub/linux/utils/util-linux/"
LICENSE="GPL-2 LGPL-2.1 BSD-4 MIT public-domain"
SLOT="0"
-IUSE="caps +cramfs fdformat ncurses nls pam python selinux slang static-libs +suid systemd test tty-helpers udev unicode"
+IUSE="caps +cramfs fdformat kill ncurses nls pam python selinux slang static-libs +suid systemd test tty-helpers udev unicode"
-RDEPEND="!sys-process/schedutils
- !sys-apps/setarch
- !<sys-apps/sysvinit-2.88-r7
- !sys-block/eject
- !<sys-libs/e2fsprogs-libs-1.41.8
- !<sys-fs/e2fsprogs-1.41.8
- !<app-shells/bash-completion-1.3-r2
- caps? ( sys-libs/libcap-ng )
+RDEPEND="caps? ( sys-libs/libcap-ng )
cramfs? ( sys-libs/zlib )
ncurses? ( >=sys-libs/ncurses-5.2-r2:0=[unicode?] )
pam? ( sys-libs/pam )
@@ -52,6 +45,18 @@ DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )
test? ( sys-devel/bc )
virtual/os-headers"
+RDEPEND+="
+ kill? (
+ !sys-apps/coreutils[kill]
+ !sys-process/procps[kill]
+ )
+ !sys-process/schedutils
+ !sys-apps/setarch
+ !<sys-apps/sysvinit-2.88-r7
+ !sys-block/eject
+ !<sys-libs/e2fsprogs-libs-1.41.8
+ !<sys-fs/e2fsprogs-1.41.8
+ !<app-shells/bash-completion-1.3-r2"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -103,7 +108,7 @@ multilib_src_configure() {
$(multilib_native_use_enable cramfs) \
$(multilib_native_use_enable fdformat) \
--with-ncurses=$(multilib_native_usex ncurses $(usex unicode auto yes) no) \
- --disable-kill \
+ $(use_enable kill) \
--disable-login \
$(multilib_native_use_enable tty-helpers mesg) \
--disable-nologin \
diff --git a/sys-apps/util-linux/util-linux-9999.ebuild b/sys-apps/util-linux/util-linux-9999.ebuild
index 95c5785af85e..d8760725199c 100644
--- a/sys-apps/util-linux/util-linux-9999.ebuild
+++ b/sys-apps/util-linux/util-linux-9999.ebuild
@@ -25,16 +25,9 @@ HOMEPAGE="https://www.kernel.org/pub/linux/utils/util-linux/"
LICENSE="GPL-2 LGPL-2.1 BSD-4 MIT public-domain"
SLOT="0"
-IUSE="caps +cramfs fdformat ncurses nls pam python selinux slang static-libs +suid systemd test tty-helpers udev unicode"
+IUSE="caps +cramfs fdformat kill ncurses nls pam python selinux slang static-libs +suid systemd test tty-helpers udev unicode"
-RDEPEND="!sys-process/schedutils
- !sys-apps/setarch
- !<sys-apps/sysvinit-2.88-r7
- !sys-block/eject
- !<sys-libs/e2fsprogs-libs-1.41.8
- !<sys-fs/e2fsprogs-1.41.8
- !<app-shells/bash-completion-1.3-r2
- caps? ( sys-libs/libcap-ng )
+RDEPEND="caps? ( sys-libs/libcap-ng )
cramfs? ( sys-libs/zlib )
ncurses? ( >=sys-libs/ncurses-5.2-r2:0=[unicode?] )
pam? ( sys-libs/pam )
@@ -52,6 +45,18 @@ DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )
test? ( sys-devel/bc )
virtual/os-headers"
+RDEPEND+="
+ kill? (
+ !sys-apps/coreutils[kill]
+ !sys-process/procps[kill]
+ )
+ !sys-process/schedutils
+ !sys-apps/setarch
+ !<sys-apps/sysvinit-2.88-r7
+ !sys-block/eject
+ !<sys-libs/e2fsprogs-libs-1.41.8
+ !<sys-fs/e2fsprogs-1.41.8
+ !<app-shells/bash-completion-1.3-r2"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -103,7 +108,7 @@ multilib_src_configure() {
$(multilib_native_use_enable cramfs) \
$(multilib_native_use_enable fdformat) \
--with-ncurses=$(multilib_native_usex ncurses $(usex unicode auto yes) no) \
- --disable-kill \
+ $(use_enable kill) \
--disable-login \
$(multilib_native_use_enable tty-helpers mesg) \
--disable-nologin \