summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2016-12-16 03:19:54 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2016-12-16 03:19:54 +0000
commitb344838b2bf502e13360d1f61a98973210d407b5 (patch)
tree671caa85c3148ad487cfda60d8bf58161b0e6beb /sys-apps
parentsys-kernel/gentoo-sources: Linux patch 4.4.39 (diff)
downloadgentoo-b344838b2bf502e13360d1f61a98973210d407b5.tar.gz
gentoo-b344838b2bf502e13360d1f61a98973210d407b5.tar.bz2
gentoo-b344838b2bf502e13360d1f61a98973210d407b5.zip
Version bump to 1.8.19.
Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pcsc-lite/Manifest1
-rw-r--r--sys-apps/pcsc-lite/pcsc-lite-1.8.19.ebuild109
2 files changed, 110 insertions, 0 deletions
diff --git a/sys-apps/pcsc-lite/Manifest b/sys-apps/pcsc-lite/Manifest
index d4e44c629d82..1e46c3013292 100644
--- a/sys-apps/pcsc-lite/Manifest
+++ b/sys-apps/pcsc-lite/Manifest
@@ -1,2 +1,3 @@
DIST pcsc-lite-1.8.12.tar.bz2 580449 SHA256 f2c30a2aba6805f2859ede5f2eca351ca6c495a18d5d36d74c63e7898b353c51 SHA512 b0ed94187052e0ff73030ecf9f5165d4f8dc4a7f1eb05c6c57c0e5552ae6699c53f12cd72e09812de3c55be86a08ab060a92ad08b5db2686dfa1afbaca336d87 WHIRLPOOL c6feed97170a640b6ee86e2188a124995acf73f618cfc5d4f1cf68a7f8da5955330a255b211606ebb5d50d58a4cfad859a7004fddf06c6476838458e3b7162c3
DIST pcsc-lite-1.8.16.tar.bz2 710247 SHA256 e7d08aa38897e86fdf632d56ac70663a3a9add3c0bf4031dc32e783f19c0688a SHA512 815b57f53adc8e820bb702a6704b2be4e9e7d772d46d4cc73d5730d3821334245c316d078a4565bbe8450fc1657a12b02ced40175ca314bf0d462c2f2599e714 WHIRLPOOL d54c5c02b2a47de535da3a3a0eca54c2dce78ca5c5ae48530c0fdbc9f77ad3a465e9eeb2a2297a7ebea565ecf93c651e3d1dd275dbc61308786717e6376cbaf9
+DIST pcsc-lite-1.8.19.tar.bz2 744283 SHA256 b65e25ec6dd1328983b424ce1a649e2993b1c4c59fc87252689b5fa7037c4340 SHA512 df723be60495cc4632c1c2ccf7c60d28bd9b2b56e4bceb60fe59bfd756cb2ddbded1bce8c3e021e713d353ada9438fe4f4ce138efa42d604e6bdc5d2367f827a WHIRLPOOL 3c136ff871e4bbb15bc09f13a41917ea2269b5478c0f56205f6735703118c6e4ca3ab654a3bcc5fc136ccad15cb0c2f15e9cf6bb58dd6343ab6e4e44246b0ece
diff --git a/sys-apps/pcsc-lite/pcsc-lite-1.8.19.ebuild b/sys-apps/pcsc-lite/pcsc-lite-1.8.19.ebuild
new file mode 100644
index 000000000000..0ed5039967a6
--- /dev/null
+++ b/sys-apps/pcsc-lite/pcsc-lite-1.8.19.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1 systemd udev user multilib-minimal
+
+DESCRIPTION="PC/SC Architecture smartcard middleware library"
+HOMEPAGE="http://pcsclite.alioth.debian.org/"
+
+STUPID_NUM="4198"
+MY_P="${PN}-${PV/_/-}"
+SRC_URI="http://alioth.debian.org/download.php/file/${STUPID_NUM}/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+# GPL-2 is there for the init script; everything else comes from
+# upstream.
+LICENSE="BSD ISC MIT GPL-3+ GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+# This is called libusb so that it doesn't fool people in thinking that
+# it is _required_ for USB support. Otherwise they'll disable udev and
+# that's going to be worse.
+IUSE="python libusb policykit selinux +udev"
+
+REQUIRED_USE="^^ ( udev libusb ) \
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+# No dependencies need the MULTILIB_DEPS because the libraries are actually
+# standalone, the deps are only needed for the daemon itself.
+CDEPEND="libusb? ( virtual/libusb:1 )
+ udev? ( virtual/udev )
+ policykit? ( >=sys-auth/polkit-0.111 )
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ !<app-crypt/ccid-1.4.1-r1
+ !<sys-apps/baselayout-2
+ !<sys-apps/openrc-0.11.8
+ selinux? ( sec-policy/selinux-pcscd )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.11-polkit-pcscd.patch
+)
+
+DOCS=( AUTHORS DRIVERS HELP README SECURITY ChangeLog )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+ enewgroup openct # make sure it exists
+ enewgroup pcscd
+ enewuser pcscd -1 -1 /run/pcscd pcscd,openct
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-maintainer-mode \
+ --enable-usbdropdir="${EPREFIX}/usr/$(get_libdir)/readers/usb" \
+ --enable-ipcdir=/run/pcscd \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+ $(multilib_native_use_enable udev libudev) \
+ $(multilib_native_use_enable libusb) \
+ $(multilib_native_use_enable policykit polkit)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ newinitd "${FILESDIR}"/pcscd-init.7 pcscd
+
+ if use udev; then
+ insinto "$(get_udevdir)"/rules.d
+ doins "${FILESDIR}"/99-pcscd-hotplug.rules
+ fi
+
+ for f in "${ED}/usr/bin/pcsc-spy"; do
+ if use python; then
+ python_fix_shebang "${f}"
+ else
+ rm "${f}"
+ fi
+ done
+}
+
+pkg_postinst() {
+ elog "Starting from version 1.6.5, pcsc-lite will start as user nobody in"
+ elog "the pcscd group, to avoid running as root."
+ elog ""
+ elog "This also means you need the newest drivers available so that the"
+ elog "devices get the proper owner."
+ elog ""
+ elog "Furthermore, a conf.d file is no longer installed by default, as"
+ elog "the default configuration does not require one. If you need to"
+ elog "pass further options to pcscd, create a file and set the"
+ elog "EXTRA_OPTS variable."
+ elog ""
+ if use udev; then
+ elog "Hotplug support is provided by udev rules; you only need to tell"
+ elog "the init system to hotplug it, by setting this variable in"
+ elog "/etc/rc.conf:"
+ elog ""
+ elog " rc_hotplug=\"pcscd\""
+ fi
+}