summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-04-18 12:57:03 -0400
committerMike Frysinger <vapier@gentoo.org>2016-04-18 12:57:18 -0400
commitb916e6674d101f748394f4899d9f804672e0b064 (patch)
tree851257df8b73467dd5069626d81891415d7359c6 /sys-apps
parentwww-servers/tomcat: version bump (diff)
downloadgentoo-b916e6674d101f748394f4899d9f804672e0b064.tar.gz
gentoo-b916e6674d101f748394f4899d9f804672e0b064.tar.bz2
gentoo-b916e6674d101f748394f4899d9f804672e0b064.zip
sys-apps/hdparm: fix building w/newer glibc #580052
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hdparm/files/hdparm-9.48-sysmacros.patch23
-rw-r--r--sys-apps/hdparm/hdparm-9.48.ebuild3
2 files changed, 25 insertions, 1 deletions
diff --git a/sys-apps/hdparm/files/hdparm-9.48-sysmacros.patch b/sys-apps/hdparm/files/hdparm-9.48-sysmacros.patch
new file mode 100644
index 000000000000..98a08c7d36d0
--- /dev/null
+++ b/sys-apps/hdparm/files/hdparm-9.48-sysmacros.patch
@@ -0,0 +1,23 @@
+https://bugs.gentoo.org/580052
+https://sourceforge.net/p/hdparm/patches/44/
+
+--- a/geom.c
++++ b/geom.c
+@@ -15,6 +15,7 @@
+ #include <errno.h>
+ #include <dirent.h>
+ #include <sys/stat.h>
++#include <sys/sysmacros.h>
+ #include <sys/ioctl.h>
+ #include <linux/types.h>
+ #include <linux/fs.h>
+--- a/sysfs.c
++++ b/sysfs.c
+@@ -15,6 +15,7 @@
+ #include <dirent.h>
+ #include <limits.h>
+ #include <sys/stat.h>
++#include <sys/sysmacros.h>
+ #include <linux/types.h>
+
+ #include "hdparm.h"
diff --git a/sys-apps/hdparm/hdparm-9.48.ebuild b/sys-apps/hdparm/hdparm-9.48.ebuild
index 6a777fda7a6d..8a087e8bce35 100644
--- a/sys-apps/hdparm/hdparm-9.48.ebuild
+++ b/sys-apps/hdparm/hdparm-9.48.ebuild
@@ -4,7 +4,7 @@
EAPI="4"
-inherit toolchain-funcs flag-o-matic
+inherit toolchain-funcs flag-o-matic eutils
DESCRIPTION="Utility to change hard drive performance parameters"
HOMEPAGE="http://sourceforge.net/projects/hdparm/"
@@ -16,6 +16,7 @@ KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc
IUSE="static"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-sysmacros.patch #580052
use static && append-ldflags -static
sed -i \
-e "/^CFLAGS/ s:-O2:${CFLAGS}:" \