summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-04-09 21:05:07 -0400
committerMike Gilbert <floppym@gentoo.org>2016-04-09 21:05:35 -0400
commitc008e237dd1dfd1139373e4e6287e95f94c60346 (patch)
tree51a57d462c9061b5a1dce4309438ffec7a9b4a45 /sys-apps
parentwww-servers/nginx: Version bump to 1.9.14 (diff)
downloadgentoo-c008e237dd1dfd1139373e4e6287e95f94c60346.tar.gz
gentoo-c008e237dd1dfd1139373e4e6287e95f94c60346.tar.bz2
gentoo-c008e237dd1dfd1139373e4e6287e95f94c60346.zip
sys-apps/systemd: Add workaround for if.h conflict
Bug: https://bugs.gentoo.org/577660 Package-Manager: portage-2.2.28_p3
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/systemd/files/linux-headers-if.h.patch34
-rw-r--r--sys-apps/systemd/systemd-229-r100.ebuild1
-rw-r--r--sys-apps/systemd/systemd-229.ebuild1
3 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/systemd/files/linux-headers-if.h.patch b/sys-apps/systemd/files/linux-headers-if.h.patch
new file mode 100644
index 000000000000..d0c38a932b7b
--- /dev/null
+++ b/sys-apps/systemd/files/linux-headers-if.h.patch
@@ -0,0 +1,34 @@
+From 96b90055e1e21417d4beb973fcb62858d7c69c17 Mon Sep 17 00:00:00 2001
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Sat, 9 Apr 2016 18:07:02 -0400
+Subject: [PATCH] Work around net/if.h / linux/if.h conflict
+
+---
+ src/shared/firewall-util.c | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/src/shared/firewall-util.c b/src/shared/firewall-util.c
+index 0d3da2e..521e09c 100644
+--- a/src/shared/firewall-util.c
++++ b/src/shared/firewall-util.c
+@@ -17,14 +17,16 @@
+ along with systemd; If not, see <http://www.gnu.org/licenses/>.
+ ***/
+
++#define _NET_IF_H 1
++
+ #include <alloca.h>
+ #include <arpa/inet.h>
+ #include <endian.h>
+ #include <errno.h>
+-#include <net/if.h>
+ #include <stddef.h>
+ #include <string.h>
+ #include <sys/socket.h>
++#include <linux/if.h>
+ #include <linux/netfilter_ipv4/ip_tables.h>
+ #include <linux/netfilter/nf_nat.h>
+ #include <linux/netfilter/xt_addrtype.h>
+--
+2.8.1
+
diff --git a/sys-apps/systemd/systemd-229-r100.ebuild b/sys-apps/systemd/systemd-229-r100.ebuild
index 0a7cf4deb07d..cd9d4466dd89 100644
--- a/sys-apps/systemd/systemd-229-r100.ebuild
+++ b/sys-apps/systemd/systemd-229-r100.ebuild
@@ -152,6 +152,7 @@ src_prepare() {
local PATCHES=(
"${FILESDIR}/218-Dont-enable-audit-by-default.patch"
"${FILESDIR}/228-noclean-tmp.patch"
+ "${FILESDIR}/linux-headers-if.h.patch"
)
[[ -d "${WORKDIR}"/patches ]] && PATCHES+=( "${WORKDIR}"/patches )
diff --git a/sys-apps/systemd/systemd-229.ebuild b/sys-apps/systemd/systemd-229.ebuild
index 70ec90f8afc7..0a35d504a89f 100644
--- a/sys-apps/systemd/systemd-229.ebuild
+++ b/sys-apps/systemd/systemd-229.ebuild
@@ -152,6 +152,7 @@ src_prepare() {
local PATCHES=(
"${FILESDIR}/218-Dont-enable-audit-by-default.patch"
"${FILESDIR}/228-noclean-tmp.patch"
+ "${FILESDIR}/linux-headers-if.h.patch"
)
[[ -d "${WORKDIR}"/patches ]] && PATCHES+=( "${WORKDIR}"/patches )