summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-06 04:33:24 +0000
committerSam James <sam@gentoo.org>2023-02-06 04:33:46 +0000
commitc0879d2ebced44576710300e0baf055328f0572a (patch)
treed439a203e657ce25f3ea971853553bcf2de8c689 /sys-apps
parentdev-python/nbxmpp: Bump to 4.2.0 (diff)
downloadgentoo-c0879d2ebced44576710300e0baf055328f0572a.tar.gz
gentoo-c0879d2ebced44576710300e0baf055328f0572a.tar.bz2
gentoo-c0879d2ebced44576710300e0baf055328f0572a.zip
sys-apps/gentoo-functions: add 0.18
Closes: https://bugs.gentoo.org/579688 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/gentoo-functions/Manifest1
-rw-r--r--sys-apps/gentoo-functions/gentoo-functions-0.18.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/sys-apps/gentoo-functions/Manifest b/sys-apps/gentoo-functions/Manifest
index d25f2f43a4a7..7b83ba1665cd 100644
--- a/sys-apps/gentoo-functions/Manifest
+++ b/sys-apps/gentoo-functions/Manifest
@@ -1 +1,2 @@
DIST gentoo-functions-0.17.tar.bz2 10798 BLAKE2B 1b725945421ab36b1412f9addc22e9fe299c0e6460790ee2832b9f63d4c06b86bb0d054b01505640a5dc1e62f3cd257628717fec852116a4c8b2c9f9d2d149ee SHA512 6a3de93b5e4d761a53a622f41e6079606cc4ad8a964771d49dafdefbb632afdf722fd055d261e494aa0be956c4160c49a775ab40c927c5340b8e4da275ef51fb
+DIST gentoo-functions-0.18.tar.bz2 11803 BLAKE2B d975b0227dd0370c072e34f11d8d6c427b90948e7469b214665d27805f5a4cada1dab2e1b9b3b32e032fdc42a82587d16c5b3a4766f85e9cb75ad74fac69cb0b SHA512 b96f71a5a84b84affb69f042cb4908f41a6b4c0328f9f0a325f523361560dc95c95b8bd5de5c22758d7038a1b564c2bd3f5d8fc63b72f87ab17523c555daa829
diff --git a/sys-apps/gentoo-functions/gentoo-functions-0.18.ebuild b/sys-apps/gentoo-functions/gentoo-functions-0.18.ebuild
new file mode 100644
index 000000000000..fb9b450e95c3
--- /dev/null
+++ b/sys-apps/gentoo-functions/gentoo-functions-0.18.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2014-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-functions.git"
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/gentoo-functions.git/snapshot/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+fi
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Base functions required by all Gentoo systems"
+HOMEPAGE="https://gitweb.gentoo.org/proj/gentoo-functions.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+src_configure() {
+ tc-export CC
+ append-lfs-flags
+ export ROOTPREFIX="${EPREFIX}"
+ export PREFIX="${EPREFIX}/usr"
+}