summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-08-08 11:27:29 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-08-08 11:32:06 +0200
commitc4ee427a16df625b862e35d7e27739ce7fbd53b3 (patch)
tree661efdd777c05f64b26e2004e6a7f6dd23f00a6c /sys-apps
parentapp-text/lesspipe: Bump to version 1.87 (diff)
downloadgentoo-c4ee427a16df625b862e35d7e27739ce7fbd53b3.tar.gz
gentoo-c4ee427a16df625b862e35d7e27739ce7fbd53b3.tar.bz2
gentoo-c4ee427a16df625b862e35d7e27739ce7fbd53b3.zip
sys-apps/help2man: Bump to version 1.48.4
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/help2man/Manifest1
-rw-r--r--sys-apps/help2man/help2man-1.48.4.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-apps/help2man/Manifest b/sys-apps/help2man/Manifest
index 9bfb4fc3567f..a0ceb60a77f6 100644
--- a/sys-apps/help2man/Manifest
+++ b/sys-apps/help2man/Manifest
@@ -1 +1,2 @@
DIST help2man-1.48.3.tar.xz 211504 BLAKE2B 407cc87b1238242c202d37c0c4cd394e0efba95759b86a88026aef7c05d6a097d1946614547ebfab45f7fe0c1ddd057724234629246d32e94862c3d633b78c31 SHA512 e000e7380604c0986b14cb64b852d55eff48595884bddd389e876056dde6ce72b37aa16d92230e6f8f6e128003b819954bae4aa90933a58b51d3665d3c0ba356
+DIST help2man-1.48.4.tar.xz 204592 BLAKE2B 0625af5a0a65daeb459a7445ef6e5a8c9ddbac4ebad5c31134bfbbd5abdc1d05cd5e682d2d1f0d4df36de4fdbbbe22ac7bbbb2c1c5fca4d53ee0c6bfefd63dfb SHA512 fa3f3eabc6010a4a34dc108bfa3b9456b9ea66b343ff2913c32cd6da52ddcf3aa8cb9c05a8b14585f314198aa4ef6f1eebbb185b90a2fb923ab3b2ee7b5e57a9
diff --git a/sys-apps/help2man/help2man-1.48.4.ebuild b/sys-apps/help2man/help2man-1.48.4.ebuild
new file mode 100644
index 000000000000..2f5c10989e9b
--- /dev/null
+++ b/sys-apps/help2man/help2man-1.48.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="GNU utility to convert program --help output to a man page"
+HOMEPAGE="https://www.gnu.org/software/help2man/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls"
+
+RDEPEND="dev-lang/perl
+ nls? ( dev-perl/Locale-gettext )"
+DEPEND="${RDEPEND}"
+
+DOCS=( debian/changelog NEWS README THANKS ) #385753
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.46.1-linguas.patch
+)
+
+src_prepare() {
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ sed -i \
+ -e 's/-shared/-bundle/' \
+ Makefile.in || die
+ fi
+ default
+}
+
+src_configure() {
+ # Disable gettext requirement as the release includes the gmo files #555018
+ local myeconfargs=(
+ ac_cv_path_MSGFMT=$(type -P false)
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}