summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-03-12 23:46:20 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-03-12 23:47:00 +0100
commitc57300b819ff9247c2e8810d6798a226b2d71b53 (patch)
tree4255e5525470a56ad53e6704bc1ad8873ce78fd9 /sys-apps
parentsys-apps/edid-decode: drop old version (diff)
downloadgentoo-c57300b819ff9247c2e8810d6798a226b2d71b53.tar.gz
gentoo-c57300b819ff9247c2e8810d6798a226b2d71b53.tar.bz2
gentoo-c57300b819ff9247c2e8810d6798a226b2d71b53.zip
sys-apps/ipmicfg: bump to version 1.31.0
Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/ipmicfg/Manifest1
-rw-r--r--sys-apps/ipmicfg/ipmicfg-1.31.0.200205.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-apps/ipmicfg/Manifest b/sys-apps/ipmicfg/Manifest
index 481fbaa6b213..b08f81ce557b 100644
--- a/sys-apps/ipmicfg/Manifest
+++ b/sys-apps/ipmicfg/Manifest
@@ -1 +1,2 @@
DIST IPMICFG_1.30.0_build.190710.zip 1886457 BLAKE2B 5a303ccedda2ffab8d599e68feb1e23faeba0cca7d2fdb224c29440a11a12114cdf536e3f9e5544c1f929fdf8aab0846db51ff2935b20b70b7c3cf7a0fa82bfc SHA512 bad76fd5bc07a9bafecbc02c9a0fc26310b4894c6c365f3c53f1a900244b634317bf59f43d8fa230af866ce6e7f537c7f902b38bb1d4ff5a8546de4fe94043f4
+DIST IPMICFG_1.31.0_build.200205.zip 1972548 BLAKE2B e6d16907bad2c85618087f770621bf8335bbe38eb5b1a2466ee5b998ab13613aa96dd44e395a05e5b183597d4e5d5f775685bc810cd7d904f57eccecc8474ba1 SHA512 c46414b3504fe357f3b7df0f0c5f8cd4ada5ffa0541a1e49f282a187b8257d6c278cda099cce034eb9a25ad47bfd531255ec88ef6e2495a80f281888374441eb
diff --git a/sys-apps/ipmicfg/ipmicfg-1.31.0.200205.ebuild b/sys-apps/ipmicfg/ipmicfg-1.31.0.200205.ebuild
new file mode 100644
index 000000000000..6c3e2af0a83a
--- /dev/null
+++ b/sys-apps/ipmicfg/ipmicfg-1.31.0.200205.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_DATE="$(ver_cut 4)"
+MY_PN="${PN^^}"
+MY_PV="$(ver_cut 1-3)"
+
+DESCRIPTION="An in-band utility for configuring Supermicro IPMI devices"
+HOMEPAGE="https://www.supermicro.com"
+SRC_URI="ftp://ftp.supermicro.com/utility/${MY_PN}/${MY_PN}_${MY_PV}_build.${MY_DATE}.zip"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="supermicro"
+SLOT="0"
+
+BDEPEND="app-arch/unzip"
+
+RESTRICT="bindist fetch mirror"
+
+S="${WORKDIR}/${MY_PN}_${MY_PV}_build.${MY_DATE}"
+
+QA_PREBUILT="usr/bin/ipmicfg"
+
+pkg_nofetch() {
+ elog "Please download ${A} from"
+ elog "https://www.supermicro.com/SwDownload/UserInfo.aspx?sw=0&cat=IPMI"
+ elog "and place it in your DISTDIR directory."
+}
+
+src_install() {
+ newbin Linux/$(usex amd64 '64bit' '32bit')/IPMICFG-Linux.x86$(usex amd64 '_64' '') ipmicfg
+
+ # Install docs
+ local DOCS=(
+ "IPMICFG_UserGuide.pdf"
+ "ReleaseNotes.txt"
+ )
+ einstalldocs
+}