summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-06-06 22:40:21 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-06-06 23:00:12 +0200
commitcbb01d51517b6c8339d715d4cb8748d860cfb9ad (patch)
tree3b30caeb04cae3fa18d747de35f17aa64ae14d2d /sys-apps
parentapp-admin/dxf: Version bump to 7.2.0 (diff)
downloadgentoo-cbb01d51517b6c8339d715d4cb8748d860cfb9ad.tar.gz
gentoo-cbb01d51517b6c8339d715d4cb8748d860cfb9ad.tar.bz2
gentoo-cbb01d51517b6c8339d715d4cb8748d860cfb9ad.zip
sys-apps/file: Install /usr/share/misc/magic
"/usr/share/misc/magic" is required for `file -C` command as used by app-arch/rpm for example. Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/file/file-5.32-r1.ebuild (renamed from sys-apps/file/file-5.32.ebuild)5
-rw-r--r--sys-apps/file/file-5.33-r1.ebuild (renamed from sys-apps/file/file-5.33.ebuild)5
-rw-r--r--sys-apps/file/file-9999.ebuild5
3 files changed, 15 insertions, 0 deletions
diff --git a/sys-apps/file/file-5.32.ebuild b/sys-apps/file/file-5.32-r1.ebuild
index c431956b3788..389e0e1c2d7f 100644
--- a/sys-apps/file/file-5.32.ebuild
+++ b/sys-apps/file/file-5.32-r1.ebuild
@@ -111,6 +111,11 @@ multilib_src_install() {
multilib_src_install_all() {
dodoc ChangeLog MAINT README
+ # Required for `file -C`
+ dodir /usr/share/misc/magic
+ insinto /usr/share/misc/magic
+ doins -r magic/Magdir/*
+
if use python ; then
cd python || die
distutils-r1_src_install
diff --git a/sys-apps/file/file-5.33.ebuild b/sys-apps/file/file-5.33-r1.ebuild
index 43f99c6754cb..ffec3650582f 100644
--- a/sys-apps/file/file-5.33.ebuild
+++ b/sys-apps/file/file-5.33-r1.ebuild
@@ -112,6 +112,11 @@ multilib_src_install() {
multilib_src_install_all() {
dodoc ChangeLog MAINT README
+ # Required for `file -C`
+ dodir /usr/share/misc/magic
+ insinto /usr/share/misc/magic
+ doins -r magic/Magdir/*
+
if use python ; then
cd python || die
distutils-r1_src_install
diff --git a/sys-apps/file/file-9999.ebuild b/sys-apps/file/file-9999.ebuild
index 5f51b583c407..74264b9da48d 100644
--- a/sys-apps/file/file-9999.ebuild
+++ b/sys-apps/file/file-9999.ebuild
@@ -113,6 +113,11 @@ multilib_src_install() {
multilib_src_install_all() {
dodoc ChangeLog MAINT README
+ # Required for `file -C`
+ dodir /usr/share/misc/magic
+ insinto /usr/share/misc/magic
+ doins -r magic/Magdir/*
+
if use python ; then
cd python || die
distutils-r1_src_install