summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2021-05-25 06:10:41 -0500
committerBen Kohler <bkohler@gentoo.org>2021-05-25 06:11:21 -0500
commitcc3b976d68dad78ff2a3c9f3277058e330674ebe (patch)
treed37026a8a1caa67b4b7b4d3453b3884d8752a88a /sys-apps
parentapp-i18n/mozc: Stabilize 2.26.4220_p20201212102434_p20201219202429 amd64, #79... (diff)
downloadgentoo-cc3b976d68dad78ff2a3c9f3277058e330674ebe.tar.gz
gentoo-cc3b976d68dad78ff2a3c9f3277058e330674ebe.tar.bz2
gentoo-cc3b976d68dad78ff2a3c9f3277058e330674ebe.zip
sys-apps/hwinfo: bump to 21.74
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hwinfo/Manifest1
-rw-r--r--sys-apps/hwinfo/hwinfo-21.74.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/sys-apps/hwinfo/Manifest b/sys-apps/hwinfo/Manifest
index 95e7193967d0..1db9e545afc4 100644
--- a/sys-apps/hwinfo/Manifest
+++ b/sys-apps/hwinfo/Manifest
@@ -1 +1,2 @@
DIST hwinfo-21.72-1.3.src.rpm 926285 BLAKE2B b8a38b2f04649e268a6d6fbebabd724a0c678e81ea9c09c3453ababa26e91ba5fe55c7feccf157ab81ab676e6610ba1700ef1691bdd06fbcbc1cdd86806282d2 SHA512 4e51ee4f8e03eee82317557aa39b5018cc2370b33bfdb280ecb8716687d951f8c34fa7598a1e0eff03025991eee654af488e3343d93167e4cf16380d047c2de3
+DIST hwinfo-21.74-1.1.src.rpm 967046 BLAKE2B 305db6eb3184de0e84d166f0e32988ea2a0ec65eceb322c8c451f33ab8656c38a21a74f416ff08442bcbc5fa91fb4fa8439d907c2c244fe62a2048be7f84b181 SHA512 1a681b51934fbed229b7daa96b5e4e0d8fc62d480927034d0c95ae8c89dc2ae43214c63cca273379162353aeb2bf81883e7c02006c4f45fd1deab0d74f8a2988
diff --git a/sys-apps/hwinfo/hwinfo-21.74.ebuild b/sys-apps/hwinfo/hwinfo-21.74.ebuild
new file mode 100644
index 000000000000..b4051eb59a5d
--- /dev/null
+++ b/sys-apps/hwinfo/hwinfo-21.74.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib rpm toolchain-funcs
+
+DESCRIPTION="Hardware detection tool used in SuSE Linux"
+HOMEPAGE="https://www.opensuse.org/"
+#Using srpms from SUSE to get pregenerated changelog, otherwise we could use GH
+#SRC_URI="https://github.com/openSUSE/hwinfo/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="http://download.opensuse.org/tumbleweed/repo/src-oss/src/${P}-1.1.src.rpm"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ amd64? ( dev-libs/libx86emu )
+ x86? ( dev-libs/libx86emu )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ >=sys-kernel/linux-headers-2.6.17"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_prepare() {
+ # Respect AR variable.
+ sed -i \
+ -e 's:ar r:$(AR) r:' \
+ src/{,isdn,ids,smp,hd}/Makefile || die
+
+ # Respect LDFLAGS.
+ sed -i -e 's:$(CC) $(CFLAGS):$(CC) $(LDFLAGS) $(CFLAGS):' src/ids/Makefile || die
+
+ # Respect MAKE variable. Skip forced -pipe and -g. Respect LDFLAGS.
+ sed -i \
+ -e 's:make:$(MAKE):' \
+ -e 's:-pipe -g::' \
+ -e 's:LDFLAGS.*=:LDFLAGS +=:' \
+ Makefile{,.common} || die
+ # Workaround from Arch, if using source tarballs from github
+ # echo 'touch changelog' > git2log
+ default
+}
+
+src_compile() {
+ tc-export AR
+ emake CC="$(tc-getCC)" RPM_OPT_FLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" LIBDIR="/usr/$(get_libdir)" install
+ keepdir /var/lib/hardware/udi
+
+ dodoc changelog README*
+ docinto examples
+ dodoc doc/example*.c
+ doman doc/*.{1,8}
+}