summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-09-25 11:24:37 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-09-25 11:24:45 +0200
commitd1970a154c982d028c38458c38fc6ae70ab151e7 (patch)
tree00dc7e2f566fa5b215b0a5c896efbf08acb06367 /sys-apps
parentdev-cpp/abseil-cpp: add RESTRICT="!test? ( test )" (diff)
downloadgentoo-d1970a154c982d028c38458c38fc6ae70ab151e7.tar.gz
gentoo-d1970a154c982d028c38458c38fc6ae70ab151e7.tar.bz2
gentoo-d1970a154c982d028c38458c38fc6ae70ab151e7.zip
sys-apps/fakeroot: Bump to version 1.24.1
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/fakeroot/Manifest1
-rw-r--r--sys-apps/fakeroot/fakeroot-1.24.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-apps/fakeroot/Manifest b/sys-apps/fakeroot/Manifest
index 9367a0ac8521..d43dd1302c9e 100644
--- a/sys-apps/fakeroot/Manifest
+++ b/sys-apps/fakeroot/Manifest
@@ -1,3 +1,4 @@
DIST fakeroot_1.22.orig.tar.bz2 338238 BLAKE2B b6cee7483ea7ec17747e638cbfefa565f26b3b00517f3ec90280f8ce556ce8efa3833accc07885365e20f80967a67291fadc27cd80766548cc86e2aa70c74c33 SHA512 193478d9ff88ca2ae69fe47b73b6c61aeb2ba3f2a9e7ed5d455022705857c6f34cdcbe2d3f614c4c4c9509368dc78b9a7b7aa56fb3b50bb3309448140abd796a
DIST fakeroot_1.23.orig.tar.xz 298080 BLAKE2B eac3da8486d57266f0f6af0479f0fcec5aaf82f4707ad8f810f954373a31cf5f390ef57dcc71ba630a1d4a578df95ac9beda9c93b3c75adffcbc89860f442b69 SHA512 0984679207e6e340abf715d4b26a213f85420cd8c58f21e65eb069337a3bd67436c6f80168412c10b28701689ec63290f122a5ff5d44a57b2b166aa72799d036
+DIST fakeroot_1.24.1.orig.tar.gz 111873 BLAKE2B 64c4661082a2b0183dfe5eacde8f97c8134a39d3b82f731ef13ecd3139595491e3560c47fee74fe2351f674a2e265a04bdb3eda475ca59ee42406088623b8b39 SHA512 f85f616c3018b6da09cb60693eb42e2b63b749edf5f7f947e9b98b51938733be02bc43af3210338973a02bcab9815657a77c0f5abe29721c275e3da658a8d7c3
DIST fakeroot_1.24.orig.tar.gz 522497 BLAKE2B fb08ed6512a3e26538662ceb28a197b85fd4a05c37b543529df6880e01c64bd774037bed1230bf7d7fe0bde798364c2fd0fcfab257fff4d3e6ae9800c076a5b0 SHA512 b15db7bbfb03264f294fb3b42813e17758b43ef7f121e55a24af9ec30ff3f4ec8eb0392db88133e56f9728b3828f6c1432d1e5d2e881a69d083ad444b9177487
diff --git a/sys-apps/fakeroot/fakeroot-1.24.1.ebuild b/sys-apps/fakeroot/fakeroot-1.24.1.ebuild
new file mode 100644
index 000000000000..f0bf2f4c22f3
--- /dev/null
+++ b/sys-apps/fakeroot/fakeroot-1.24.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="A fake root environment by means of LD_PRELOAD and SysV IPC (or TCP) trickery"
+HOMEPAGE="https://packages.qa.debian.org/f/fakeroot.html"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${P/-/_}.orig.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="acl debug static-libs test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ sys-libs/libcap
+ acl? ( sys-apps/acl )
+ test? ( app-arch/sharutils )"
+
+DOCS="AUTHORS BUGS DEBUG README doc/README.saving"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ export ac_cv_header_sys_acl_h=$(usex acl)
+
+ use debug && append-cppflags "-DLIBFAKEROOT_DEBUGGING"
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -o -name '*.a' -delete || die
+}