summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-05-24 13:35:48 +0200
committerDavid Seifert <soap@gentoo.org>2021-05-24 13:35:48 +0200
commitd1eb467734a0317fd6546027d45fafe99361d87a (patch)
tree4bb3d58759161ca8965619b977b180baacec8fad /sys-apps
parentsys-apps/sysvinit: drop 2.97, 2.98-r1 (diff)
downloadgentoo-d1eb467734a0317fd6546027d45fafe99361d87a.tar.gz
gentoo-d1eb467734a0317fd6546027d45fafe99361d87a.tar.bz2
gentoo-d1eb467734a0317fd6546027d45fafe99361d87a.zip
sys-apps/coreutils: drop 8.31-r1
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/coreutils/Manifest1
-rw-r--r--sys-apps/coreutils/coreutils-8.31-r1.ebuild212
-rw-r--r--sys-apps/coreutils/files/coreutils-8.31-sandbox-env-test.patch52
3 files changed, 0 insertions, 265 deletions
diff --git a/sys-apps/coreutils/Manifest b/sys-apps/coreutils/Manifest
index 3df4cec98e7a..0f0d568b69cd 100644
--- a/sys-apps/coreutils/Manifest
+++ b/sys-apps/coreutils/Manifest
@@ -1,3 +1,2 @@
DIST coreutils-8.30-patches-01.tar.xz 5788 BLAKE2B a41511ce39ac570cb14b7f12d125eebef92217469a9490808719fa0665f5e5c0adb96fbd02c4bac4d280d1502295669575790a81dbc01afe2ca3a9d384cbefb0 SHA512 b1e1933637de4581d5f8c6ede4e80a012435d13f0cf5550a76ab5bbe9441e3c15ce19ef3f78a7ea3b8368d5e9a3bb17c1207c471d26171b59786f38adeba0454
-DIST coreutils-8.31.tar.xz 5410140 BLAKE2B e3ae6be8edbe9df9164b4c9ac8bf14dc23b147fa665f20669e18ac4c6e45ba839dc0dc99e05670eb006d22133475a4a717a5f40b00ebaedfd6e1fbab887674d5 SHA512 ef8941dae845bbf5ae5838bc49e44554a766302930601aada6fa594e8088f0fbad74e481ee392ff89633e68b99e4da3f761fcb5d31ee3b233d540fe2a2d4e1af
DIST coreutils-8.32.tar.xz 5547836 BLAKE2B 0ad99c176c19ec214fcfd0845523e5362f0151827707c759bd46c0fe8d2501c6ad1c29c5b71266f6525857bc0d56c472db0d7fe29953b6c65e2e6c76bdf3c515 SHA512 1c8f3584efd61b4b02e7ac5db8e103b63cfb2063432caaf1e64cb2dcc56d8c657d1133bbf10bd41468d6a1f31142e6caa81d16ae68fa3e6e84075c253613a145
diff --git a/sys-apps/coreutils/coreutils-8.31-r1.ebuild b/sys-apps/coreutils/coreutils-8.31-r1.ebuild
deleted file mode 100644
index 6c16ecc18fb4..000000000000
--- a/sys-apps/coreutils/coreutils-8.31-r1.ebuild
+++ /dev/null
@@ -1,212 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python3_7 )
-
-inherit flag-o-matic python-any-r1 toolchain-funcs
-
-PATCH="${PN}-8.30-patches-01"
-DESCRIPTION="Standard GNU utilities (chmod, cp, dd, ls, sort, tr, head, wc, who,...)"
-HOMEPAGE="https://www.gnu.org/software/coreutils/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
- mirror://gentoo/${PATCH}.tar.xz
- https://dev.gentoo.org/~polynomial-c/dist/${PATCH}.tar.xz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x86-linux"
-IUSE="acl caps gmp hostname kill multicall nls selinux +split-usr static test vanilla xattr"
-RESTRICT="!test? ( test )"
-
-LIB_DEPEND="acl? ( sys-apps/acl[static-libs] )
- caps? ( sys-libs/libcap )
- gmp? ( dev-libs/gmp:=[static-libs] )
- xattr? ( sys-apps/attr[static-libs] )"
-RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs]} )
- selinux? ( sys-libs/libselinux )
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- static? ( ${LIB_DEPEND} )
- app-arch/xz-utils
- test? (
- dev-lang/perl
- dev-perl/Expect
- dev-util/strace
- ${PYTHON_DEPS}
- )"
-RDEPEND+="
- hostname? ( !sys-apps/net-tools[hostname] )
- kill? (
- !sys-apps/util-linux[kill]
- !sys-process/procps[kill]
- )
- !app-misc/realpath
- !<sys-apps/util-linux-2.13
- !<sys-apps/sandbox-2.10-r4
- !sys-apps/stat
- !net-mail/base64
- !sys-apps/mktemp
- !<app-forensics/tct-1.18-r1
- !<net-fs/netatalk-2.0.3-r4"
-
-pkg_setup() {
- if use test ; then
- python-any-r1_pkg_setup
- fi
-}
-
-src_prepare() {
- if ! use vanilla ; then
- eapply "${WORKDIR}"/patch/*.patch
- eapply "${FILESDIR}"/${PN}-8.31-sandbox-env-test.patch
- fi
-
- eapply_user
-
- # Since we've patched many .c files, the make process will try to
- # re-build the manpages by running `./bin --help`. When doing a
- # cross-compile, we can't do that since 'bin' isn't a native bin.
- #
- # Also, it's not like we changed the usage on any of these things,
- # so let's just update the timestamps and skip the help2man step.
- set -- man/*.x
- touch ${@/%x/1} || die
-
- # Avoid perl dep for compiled in dircolors default (bug #348642)
- if ! has_version dev-lang/perl ; then
- touch src/dircolors.h || die
- touch ${@/%x/1} || die
- fi
-}
-
-src_configure() {
- local myconf=(
- --with-packager="Gentoo"
- --with-packager-version="${PVR} (p${PATCH_VER:-0})"
- --with-packager-bug-reports="https://bugs.gentoo.org/"
- # kill/uptime - procps
- # groups/su - shadow
- # hostname - net-tools
- --enable-install-program="arch,$(usev hostname),$(usev kill)"
- --enable-no-install-program="groups,$(usev !hostname),$(usev !kill),su,uptime"
- --enable-largefile
- $(usex caps '' --disable-libcap)
- $(use_enable nls)
- $(use_enable acl)
- $(use_enable multicall single-binary)
- $(use_enable xattr)
- $(use_with gmp)
- )
-
- if tc-is-cross-compiler && [[ ${CHOST} == *linux* ]] ; then
- # bug #311569
- export fu_cv_sys_stat_statfs2_bsize=yes
- # bug #416629
- export gl_cv_func_realpath_works=yes
- fi
-
- # bug #409919
- export gl_cv_func_mknod_works=yes
-
- if use static ; then
- append-ldflags -static
-
- # bug #321821
- sed -i '/elf_sys=yes/s:yes:no:' configure || die
- fi
-
- if ! use selinux ; then
- # bug #301782
- export ac_cv_{header_selinux_{context,flash,selinux}_h,search_setfilecon}=no
- fi
-
- econf "${myconf[@]}"
-}
-
-src_test() {
- # Known to fail with FEATURES=usersandbox (bug #439574):
- # - tests/du/long-from-unreadable.sh} (bug #413621)
- # - tests/rm/deep-2.sh (bug #413621)
- # - tests/dd/no-allocate.sh (bug #629660)
- if has usersandbox ${FEATURES} ; then
- ewarn "You are emerging ${P} with 'usersandbox' enabled." \
- "Expect some test failures or emerge with 'FEATURES=-usersandbox'!"
- fi
-
- # Non-root tests will fail if the full path isn't
- # accessible to non-root users
- chmod -R go-w "${WORKDIR}" || die
- chmod a+rx "${WORKDIR}" || die
-
- # coreutils tests like to do `mount` and such with temp dirs,
- # so make sure:
- # - /etc/mtab is writable (bug #265725)
- # - /dev/loop* can be mounted (bug #269758)
- mkdir -p "${T}"/mount-wrappers || die
- mkwrap() {
- local w ww
- for w in "${@}" ; do
- ww="${T}/mount-wrappers/${w}"
- cat <<-EOF > "${ww}"
- #!${EPREFIX}/bin/sh
- exec env SANDBOX_WRITE="\${SANDBOX_WRITE}:/etc/mtab:/dev/loop" $(type -P ${w}) "\$@"
- EOF
- chmod a+rx "${ww}" || die
- done
- }
- mkwrap mount umount
-
- addwrite /dev/full
- #export RUN_EXPENSIVE_TESTS="yes"
- #export FETISH_GROUPS="portage wheel"
- env PATH="${T}/mount-wrappers:${PATH}" \
- emake -j1 -k check
-}
-
-src_install() {
- default
-
- insinto /etc
- newins src/dircolors.hin DIR_COLORS
-
- if use split-usr ; then
- cd "${ED%/}"/usr/bin || die
- dodir /bin
-
- # Move critical binaries into /bin (required by FHS)
- local fhs="cat chgrp chmod chown cp date dd df echo false ln ls
- mkdir mknod mv pwd rm rmdir stty sync true uname"
- mv ${fhs} ../../bin/ || die "Could not move FHS bins!"
-
- if use hostname ; then
- mv hostname ../../bin/ || die
- fi
-
- if use kill ; then
- mv kill ../../bin/ || die
- fi
-
- # Move critical binaries into /bin (common scripts)
- # (Why are these required for booting?)
- local com="basename chroot cut dir dirname du env expr head mkfifo
- mktemp readlink seq sleep sort tail touch tr tty vdir wc yes"
- mv ${com} ../../bin/ || die "Could not move common bins!"
-
- # Create a symlink for uname in /usr/bin/ since autotools require it.
- # (Other than uname, we need to figure out why we are
- # creating symlinks for these in /usr/bin instead of leaving
- # the files there in the first place...)
- local x
- for x in ${com} uname ; do
- dosym ../../bin/${x} /usr/bin/${x}
- done
- fi
-}
-
-pkg_postinst() {
- ewarn "Make sure you run 'hash -r' in your active shells."
- ewarn "You should also re-source your shell settings for LS_COLORS"
- ewarn " changes, such as: source /etc/profile"
-}
diff --git a/sys-apps/coreutils/files/coreutils-8.31-sandbox-env-test.patch b/sys-apps/coreutils/files/coreutils-8.31-sandbox-env-test.patch
deleted file mode 100644
index f81ea13776b3..000000000000
--- a/sys-apps/coreutils/files/coreutils-8.31-sandbox-env-test.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-Skip tests known to fail when running under Gentoo sandbox.
-
---- a/tests/du/long-from-unreadable.sh
-+++ b/tests/du/long-from-unreadable.sh
-@@ -29,6 +29,9 @@
- # unnecessarily to using FTS_NOCHDIR mode in this corner case.
-
- . "${srcdir=.}/tests/init.sh"; path_prepend_ ./src
-+# Avoid #413621 until #548250 is resolved
-+test -n "$SANDBOX_ACTIVE" && skip_ "Gentoo: Test known bad under sandbox (#413621)"
-+
- print_ver_ du
-
- require_perl_
---- a/tests/ls/stat-free-symlinks.sh
-+++ b/tests/ls/stat-free-symlinks.sh
-@@ -17,6 +17,9 @@
- # along with this program. If not, see <https://www.gnu.org/licenses/>.
-
- . "${srcdir=.}/tests/init.sh"; path_prepend_ ./src
-+# Avoid #413621 until #548250 is resolved
-+test -n "$SANDBOX_ACTIVE" && skip_ "Gentoo: Test known bad under sandbox (#413621)"
-+
- print_ver_ ls
- require_strace_ stat
-
---- a/tests/misc/env-S.pl
-+++ b/tests/misc/env-S.pl
-@@ -30,6 +30,11 @@ $env = $1;
- # Turn off localization of executable's output.
- @ENV{qw(LANGUAGE LANG LC_ALL)} = ('C') x 3;
-
-+# Skip if sandbox is enabled
-+if ($ENV{SANDBOX_ACTIVE}) {
-+ CuSkip::skip "Gentoo: Test known bad under sandbox (#675802)\n";
-+}
-+
- my @Tests =
- (
- # Test combination of -S and regular arguments
---- a/tests/rm/deep-2.sh
-+++ b/tests/rm/deep-2.sh
-@@ -17,6 +17,9 @@
- # along with this program. If not, see <https://www.gnu.org/licenses/>.
-
- . "${srcdir=.}/tests/init.sh"; path_prepend_ ./src
-+# Avoid #413621 until #548250 is resolved
-+test -n "$SANDBOX_ACTIVE" && skip_ "Gentoo: Test known bad under sandbox (#413621)"
-+
- print_ver_ rm
- require_perl_
-