summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-11-20 19:22:27 +0100
committerThomas Deutschmann <whissi@gentoo.org>2017-11-20 19:22:46 +0100
commitf4f38f81a3243401e21d00e3da378d701aa1c17b (patch)
tree8785f0269677fc95c966d2fa005afc8e63b37109 /sys-apps
parentnet-fs/minio: Version bump (diff)
downloadgentoo-f4f38f81a3243401e21d00e3da378d701aa1c17b.tar.gz
gentoo-f4f38f81a3243401e21d00e3da378d701aa1c17b.tar.bz2
gentoo-f4f38f81a3243401e21d00e3da378d701aa1c17b.zip
sys-apps/miscfiles: Rev bump to bump EAPI and Unicode data
Closes: https://github.com/gentoo/gentoo/pull/6250 Bug: https://bugs.gentoo.org/622770 Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/miscfiles/Manifest1
-rw-r--r--sys-apps/miscfiles/miscfiles-1.5-r2.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/sys-apps/miscfiles/Manifest b/sys-apps/miscfiles/Manifest
index 5dcbcbac2971..383439d6ae0d 100644
--- a/sys-apps/miscfiles/Manifest
+++ b/sys-apps/miscfiles/Manifest
@@ -1,2 +1,3 @@
+DIST UnicodeData-10.0.0.txt.xz 158456 SHA256 f90b97fad6c49a01c4c29738658fd4ea31fd234fcd0f63535574e59a30ef45f8 SHA512 85e8c7b33d71025a5f6f109e28010a5d5167f1aeb86c88eedd2e5ea5cecae3d1be741e5b0113a78566f51e8e15812a180a8c43c6b887385fec157d744c7a4a9c WHIRLPOOL a01456fb268f752eb9e12bd8106b74b656cc9efa956c4ef182f0c5a38bfb21140e0130a4c33bcc5b4905af75258e46ba8dc7bd5b4033677babadfdb4a4c65833
DIST UnicodeData-6.1.0.txt.xz 129972 SHA256 044c7f014c601ec4602d8e19c1541a952e2c7e30930c623acc65b1f45acb170a SHA512 9ada361d915f3883e673c6e55f351c7411dc970e180e7e0b05fef498c2f80a5a29bfd6c22513ff4b6b6c4c9fba5c77f0aca2dd54c7a76d3fa9b78623b1fdd93f WHIRLPOOL b052639f5ffe6acab1b875ee55aa917ed6f526deffce1f12f15530f1dd44d3cbb259516c40c725f7a35838d7ecb68f5452e099aef904d0763720cde87cebebf1
DIST miscfiles-1.5.tar.gz 1585293 SHA256 6aaaa8898b0f6dac18bcaa5492874a6cd1243ffbe7a6dd347ca8f3ec3642a500 SHA512 d7ab23a709539278cce59e0c32bfcb3a0f11dc52ef537e3823e72382962af7f4fedb8b957f39ff1da51a93a00e3c4f6ec29f7332d7879c77fd7f4ec0ee4f82aa WHIRLPOOL 3d134944fcf75231f682d05320ad9b198b99f9eb4c27a949b67e724cb3b16181afedd61e83bcdb672fb7df516d8cdc43310209a07108b35fdb40ea9025be297a
diff --git a/sys-apps/miscfiles/miscfiles-1.5-r2.ebuild b/sys-apps/miscfiles/miscfiles-1.5-r2.ebuild
new file mode 100644
index 000000000000..ca1d83243fdc
--- /dev/null
+++ b/sys-apps/miscfiles/miscfiles-1.5-r2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+UNI_PV="10.0.0"
+DESCRIPTION="Miscellaneous files"
+HOMEPAGE="https://savannah.gnu.org/projects/miscfiles/"
+# https://www.unicode.org/Public/${UNI_PV}/ucd/UnicodeData.txt
+SRC_URI="mirror://gnu/miscfiles/${P}.tar.gz
+ https://dev.gentoo.org/~whissi/dist/${PN}/UnicodeData-${UNI_PV}.txt.xz"
+
+LICENSE="GPL-2 unicode"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE="minimal"
+
+# Collides with older versions/revisions
+RDEPEND="!<sys-freebsd/freebsd-share-7.2-r1"
+DEPEND=""
+
+src_prepare() {
+ default
+
+ mv "${WORKDIR}"/UnicodeData-${UNI_PV}.txt unicode || die
+}
+
+src_configure() {
+ econf --datadir="${EPREFIX%/}"/usr/share/misc
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc NEWS ORIGIN README dict-README
+
+ # not sure if this is still needed ...
+ dodir /usr/share/dict
+ cd "${ED%/}"/usr/share/misc
+ mv $(awk '$1=="dictfiles"{$1="";$2="";print}' "${S}"/Makefile) ../dict/ || die
+ cd ../dict
+ ln -s web2 words || die
+ ln -s web2a extra.words || die
+
+ if use minimal ; then
+ cd "${ED}"/usr/share/dict
+ rm -f words extra.words
+ gzip -9 *
+ ln -s web2.gz words
+ ln -s web2a.gz extra.words
+ ln -s connectives{.gz,}
+ ln -s propernames{.gz,}
+ cd ..
+ rm -r misc rfc
+ fi
+}
+
+pkg_postinst() {
+ if [[ ${ROOT} == "/" ]] && type -P create-cracklib-dict >/dev/null ; then
+ ebegin "Regenerating cracklib dictionary"
+ create-cracklib-dict "${EPREFIX%/}"/usr/share/dict/* > /dev/null
+ eend $?
+ fi
+
+ # pkg_postinst isn't supposed to fail
+ return 0
+}