summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2019-03-31 01:06:59 +0800
committerJason Zaman <perfinion@gentoo.org>2019-03-31 21:45:27 +0800
commitf9368391e90a822bf1f8f3e9934011ea890af6b6 (patch)
treede319cbf2ae641453b15a0aa3b8950cc2d8caa65 /sys-apps
parentsys-apps/semodule-utils: bump to 2.9 (diff)
downloadgentoo-f9368391e90a822bf1f8f3e9934011ea890af6b6.tar.gz
gentoo-f9368391e90a822bf1f8f3e9934011ea890af6b6.tar.bz2
gentoo-f9368391e90a822bf1f8f3e9934011ea890af6b6.zip
sys-apps/secilc: bump to 2.9
Signed-off-by: Jason Zaman <perfinion@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/secilc/Manifest1
-rw-r--r--sys-apps/secilc/secilc-2.9.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sys-apps/secilc/Manifest b/sys-apps/secilc/Manifest
index d6ebffa440af..82611930fc5d 100644
--- a/sys-apps/secilc/Manifest
+++ b/sys-apps/secilc/Manifest
@@ -1,3 +1,4 @@
DIST secilc-2.7.tar.gz 175733 BLAKE2B dfad83618f3dd14f4a710d27b6ff3dbe188c9e1eecabe29dd16d9b0ba35a2aa2c5777d999fb378159624f7b7af9af152592e69f9212d2ae6dc6e52dbefcba056 SHA512 cd828ad34e80151951f94414d27246b480cd4831d1d57cb35d5958ce23c30fe74f26ec1c4b29b51fe382bf03ec3144311b35ca645ffc6b914b7abfe677684c06
DIST secilc-2.8.tar.gz 175893 BLAKE2B d1e588c82d8be68efb66abbcedf28b3f99ac58edf58df238d970243b7a9c94109fcfc6958907fd4f614381e9ee4e248796b556a37a283d6f0e602a98349c1dd9 SHA512 70b92802af8bdfbeb458ccaaed74e00e8a1edfcdbb48a0b422cf1e98ce467db1a586c800574ae61b0fbf006330c603b44d022091d7bcb6b0963ef1b1c6e547c1
DIST secilc-2.9-rc1.tar.gz 175895 BLAKE2B d89eebc1c71663c35f880f264d79e17da477261403cf4394ebf5017d86c64ada12c8d8fd92651e2ca33a0a4d90a4835a846221cab34564167fae66a76c962ebb SHA512 5aeb099fc8afad5dce5c55c171db8ca1e1326bd670f84debdeb679b3e81e3f9943c68bcbbb3beaa9c9c3aa3aceb691f6cf8a13081f0bf28eb921d7b139dfb814
+DIST secilc-2.9.tar.gz 175885 BLAKE2B 0a5fd0adb70ce80574148ac035dcb8c5c80f6779a6a0c696eaba26cb6c4441e58eb161600034102dcb34c87099357bfc66015d245cf2fd49b56e65d782fc8aac SHA512 c552ce65fc23bef1a93b3dc485369d64ad19a3f30707b95d0dd488d1766ab9f5e75884b79e6464997eaafee119193a1fdd5ff8228aee0fa902e426eefa14a4ee
diff --git a/sys-apps/secilc/secilc-2.9.ebuild b/sys-apps/secilc/secilc-2.9.ebuild
new file mode 100644
index 000000000000..aead3f36a435
--- /dev/null
+++ b/sys-apps/secilc/secilc-2.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+inherit toolchain-funcs
+
+MY_P="${P//_/-}"
+MY_RELEASEDATE="20190315"
+
+SEPOL_VER="${PV}"
+
+DESCRIPTION="SELinux Common Intermediate Language (CIL) Compiler"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ app-text/xmlto
+ >=sys-libs/libsepol-${SEPOL_VER}
+ "
+RDEPEND="
+ >=sys-libs/libsepol-${SEPOL_VER}
+ "
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_compile() {
+ tc-export CC
+ default
+}