summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-06-21 11:40:41 +0200
committerDavid Seifert <soap@gentoo.org>2022-06-21 11:40:41 +0200
commitfa3ca0b5593c6d7677e3b6612f67c14ccf1f4c7b (patch)
tree371c422afcd50a33e82b136ae9b92d4cb2df557d /sys-apps
parentsys-apps/kbd: drop 2.5.0 (diff)
downloadgentoo-fa3ca0b5593c6d7677e3b6612f67c14ccf1f4c7b.tar.gz
gentoo-fa3ca0b5593c6d7677e3b6612f67c14ccf1f4c7b.tar.bz2
gentoo-fa3ca0b5593c6d7677e3b6612f67c14ccf1f4c7b.zip
sys-apps/logwatch: drop 7.5.6
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/logwatch/Manifest1
-rw-r--r--sys-apps/logwatch/logwatch-7.5.6.ebuild93
2 files changed, 0 insertions, 94 deletions
diff --git a/sys-apps/logwatch/Manifest b/sys-apps/logwatch/Manifest
index 6ae6b7a0713e..065b748116b1 100644
--- a/sys-apps/logwatch/Manifest
+++ b/sys-apps/logwatch/Manifest
@@ -1,2 +1 @@
-DIST logwatch-7.5.6.tar.gz 484873 BLAKE2B 18a10f7baade4650c836ad402fcb92096923e0a8b6890352916e3b514bf85fe5b5070c0a47059c68fd84624407006107332f75a5ce3164a25cfa05f28f2ec882 SHA512 fb490f5bc1bf469309ee9caa1e040d71b4332d7fb64f94865a9b5fe707a92cb10c207022ce5e279709bf3412605f67f7da11303d91aa078f680c598398aab2ab
DIST logwatch-7.6.tar.gz 488750 BLAKE2B fd7f2a7c65151dbfbd924102b01ead00f92d74a59a417361b65be972368f7ed93810feefedf1ad9bba2de5ebbc74589c3fc0a8a484f19b5a9782c9799ffdf656 SHA512 8672dcf2b781d89ec281c4370b204467f9db219edb7c23adf02b71decf0ecab7b442d6e95e91416af3aecc27948e9442bb3b369e532e40f7ef32635628e110af
diff --git a/sys-apps/logwatch/logwatch-7.5.6.ebuild b/sys-apps/logwatch/logwatch-7.5.6.ebuild
deleted file mode 100644
index 24fb4fa00cfe..000000000000
--- a/sys-apps/logwatch/logwatch-7.5.6.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit tmpfiles
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://git.code.sf.net/p/logwatch/git ${PN}"
- inherit git-r3
-else
- SRC_URI="mirror://sourceforge/${PN}/${P}/${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 hppa ppc ppc64 sparc x86"
-fi
-
-DESCRIPTION="Analyzes and Reports on system logs"
-HOMEPAGE="https://sourceforge.net/projects/logwatch/"
-
-LICENSE="MIT"
-SLOT="0"
-
-RDEPEND="virtual/cron
- virtual/mta
- virtual/mailx
- dev-lang/perl
- dev-perl/Date-Calc
- dev-perl/Date-Manip
- dev-perl/Tie-IxHash
- dev-perl/Sys-CPU
- dev-perl/Sys-MemInfo"
-
-PATCHES=()
-
-src_install() {
- dodir /usr/share/logwatch/lib
- dodir /usr/share/logwatch/scripts/services
- dodir /usr/share/logwatch/scripts/shared
- dodir /usr/share/logwatch/default.conf/logfiles
- dodir /usr/share/logwatch/default.conf/services
- dodir /usr/share/logwatch/default.conf/html
- keepdir /etc/logwatch
-
- # logwatch.pl requires cache dir (bug #607668)
- newtmpfiles "${FILESDIR}"/logwatch.tmpfile ${PN}.conf
-
- newsbin scripts/logwatch.pl logwatch.pl
-
- exeinto /usr/share/logwatch/lib
- doexe lib/*.pm
-
- exeinto /usr/share/logwatch/scripts/services
- doexe scripts/services/*
-
- exeinto /usr/share/logwatch/scripts/shared
- doexe scripts/shared/*
-
- insinto /usr/share/logwatch/default.conf
- doins conf/logwatch.conf
-
- insinto /usr/share/logwatch/default.conf/logfiles
- doins conf/logfiles/*
-
- insinto /usr/share/logwatch/default.conf/services
- doins conf/services/*
-
- insinto /usr/share/logwatch/default.conf/html
- doins conf/html/*
-
- # Make sure logwatch is run before anything else #100243
- exeinto /etc/cron.daily
- newexe "${FILESDIR}"/logwatch 00-logwatch
-
- doman logwatch.8
- dodoc README HOWTO-Customize-LogWatch
-
- # Do last due to insopts modification.
- insinto /usr/share/logwatch/scripts/logfiles
- insopts -m755
- doins -r scripts/logfiles/*
-}
-
-pkg_postinst() {
- # Migration from /etc/cron.daily/logwatch -> /etc/cron.daily/00-logwatch (bug #100243)
- if [[ -e ${ROOT}/etc/cron.daily/logwatch ]] ; then
- local md5=$(md5sum "${ROOT}"/etc/cron.daily/logwatch)
- [[ ${md5} == "edb003cbc0686ed4cf37db16025635f3" ]] \
- && rm -f "${ROOT}"/etc/cron.daily/logwatch \
- || ewarn "You have two logwatch files in /etc/cron.daily/"
- fi
-
- # Trigger cache dir creation to allow immediate use of logwatch (bug #607668)
- tmpfiles_process ${PN}.conf
-}