summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-11-02 21:53:06 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-11-02 21:53:06 +0100
commit71bb8b0a6639a5f13cb052618917174578d5af74 (patch)
tree4d97ad6a5b2331f6a4450846a0ef02b6c3f65561 /sys-auth/AusweisApp2
parentsys-block/arcconf: drop 3.07.23971-r1 (diff)
downloadgentoo-71bb8b0a6639a5f13cb052618917174578d5af74.tar.gz
gentoo-71bb8b0a6639a5f13cb052618917174578d5af74.tar.bz2
gentoo-71bb8b0a6639a5f13cb052618917174578d5af74.zip
sys-auth/AusweisApp2: add 1.24.4
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-auth/AusweisApp2')
-rw-r--r--sys-auth/AusweisApp2/AusweisApp2-1.24.4.ebuild51
-rw-r--r--sys-auth/AusweisApp2/Manifest1
2 files changed, 52 insertions, 0 deletions
diff --git a/sys-auth/AusweisApp2/AusweisApp2-1.24.4.ebuild b/sys-auth/AusweisApp2/AusweisApp2-1.24.4.ebuild
new file mode 100644
index 000000000000..f1b6cc8c799f
--- /dev/null
+++ b/sys-auth/AusweisApp2/AusweisApp2-1.24.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Official authentication app for German ID cards and residence permits"
+HOMEPAGE="https://www.ausweisapp.bund.de/"
+SRC_URI="https://github.com/Governikus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EUPL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwebsockets:5[qml]
+ dev-qt/qtwidgets:5
+ net-libs/http-parser:0=
+ sys-apps/pcsc-lite
+ virtual/udev"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=OFF
+ -DQt=Qt5
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/sys-auth/AusweisApp2/Manifest b/sys-auth/AusweisApp2/Manifest
index f5aaedbe2b65..9243bfdd4e41 100644
--- a/sys-auth/AusweisApp2/Manifest
+++ b/sys-auth/AusweisApp2/Manifest
@@ -1,2 +1,3 @@
DIST AusweisApp2-1.24.2.tar.gz 11478273 BLAKE2B 3afb45bfa82c83f2fda6286c879d20fe3dd3769eb6be74c12297dfd991d976f40c6e9342237f953ae51534c41306daea3de7f8cf7e6b638489037772193e72e4 SHA512 15735cc52947b2cc16794cc508af7c2347d9789222c8506ff0ffbfce1263230892fd81f57d583df7f929ef197c2bbc0728ef31c3c700f2c08ec9dba516bd225b
DIST AusweisApp2-1.24.3.tar.gz 11482297 BLAKE2B 2bd1351e0406c11b23cbd5ad3e1304e5bc1cde7a54227bb5cdc628f3d3c66aba82a7f1dc44eb9c6b6552926c9e987e0f3bb040155c014dc52c79bbaf961bbe10 SHA512 af963288e255c1dd49bcfafeebf4b5523d585c46fd293a4d3a57d6cd35cffddaa98bff21225aa623506a581596f375d5e9ae446b52bf351e3dae0aa9db81bff8
+DIST AusweisApp2-1.24.4.tar.gz 11482381 BLAKE2B 26bb34bcefbe4dfce4b30300e71fdab61afa3a30c4b17dd5d90abc4f0cbaca062f7d91f0d49a082a3436a43b3a880f3771e879774f22e35963a905485c8e3c7e SHA512 672b1e7a4543824afa241430b6784eef38273f32436451270c84d02617044b727691e3e15aa2ac09a06d3286a36e81c54c205f706a3db6c5cfabc48cf0a52c30