summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-04-14 22:42:19 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-04-14 22:42:19 +0200
commita5c246154ca5890b1fa29c0b02d676f737ce0c82 (patch)
treebcf00b6db83a388962a78e6d9677df8b7f168d7a /sys-auth/AusweisApp2
parentdev-lua/luasec: add 1.1.0 (diff)
downloadgentoo-a5c246154ca5890b1fa29c0b02d676f737ce0c82.tar.gz
gentoo-a5c246154ca5890b1fa29c0b02d676f737ce0c82.tar.bz2
gentoo-a5c246154ca5890b1fa29c0b02d676f737ce0c82.zip
sys-auth/AusweisApp2: add 1.22.5
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-auth/AusweisApp2')
-rw-r--r--sys-auth/AusweisApp2/AusweisApp2-1.22.5.ebuild48
-rw-r--r--sys-auth/AusweisApp2/Manifest1
2 files changed, 49 insertions, 0 deletions
diff --git a/sys-auth/AusweisApp2/AusweisApp2-1.22.5.ebuild b/sys-auth/AusweisApp2/AusweisApp2-1.22.5.ebuild
new file mode 100644
index 000000000000..fd2f4d5730d0
--- /dev/null
+++ b/sys-auth/AusweisApp2/AusweisApp2-1.22.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Official authentication app for German ID cards and residence permits"
+HOMEPAGE="https://www.ausweisapp.bund.de/"
+SRC_URI="https://github.com/Governikus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EUPL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwebsockets:5[qml]
+ dev-qt/qtwidgets:5
+ net-libs/http-parser:0=
+ sys-apps/pcsc-lite
+ virtual/udev"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_SHARED_LIBS=OFF )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/sys-auth/AusweisApp2/Manifest b/sys-auth/AusweisApp2/Manifest
index 8f737eccdb84..c1383a92ee78 100644
--- a/sys-auth/AusweisApp2/Manifest
+++ b/sys-auth/AusweisApp2/Manifest
@@ -1 +1,2 @@
DIST AusweisApp2-1.22.4.tar.gz 10972798 BLAKE2B 7d613e9729a9c13fc56945bc432f2daf1a40fbc795829bbb51caaf4c895b3a4b2b8dc5528f68df0f0d60a3ec2d78cd72e767ec5430804da2a4759349fbf4d520 SHA512 88f66873cc1515ab068cfd48ab7f8477c17743cb3f9114a6a1484371d0faeb24492d1f6c0652800d3640cc9b5768568f578de5da1c43691347e32c1a34a49d12
+DIST AusweisApp2-1.22.5.tar.gz 11251263 BLAKE2B 8f62864d4e4139b06715765666fb7cc040d7cfc0c3cfb8082399ca24b2edbca754f511a4e7ab1eee6dd4fa3e8ea6cd38d048446877a6cff6ce37d7bddc56e01a SHA512 79cdd749d656aa9b082a80b9db9863bc11f4c5b8e06efefa2eb215724a45894137c5b6b8884d622e4a8203346e1b4d91b292013395a978e06a0201e40693a17d